Bug 873103 - Chinese input does not work after installation
Chinese input does not work after installation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
AcceptedNTH
: i18n
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-05 01:26 EST by lnie
Modified: 2013-01-05 02:49 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 16:47:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
i18n (19 bytes, application/octet-stream)
2012-11-07 01:13 EST, lnie
no flags Details
packaging.log (206.10 KB, text/x-log)
2012-11-07 01:14 EST, lnie
no flags Details
patch for gnome-settings-daemon (997 bytes, patch)
2012-12-20 08:22 EST, Rui Matos
no flags Details | Diff

  None (edit)
Description lnie 2012-11-05 01:26:55 EST
Description of problem:

I have a default install in Chinese successfully,however,after the reboot,I can not input Chinese though I choose the langage mode on the top-right corner from "en"to "zh".Then I have a default install in French,this time,the default support langage is "Bambara",terrible.
Version-Release number of selected component (if applicable):

f18 TC7 x86-64 
How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2012-11-06 09:54:42 EST
What does /etc/sysconfig/i18n say immediately after installation?  Also, please attach /var/log/anaconda/packaging.log to this bug report.
Comment 2 Jesse Keating 2012-11-06 16:14:17 EST
This may be fixed by the combo of bug 873865 and bug 868869
Comment 3 lnie 2012-11-07 01:13:33 EST
Created attachment 639836 [details]
i18n
Comment 4 lnie 2012-11-07 01:14:28 EST
Created attachment 639837 [details]
packaging.log
Comment 5 Chris Lumens 2012-11-07 10:20:48 EST
Jesse - yes, I think you are right.
Comment 6 Adam Williamson 2012-11-23 01:23:20 EST
lnie, can you re-test this with Beta RC1 and check whether it's fixed? Thanks!
Comment 7 lnie 2012-11-25 22:07:40 EST
(In reply to comment #6)
> lnie, can you re-test this with Beta RC1 and check whether it's fixed?
> Thanks!

Hi Adam, I  tested this again with Beta RC1(actually,I have tested it
3 times).the result is the same as the previous one.
Comment 8 Adam Williamson 2012-11-28 04:29:43 EST
Setting back to ASSIGNED, then.
Comment 9 Chris Lumens 2012-12-11 14:33:13 EST
So, is this bug report about langauges not being set up or input method packages not being installed?  I just did Chinese and French installs with a post-beta tree, and I see things translated as expected from anaconda, through grub, firstboot, and the gnome-shell crash dialog.
Comment 10 Adam Williamson 2012-12-12 00:51:28 EST
Chris: from the initial report, this looks to be about the post-install state:

"however,after the reboot,I can not input Chinese though I choose the langage mode on the top-right corner from "en"to "zh""

it may be that some packages that are needed to make CJK input work do not get installed. could even be related to the langpacks problem?
Comment 11 Chris Lumens 2012-12-12 10:02:43 EST
Perhaps, but I don't think we'll know until it gets re-tested by someone who knows to spot that things are wrong.
Comment 12 Adam Williamson 2012-12-12 17:47:14 EST
I could probably fake enough Japanese input knowledge to figure this one out if I really have to, but we'll see if someone better can do it first.
Comment 13 lnie 2012-12-12 23:35:07 EST
Actually,I am able to type Janpanese after a Janpanese install(f18 final TC1),
But I am unable to type Chinese after an Chinese install.though I am able to change "en" to"zh".I have to add"Chinese(Intelligent pinyin)"to the"input source"of"Region&Language"to type Chinese,even though I make a Chinese install.(the system language is Chinese, Activities:活动,Terminal:终端)
Comment 14 Chris Lumens 2012-12-13 10:26:56 EST
That doesn't really narrow down whether this is an anaconda problem or something else, though.  Do you have the correct input method packages installed?  To the best of my knowledge, there's nothing really that anaconda needs to do to set up a particular input method as the default, nor have we done so in the past.  I'm starting to think this is not an anaconda problem.
Comment 15 Adam Williamson 2012-12-13 18:41:10 EST
I can confirm at least one part of this bug: after installing smoke6 in French, I get keyboard layouts English and Bambara. This seems wrong. Not sure if these two are really the same bug, or something different.
Comment 16 lnie 2012-12-13 23:40:14 EST
(In reply to comment #14)
> To the best of my knowledge, there's nothing really that
> anaconda needs to do to set up a particular input method as the default, nor
> have we done so in the past.
Hi Chris,I have make f15 and f17 Chinese install before I report the bug,and after a reboot,I'm able to type Chinese without do anything.As for the Janpanese installtion ,the bug is fixed.I can type Janpanese after a reboot.
Comment 17 lnie 2012-12-13 23:46:51 EST
(In reply to comment #15)
> I can confirm at least one part of this bug: after installing smoke6 in
> French, I get keyboard layouts English and Bambara. This seems wrong. Not
> sure if these two are really the same bug, or something different.
Hi Adam,it seems that these two are the same bug,as I have a Janpanese install,the  keyboard layouts English and Bambara.But,this bug dosen't occur again in a Janpanese install of f18 Final TC1
Comment 18 Tao Wu 2012-12-14 04:54:04 EST
Accoding to lnie's description and my experience, I think the main input related packages has been installed, but it is not active by default. That's why it worked well after adding the input method to the "input source".
Comment 19 Vratislav Podzimek 2012-12-17 08:21:30 EST
(In reply to comment #15)
> I can confirm at least one part of this bug: after installing smoke6 in
> French, I get keyboard layouts English and Bambara. This seems wrong. Not
> sure if these two are really the same bug, or something different.
I have just installed a system with 'French' layout in the installation and in Gnome I got French, Bambara and English. But since configuration files look as expected (only 'fr' layout and console keymap listed), there is nothing more Anaconda could do. See bug #878433 for more info.

The support for input methods is something separate and I'm afraid anaconda can hardly guess which languages need input methods installed. Moreover it cannot configure this for a user that doesn't exist (during installation).
Comment 20 lnie 2012-12-19 03:01:52 EST
Still occur in f18 Final TC3 x86_64.
Comment 21 Rui Matos 2012-12-20 08:22:59 EST
Created attachment 666654 [details]
patch for gnome-settings-daemon

IIUC, the original bug is specific to the zh_CN locale and should be fixed with this patch.

For upstream we should have a better user experience in GNOME 3.8 with the initial-setup tool.
Comment 22 Fedora Update System 2012-12-20 14:54:25 EST
gnome-settings-daemon-3.6.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.6.3-2.fc18
Comment 23 Adam Williamson 2012-12-20 20:06:36 EST
Proposing as NTH, we should fix this.
Comment 24 Fedora Update System 2012-12-20 20:33:39 EST
Package gnome-settings-daemon-3.6.3-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-settings-daemon-3.6.3-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20738/gnome-settings-daemon-3.6.3-2.fc18
then log in and leave karma (feedback).
Comment 25 Adam Williamson 2012-12-21 16:40:40 EST
Discussed at 2012-12-21 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-21/f18final-blocker-review-7.2012-12-21-18.33.log.txt . Accepted as NTH for obvious reasons - this is v. significant for Chinese users, and can't be fixed with an update for DVD installs.
Comment 26 Fedora Update System 2013-01-02 16:47:28 EST
gnome-settings-daemon-3.6.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 lnie 2013-01-05 02:49:13 EST
 Tested it in the newly f18 final TC4 x86_64,this bug seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.