Bug 875621 - goa-daemon appears to leak timerfds
goa-daemon appears to leak timerfds
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:33c03e633cb5900c778e033935c...
:
: 872472 877922 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-12 03:30 EST by Vít Ondruch
Modified: 2013-11-07 11:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 21:30:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (2.22 KB, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: environ (1.03 KB, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: backtrace (67.94 KB, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: cgroup (131 bytes, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: executable (23 bytes, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: maps (217.56 KB, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: dso_list (11.17 KB, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: proc_pid_status (949 bytes, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: var_log_messages (988 bytes, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details
File: open_fds (52.50 KB, text/plain)
2012-11-12 03:30 EST, Vít Ondruch
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 691142 None None None Never

  None (edit)
Description Vít Ondruch 2012-11-12 03:30:25 EST
Version-Release number of selected component:
gnome-online-accounts-3.6.1-1.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/libexec/goa-daemon
crash_function: g_wakeup_new
kernel:         3.6.6-3.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 g_wakeup_new at gwakeup.c:163
: #3 g_cancellable_make_pollfd at gcancellable.c:406
: #4 socket_source_new at gsocket.c:3270
: #5 g_socket_create_source at gsocket.c:3335
: #6 _g_socket_read_with_control_messages at gdbusprivate.c:200
: #7 _g_dbus_worker_do_read_unlocked at gdbusprivate.c:860
: #8 _g_dbus_worker_do_read_cb at gdbusprivate.c:809
: #9 g_simple_async_result_complete at gsimpleasyncresult.c:775
: #10 complete_in_idle_cb at gsimpleasyncresult.c:787
: #15 gdbus_shared_thread_func at gdbusprivate.c:277
Comment 1 Vít Ondruch 2012-11-12 03:30:32 EST
Created attachment 643297 [details]
File: core_backtrace
Comment 2 Vít Ondruch 2012-11-12 03:30:34 EST
Created attachment 643298 [details]
File: environ
Comment 3 Vít Ondruch 2012-11-12 03:30:37 EST
Created attachment 643299 [details]
File: limits
Comment 4 Vít Ondruch 2012-11-12 03:30:39 EST
Created attachment 643300 [details]
File: backtrace
Comment 5 Vít Ondruch 2012-11-12 03:30:42 EST
Created attachment 643301 [details]
File: cgroup
Comment 6 Vít Ondruch 2012-11-12 03:30:44 EST
Created attachment 643302 [details]
File: executable
Comment 7 Vít Ondruch 2012-11-12 03:30:47 EST
Created attachment 643303 [details]
File: maps
Comment 8 Vít Ondruch 2012-11-12 03:30:49 EST
Created attachment 643304 [details]
File: dso_list
Comment 9 Vít Ondruch 2012-11-12 03:30:51 EST
Created attachment 643305 [details]
File: proc_pid_status
Comment 10 Vít Ondruch 2012-11-12 03:30:54 EST
Created attachment 643306 [details]
File: var_log_messages
Comment 11 Vít Ondruch 2012-11-12 03:30:56 EST
Created attachment 643307 [details]
File: open_fds
Comment 12 Jakub Hrozek 2012-11-19 04:07:04 EST
Resumed a laptop from sleep

backtrace_rating: 4
Package: gnome-online-accounts-3.6.2-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Matthias Clasen 2013-01-04 13:10:35 EST
filed upstream as: https://bugzilla.gnome.org/show_bug.cgi?id=691142
Comment 14 Fedora Update System 2013-01-08 12:11:52 EST
gnome-online-accounts-3.6.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-online-accounts-3.6.2-2.fc18
Comment 15 Debarshi Ray 2013-01-08 12:25:21 EST
*** Bug 872472 has been marked as a duplicate of this bug. ***
Comment 16 Debarshi Ray 2013-01-08 12:26:22 EST
*** Bug 877922 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2013-01-09 17:50:49 EST
Package gnome-online-accounts-3.6.2-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-online-accounts-3.6.2-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0511/gnome-online-accounts-3.6.2-2.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-01-14 21:30:26 EST
gnome-online-accounts-3.6.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.