Bug 87742 - (IDE SERVERWORKS)RedHat 9 device driver for CD drive has boot error on Compaq ProLiant DL360
(IDE SERVERWORKS)RedHat 9 device driver for CD drive has boot error on Compaq...
Status: CLOSED DUPLICATE of bug 71499
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
: 90227 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-01 17:33 EST by Blair Zajac
Modified: 2007-04-18 12:52 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (12.94 KB, text/plain)
2003-04-01 17:35 EST, Blair Zajac
no flags Details

  None (edit)
Description Blair Zajac 2003-04-01 17:33:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Description of problem:
We have a Compaq ProLiant DL360 with 1 Gbyte of RAM.  Booting the system
off of the RedHat 8.0 ISO #1 works fine all the way for anaconda to
mount the ISO and install the OS from the CD.

Trying to install RedHat 8.0.94 or RedHat 9 has the system boot of the
CD fine, but when the installer goes to mount the CD, it fails, and
the installer asks for an alternate location of the OS.  I was able
to install RedHat using a NFS image.

Now booting the final OS gets this error:

hda: CRN-8245B, ATAPI CD/DVD-ROM drive
hda: set_drive_speed_status: status=0x01 { Error }
hda: set_drive_speed_status: error=0x04

The CD-ROM can't be mounted or anything.

Blar


Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to RedHat 9 on a system with a CRN-8245B drive.
2. Try to mount a CD-ROM, can't.
3.

Actual Results:  Cannot mount any CDs.


Expected Results:  Should be able to mount a CD.


Additional info:

hda: CRN-8245B, ATAPI CD/DVD-ROM drive
hda: set_drive_speed_status: status=0x01 { Error }
hda: set_drive_speed_status: error=0x04
Comment 1 Blair Zajac 2003-04-01 17:35:33 EST
Created attachment 90818 [details]
dmesg output
Comment 2 Ben Klang 2003-04-03 13:40:41 EST
I am encountering a similar problem with an HP DL360G3 (DL-360-G3) box.  I was 
able to successfully boot and install from CD using RedHat 8, but with the new 
RedHat 9 (same server), I am only able to boot.  Once booted in to RH9, I get a 
dialog asking me for the language, keyboard, and install media.  When selecting 
CDROM ( the same CDROM I just booted from) it fails.  It gives me messages about 
not being able to mount CD-ROM, invalid media, and bad return codes when 
probing UnitReady sense codes.  I have verified the MD5 checksum in two different 
machines.  The RedHat 8 disc and the RedHat 9 disc are both burned to a CDR 
from the same package.  Both MD5 sums work correctly in both checksumming 
machines. 
Comment 3 Shane Witbeck 2003-04-06 21:01:39 EDT
I am having a similar issue with a Dell PowerEdge 1650. I have noticed the same
errors while trying to install rh 9. I have installed rh 9 on another desktop
machine using the same ISO's on the same CD's and performed the mediacheck
option prior. I am able to boot from rh 9 disk 1 and after I choose CD-ROM for
the location of the install files it does not go any further. The CD-ROM in
question is a TEAC CD-224E. 
Comment 4 Arjan van de Ven 2003-04-07 04:53:44 EDT
PowerEdge 1650 is a different and known issue and greatly depends on the bios
version (A07 seems to work ok, later ones do not)
Comment 5 redhat admin 2003-04-18 06:42:43 EDT
I have a Proliant 1600 and I can boot but the install hangs *after* the media
check screen. I tried in both gui and text. I even tried booting with noprobe to
see if that helped. I have only tried RH9.0. Will try 8.0 tonight.
Comment 6 davidl 2003-05-05 14:17:05 EDT
I have a Proliant ML370 G2 with a similar problem - runs 8.0 fine but fails
on the 9.0 cd 1 image. I know the image is good as it installs correctly on
another machine. From Alt F4 while testing the cd-image(which fails) I
get :
hda : command error : status=0x51 {DriveReady Seekcomplete Error}
hda : command error: error=0x54
end_request : I/O error, dev 03:00(hda) sector 1306624.

 
Comment 7 Jose DeLeon 2003-05-11 23:59:01 EDT
Same problem.
Comment 8 Michael Fulbright 2003-05-13 12:42:53 EDT
This error indicates the CD is bad.  The mediacheck will sometimes pass on
marginal CDs that fail during installation.

*** This bug has been marked as a duplicate of 75008 ***
Comment 9 Blair Zajac 2003-05-13 13:12:25 EDT
I wasn't too clear about this, but, this is not a bad CD-ROM.

After performing a clean install of RedHat 9 from NFS mounted CD-ROM images,
everytime I boot the system normally from the hard disk I see this message in 
dmesg:

hda: CRN-8245B, ATAPI CD/DVD-ROM drive
hda: set_drive_speed_status: status=0x01 { Error }
hda: set_drive_speed_status: error=0x04

So it's not a bad CD-ROM, rather a device driver.

Best,
Blair
Comment 10 Clark Tompsett 2003-05-23 11:45:04 EDT
This bug also affects Compaq Presario 900 laptops.
Comment 11 Michael Fulbright 2003-05-27 14:49:28 EDT
*** Bug 90227 has been marked as a duplicate of this bug. ***
Comment 12 ville.sulko 2003-06-02 07:10:20 EDT
Same here. RedHat 9 install fails to recognize cd#1 as valid installation 
media. HW Compaq DL380... Seems pretty much like a driver bug to me... Any 
workarounds? I could easily install over network, but I wan't to try out LVM, 
and it's not possible to create logical volumes using text-mode installer (or 
is it?)...
Comment 13 E Blaufuss 2003-06-06 13:40:48 EDT
We've got two Compaq ML 350s, both had the same problem with CD installs,
the media has been checked and used to sucessfully install on other machine.
An HTTP install worked, but CD remains unusable...
Is there any resolution or workaround to this problem?
Comment 14 zak 2003-06-09 01:22:36 EDT
*** Bug 92162 has been marked as a duplicate of this bug. ***
Comment 15 zak 2003-06-09 01:27:43 EDT
Me too - Compaq ML 350. 

Also, although the issue clearly stems from a problem in the installer kernel
somewhere I think this bug is more appropriate in the installer section instead
of kernel. Is it possible to assign to installation, installer, anaconda and kernel>

This has to be a major boo-boo and I'm surprised that this bugzilla entry as not
had significantly more activity, especially from the RedHat folks.

Ciao
Comment 16 Arjan van de Ven 2003-06-09 03:08:53 EDT
tell me how I can replace the kernels on your cds and it might become
interesting to fix it. The current erratum kernel has the bug fixed but that
doesn't mean the kernel on the cd is fixed as well :(
Comment 17 Alan Cox 2003-06-09 09:55:24 EDT
Presario 900 is unrelated (search bugzilla for the keyword (RADEON IGP) for more
info on that
Dell 1650 with newer BIOS is fixed in main tree now and was a kernel issue
Compaq DL360 seems more complex but use "ide=nodma".

Comment 18 Alan Cox 2003-06-09 10:21:54 EDT

*** This bug has been marked as a duplicate of 71499 ***
Comment 19 zak 2003-06-10 07:17:07 EDT
Arjan,

Obviously you are not going to be able to fix the kernel on my cds or on the
thousands out there. However a boot image which would allow you to boot off the
floppy and then still use the cds for a source of RPMs to install surely is not
that far-fetched an idea? 

Further, it seems that I was mistaken in marking 92162 as a dup of this bug. I
fixed that now.
Comment 20 Arjan van de Ven 2003-06-10 07:22:30 EDT
the problem is that only a small part of the kernel will go on such floppy, for
the rest kernel modules from the cd are used.... which aren't updatable 
Comment 21 Dave Brown 2003-06-23 00:41:10 EDT
Firstly, can someone please reopen this bug. It has been marked Resolved - 
Duplicate but i've searched through all the duplicates in this bug and none of 
them fix the problem (most relate to bad installation media - which has been 
ruled out in the case of this bug).

How not updateable are we talking here? Ie not gonna be fixed until new CDs are 
done? or can it be worked around by providing updated bootdisk.img and other 
files for users to merge into their existing disks and then burn?

I'm going to try stuffing around with the CD boot system and see if i can get 
it working as we REALLY need to have this in our environment. Any help 
appreciated - i'll post my findings (if any constructive come out of it).
Comment 22 Mark Whitehouse 2003-06-23 14:35:08 EDT
We have a similar issue with a Compaq DL380.  We have made a custom 9.0 boot CD
with the latest kernel 2.4.20-18.9 but are still unable to install 9.0 from this
CD.  So, from my perspective the issue is: how do I create a custom 9.0 CD which
will work with the Compaq DL380?
Comment 23 Paascal Boulch 2004-03-03 05:23:48 EST
Here is a workaround regarding this problem by creating a boot floppy

http://www.cpqlinux.com/wget-ftp-index.html

Tested on Compaq ML370 with Redhat 9

Comment 24 Red Hat Bugzilla 2006-02-21 13:52:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.