Bug 879727 - [abrt] fritzing-0.7.5b-2.fc18: QStatusBar::messageChanged: Process /usr/bin/Fritzing was killed by signal 11 (SIGSEGV)
[abrt] fritzing-0.7.5b-2.fc18: QStatusBar::messageChanged: Process /usr/bin/F...
Status: CLOSED DUPLICATE of bug 852568
Product: Fedora
Classification: Fedora
Component: fritzing (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ed Marshall
Fedora Extras Quality Assurance
abrt_hash:cbd762d2382051cb399c2d29399...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-23 17:34 EST by Niki Guldbrand
Modified: 2013-01-07 19:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 19:36:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (156.67 KB, text/plain)
2012-11-23 17:34 EST, Niki Guldbrand
no flags Details
File: environ (1.53 KB, text/plain)
2012-11-23 17:34 EST, Niki Guldbrand
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-23 17:34 EST, Niki Guldbrand
no flags Details
File: backtrace (823.46 KB, text/plain)
2012-11-23 17:34 EST, Niki Guldbrand
no flags Details
File: cgroup (127 bytes, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details
File: smolt_data (3.04 KB, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details
File: executable (17 bytes, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details
File: maps (91.34 KB, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details
File: dso_list (18.52 KB, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details
File: proc_pid_status (927 bytes, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details
File: var_log_messages (312 bytes, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details
File: open_fds (820 bytes, text/plain)
2012-11-23 17:35 EST, Niki Guldbrand
no flags Details

  None (edit)
Description Niki Guldbrand 2012-11-23 17:34:01 EST
Description of problem:
It seems that it crashes when the mose enters the app window, and the coordinates starts updating at the bottom of the window

Version-Release number of selected component:
fritzing-0.7.5b-2.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        Fritzing
crash_function: QStatusBar::messageChanged
kernel:         3.6.6-3.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 QStatusBar::messageChanged at .moc/release-shared/moc_qstatusbar.cpp:145
: #1 QStatusBar::hideOrShow at widgets/qstatusbar.cpp:696
: #2 QMetaObject::activate at kernel/qobject.cpp:3547
: #3 QStatusBar::messageChanged at .moc/release-shared/moc_qstatusbar.cpp:145
: #4 QStatusBar::hideOrShow at widgets/qstatusbar.cpp:696
: #5 QMetaObject::activate at kernel/qobject.cpp:3547
: #6 QStatusBar::messageChanged at .moc/release-shared/moc_qstatusbar.cpp:145
: #7 QStatusBar::hideOrShow at widgets/qstatusbar.cpp:696
: #8 QMetaObject::activate at kernel/qobject.cpp:3547
: #9 QStatusBar::messageChanged at .moc/release-shared/moc_qstatusbar.cpp:145
Comment 1 Niki Guldbrand 2012-11-23 17:34:11 EST
Created attachment 650690 [details]
File: core_backtrace
Comment 2 Niki Guldbrand 2012-11-23 17:34:13 EST
Created attachment 650691 [details]
File: environ
Comment 3 Niki Guldbrand 2012-11-23 17:34:15 EST
Created attachment 650692 [details]
File: limits
Comment 4 Niki Guldbrand 2012-11-23 17:34:58 EST
Created attachment 650693 [details]
File: backtrace
Comment 5 Niki Guldbrand 2012-11-23 17:35:00 EST
Created attachment 650694 [details]
File: cgroup
Comment 6 Niki Guldbrand 2012-11-23 17:35:02 EST
Created attachment 650695 [details]
File: smolt_data
Comment 7 Niki Guldbrand 2012-11-23 17:35:04 EST
Created attachment 650696 [details]
File: executable
Comment 8 Niki Guldbrand 2012-11-23 17:35:10 EST
Created attachment 650697 [details]
File: maps
Comment 9 Niki Guldbrand 2012-11-23 17:35:13 EST
Created attachment 650698 [details]
File: dso_list
Comment 10 Niki Guldbrand 2012-11-23 17:35:15 EST
Created attachment 650699 [details]
File: proc_pid_status
Comment 11 Niki Guldbrand 2012-11-23 17:35:17 EST
Created attachment 650700 [details]
File: var_log_messages
Comment 12 Niki Guldbrand 2012-11-23 17:35:20 EST
Created attachment 650701 [details]
File: open_fds
Comment 13 Rob Riggs 2013-01-03 22:04:29 EST
This affects F17 as well.  The problem seems to be due to incompatibilities with versions of QT newer than 4.8.2.

http://fritzing.org/forum/thread/1133/?page=all

This is apparently fixed in the current version of Fritzing.

There appear to be a few dupes of this bug filed.
Comment 14 Ed Marshall 2013-01-07 19:36:54 EST

*** This bug has been marked as a duplicate of bug 852568 ***

Note You need to log in before you can comment on or make changes to this bug.