Bug 880781 - virt-manager-0.9.4-3.fc18 consistently looses connection during "Locate ISO media volume" portion of KVM VM creation
virt-manager-0.9.4-3.fc18 consistently looses connection during "Locate ISO m...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 901788 901938 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 14:24 EST by Scott Dowdle
Modified: 2013-04-09 21:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-09 21:28:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2012-11-27 14:24:25 EST
Description of problem:
virt-manager stalls for a minute or so after clicking on the "Browse" button (and then "Browse Local") of the "Use ISO Image" portion of VM creation.  The following message appears in /var/log/messages:

Nov 27 10:33:20 scott libvirtd[27857]: 2012-11-27 17:33:20.114+0000: 27857: warning : virKeepAliveTimerInternal:156 : No response from client 0x2376eb0 after 5 keepalive messages in 30 seconds

When the file selector dialog finally appears and an iso file is selected, virt-manager has lost its connection and the install process fails.  This may be specific to KDE as I haven't tried it in any other desktop environment yet.  I will hopefully test this some additional systems and additional desktop environments.

Version-Release number of selected component (if applicable):
virt-manager-0.9.4-3.fc18
libvirt-0.10.2.1-3.fc18.x86_64

How reproducible:
Try to create a VM on localhost and try to select an iso to install from (again from localhost as no remote storage is needed to trigger this) and it will time out and disconnect.

Steps to Reproduce:
1. Start VM creation process
2. Attempt to pick an iso to install from
3. It will stall and get disconnected ending in creation failure.
  
Actual results:
Can't create a VM

Expected results:
I should be able to select an iso and create a VM.

Additional info:
Comment 1 Scott Dowdle 2012-11-27 14:27:02 EST
Just wanted to mention that I did do a number of updates since I originally noticed the bug... and have rebooted since... and the bug is still there... so it isn't the result of a transient system condition... caused by such things as package upgrades... or manual monkeying with services.
Comment 2 Scott Dowdle 2012-11-27 14:49:27 EST
After some additional testing... yes it appears to be specific to KDE... or at least the problem is not observed in GNOME 3 Shell.  Then I switched back to KDE and observed the bug again.
Comment 3 Cole Robinson 2012-12-17 10:32:10 EST
Strange, I can't reproduce on gnome or kde. Can you reproduce when running virt-manager --debug and attach the output here?

Also, what's the output of:

sudo virsh pool-list --all
Comment 4 Scott Dowdle 2012-12-17 14:21:36 EST
Sorry.  I'm out of town and won't be able to try it until after Xmas.
Comment 5 Cole Robinson 2012-12-18 16:44:33 EST
No problem Scott, I'll just set needinfo again, please unset when you reproduce. Thanks
Comment 6 Scott Dowdle 2012-12-27 15:10:37 EST
Ok, made it back home... and got fully updated.  I was still able to duplicate the problem.  Then I tried it with the --debug flag... and with that enabled, the problem doesn't happen.  Without the --debug flag, I still get the problem.  I have no idea why that would be.  Because there is no error with --debug, I didn't include the output.  I'm make a short video showing I'm having the issue and that it goes away with --debug.

Here's the output from virsh pool-list --all:

[root@scott ~]# virsh pool-list --all
Name                 State      Autostart 
-----------------------------------------
default              active     yes
Comment 7 Scott Dowdle 2012-12-27 15:47:52 EST
Here's a video showing that I have the problem without --debug but don't have it with --debug:

http://www.montanalinux.org/files/newvideos/virt-manager-bug-880781.webm

If you have a problem playing that in your browser, just wget it and play it with your preferred video player.
Comment 8 Cole Robinson 2013-01-06 13:21:49 EST
Thanks for the video Scott, it was helpful. I think I fixed this:

http://git.fedorahosted.org/cgit/virt-manager.git/commit/?id=da71b2ec5c08707788d9caaf30318a191c5600f1

virt-manager by default forks off like a daemon. This is the only way to get ssh to launch an askpass dialog, which is important for remote server access. Unfortunately this causes issues with dbus related stuff from time to time.

We were altering the default gtk icon_theme before forking which was the root 'cause'. My guess is that this causes some internal gtk dbus state to be initialized which is then no longer valid after the fork. If you make it so virt-manager doesn't drop stdio but still forks, you can see bunch of dbus timeouts go by.

--debug wasn't reproducing this because --debug doesn't fork, so that we see the debug output on stdout. I always use debug hence why I wasn't seeing it.
Comment 9 Cole Robinson 2013-01-24 16:03:17 EST
*** Bug 901788 has been marked as a duplicate of this bug. ***
Comment 10 Cole Robinson 2013-01-24 17:21:31 EST
*** Bug 901938 has been marked as a duplicate of this bug. ***
Comment 11 Scott Dowdle 2013-03-01 12:26:04 EST
Just to let you know the behavior is back.  I thought you had fixed it... but I guess the bug has creeped back in.
Comment 12 Cole Robinson 2013-03-01 15:58:04 EST
It's fixed upstream, I still haven't pushed it to Fedora yet. I'd figured I'd have a new upstream release out by now but that hasn't happened yet...
Comment 13 Scott Dowdle 2013-03-29 13:56:30 EDT
Is there a testing build available?  I'm getting somewhat frustrated with the inability to use KVM (the way I like to with virt-manager) on a KDE desktop.  I certainly know you are busy and do a lot of work... but I'd appreciate any effort you can muster for an updated package.
Comment 14 Fedora Update System 2013-04-01 08:53:35 EDT
virt-manager-0.9.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/virt-manager-0.9.5-1.fc18
Comment 15 Fedora Update System 2013-04-01 18:28:59 EDT
Package virt-manager-0.9.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4629/virt-manager-0.9.5-1.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-04-09 21:28:32 EDT
virt-manager-0.9.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.