Bug 88198 - Query (Root Password dialogue) Cancel Button gives unknown exit code
Query (Root Password dialogue) Cancel Button gives unknown exit code
Status: CLOSED DUPLICATE of bug 75384
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-07 12:45 EDT by Josh Douglas
Modified: 2006-02-21 13:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Douglas 2003-04-07 12:45:55 EDT
Description of problem:

     In Gnome, the "Query" dialogue which comes up when running something from
the System Settings menu that needs root privleges like "Display" (or any of the
other 'redhat-config' utilities) has two buttons, one for "Okay" (if the
password has been entered), the other for "Cancel".  If the "Cancel" button is
clicked, an "Error" dialogue will pop up diplaying the text "Unknown exit code.".

Version-Release number of selected component (if applicable):

How reproducible:

     Click cancel when asked for the root password.

Steps to Reproduce:
1.  In Gnome, click on the Red Hat menu icon.
2.  Select the "System Settings" sub menu.
3.  Select "Display" or anything else that requires root access.
4.  Click the  "Cancel" button instead of entering the password.
    
Actual results:

     An Error box will pop up with an "Okay" button and the text "Unknown exit
code."

Expected results:

     Originally thought when clicking the "Cancel" button, the Query dialogue
would close with no other input.

Additional info:
     
     Not sure as to what else affects this, like if the Query dialogue is just
one dialogue for all utilities that require root or if each utility has it's own
Query dialogue.  I've tried it on redhat-config-xfree86, redhat-config-users,
redhat-config-samba, and redhat-config-date.
Comment 1 Matthew Miller 2003-05-03 17:36:15 EDT
This is basically a dup of bug #75834, although this one shows the exact correct
error present in Red Hat Linux 9 ("Unknown exit code."). This was introduced
sometime between usermode 1.65 in the third public beta and 1.67 in the release.
Comment 2 Matthew Miller 2003-05-07 23:10:52 EDT
The error-on-cancel problem appears fixed in usermode 1.68 in rawhide.
Comment 3 Brent Fox 2003-06-03 14:58:20 EDT

*** This bug has been marked as a duplicate of 75384 ***
Comment 4 Barry K. Nathan 2003-09-04 22:19:20 EDT
I think this should be marked as a dupe of 75834, not 75384! :)
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.