Bug 75834 - Preferences->Password Change (cosmetic) error message
Preferences->Password Change (cosmetic) error message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
: 72719 79737 80925 90456 92184 102865 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-13 11:14 EDT by Mark Cooke
Modified: 2013-07-02 18:57 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 21:58:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2002-10-13 11:14:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Cancelling the gui password change box produces an 'Unknown Error' message popup.

A cosmetic annoyance.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open RedHat->Preferences->Password 
2.Click cancel / close window button

Actual Results:  Password dialog appears, vanishes, then an error dialog pops up
after cancelling.

Expected Results:  Error dialog should not be presented to the user.

Additional info:
Comment 1 David Balažic 2002-11-21 19:37:40 EST
I noticed something similar.
"Preferences"->"Password" , don't enter anything, click "Cancel" :
The dialog disappears and reappears. Click "Cancel" again, the same thing 
happens. Click for the third time , then it finally goes away.
Not error dialog is displayed. I think I did this as root, not sure though.
Comment 2 Marius Andreiana 2003-01-24 06:08:42 EST
bug 75834 says pressing OK without a password gives the same error message.

I couldn't replicate the behaviour described in comment #1.
Comment 3 Toni Willberg 2003-01-24 06:27:05 EST
See also #79737 (duplicate of this)
Comment 4 Daniel Resare 2003-01-24 06:56:00 EST
*** Bug 80925 has been marked as a duplicate of this bug. ***
Comment 5 Matthew Miller 2003-04-16 11:57:45 EDT
This is present in Red Hat Linux 9, starting in usermode 1.67. It didn't happen
in the 1.65 version from phoebe beta 3. I don't think there was a publically
available 1.66 version, and have no idea if it worked there or not. :)
Should the Version for this bug be updated?

More precisely, with usermode 1.65, you get a "The password you typed is
invalid. Please try again", which is also not really correct for having clicked
cancel.

If you press OK without entering a password, it tries to authenticate using a
blank password. This is probably actually correct.

Also, it's not merely the password change applet -- it's anything usermode is
used for.
Comment 6 Matthew Miller 2003-05-06 22:16:05 EDT
The error-on-cancel problem appears fixed in usermode 1.68 in rawhide.
Comment 7 Toni Willberg 2003-05-28 08:26:38 EDT
*** Bug 79737 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2003-06-03 14:59:20 EDT
*** Bug 92184 has been marked as a duplicate of this bug. ***
Comment 9 Mattias Dahlberg 2003-10-18 05:10:19 EDT
Yes, it seems to be fixed. I can't reproduce in Fedora Core.
Comment 10 Miloslav Trmac 2004-02-07 12:24:45 EST
*** Bug 72719 has been marked as a duplicate of this bug. ***
Comment 11 Miloslav Trmac 2004-02-07 12:26:26 EST
*** Bug 90456 has been marked as a duplicate of this bug. ***
Comment 12 Matthew Miller 2004-04-06 23:22:20 EDT
*** Bug 102865 has been marked as a duplicate of this bug. ***
Comment 13 Matthew Miller 2004-10-12 21:58:12 EDT
unless someone objects, i'm closing this -- it works in FC2 no problem.

Note You need to log in before you can comment on or make changes to this bug.