Bug 885349 - (ghc-wai-logger) Review Request: ghc-wai-logger - A logging system for WAI
Review Request: ghc-wai-logger - A logging system for WAI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
Ready
:
Depends On: ghc-date-cache 892581 ghc-byteorder
Blocks: Haskell-pkg-reviews 832656
  Show dependency treegraph
 
Reported: 2012-12-08 14:46 EST by Ben Boeckel
Modified: 2013-03-12 19:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-08 18:52:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
petersen: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2012-12-08 14:46:00 EST
Spec URL: http://benboeckel.net/packaging/ghc-wai-logger/ghc-wai-logger.spec
SRPM URL: http://benboeckel.net/packaging/ghc-wai-logger/ghc-wai-logger-0.3.0-1.fc19.src.rpm
Description:
A logging system for WAI

Fedora Account System Username: mathstuf
Comment 1 Kevin Fenzi 2012-12-27 21:52:05 EST
Anything I can do to move these along?	

Lakshmi: I'm happy to review if you are busy...
Comment 2 Narasimhan 2012-12-28 00:37:52 EST
Kevin,
I am unable to access the spec file and srpm. I mentioned this to Ben in bug 885348.
Comment 3 Narasimhan 2013-01-12 00:30:59 EST
@Ben,
This package requires byte-order.
Comment 4 Jens Petersen 2013-02-06 03:30:23 EST
I am taking over the review for Narasimhan.

Will start once ghc-byteorder is in rawhide.
Comment 5 Jens Petersen 2013-02-12 01:40:20 EST
Ok dependencies are now all in Rawhide.

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated

===== MUST items =====

C/C++:
[x]: Package does not contain any libtool archives (.la)
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.
     Note: Unversioned so-files in private %_libdir subdirectory (see
     attachment). Verify they are not in ld path.

[!]: Static libraries in -static subpackage, if present.
     Note: ghc-wai-logger-devel-0.3.0-1.fc19.x86_64.rpm : /usr/lib64/ghc-7.4.2
     /wai-logger-0.3.0/libHSwai-logger-0.3.0.a ghc-wai-logger-
     devel-0.3.0-1.fc19.x86_64.rpm : /usr/lib64/ghc-7.4.2/wai-logger-0.3.0
     /libHSwai-logger-0.3.0_p.a

Waived:

see https://fedoraproject.org/wiki/Packaging:Haskell?rd=Packaging/Haskell#Static_vs._Dynamic_Linking
and https://fedoraproject.org/wiki/PackagingDrafts/Haskell#Shared_and_static_library_linking

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package contains no bundled libraries.

[x]: Changelog in prescribed format.

But would be good to fix rpmlint warning about no version

[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Sources contain only permissible code or content.
[-]: Each %files section contains %defattr if rpm < 4.4
[-]: Macros in Summary, %description expandable at SRPM build time.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package complies to the Packaging Guidelines
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.

[!]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.

fedora-review bug?  LICENSE file is clearly present and correct.

[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named using only allowed ASCII characters.
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: Package do not use a name that already exist
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package installs properly.
[x]: Package is not relocatable.
[x]: Requires correct, justified where necessary.
[x]: CheckResultdir
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file is legible and written in American English.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: Package contains systemd file(s) if in need.
[x]: File names are valid UTF-8.
[-]: Useful -debuginfo package or justification otherwise.

https://fedoraproject.org/wiki/Packaging:Haskell?rd=Packaging/Haskell#Debug_Information

[-]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 143360 bytes in 23 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX tarball generation or download is documented.
[!]: SourceX / PatchY prefixed with %{name}.
     Note: Source0 (wai-logger-0.3.0.tar.gz)

Fedora uses ghc- prefix for Haskell libraries.

[x]: SourceX is a working URL.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[?]: Packages should try to preserve timestamps of original installed files.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: ghc-wai-logger-0.3.0-1.fc19.x86_64.rpm
          ghc-wai-logger-0.3.0-1.fc19.src.rpm
          ghc-wai-logger-devel-0.3.0-1.fc19.x86_64.rpm
ghc-wai-logger.x86_64: W: no-version-in-last-changelog
ghc-wai-logger.src: W: no-version-in-last-changelog
ghc-wai-logger.src: W: strange-permission wai-logger-0.3.0.tar.gz 0640L
ghc-wai-logger.src: W: strange-permission ghc-wai-logger.spec 0640L
ghc-wai-logger-devel.x86_64: W: no-version-in-last-changelog
3 packages and 0 specfiles checked; 0 errors, 5 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint ghc-wai-logger ghc-wai-logger-devel
ghc-wai-logger.x86_64: W: no-version-in-last-changelog
ghc-wai-logger-devel.x86_64: W: no-version-in-last-changelog
2 packages and 0 specfiles checked; 0 errors, 2 warnings.
# echo 'rpmlint-done:'



Requires
--------
ghc-wai-logger-0.3.0-1.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    
    ghc(base-4.5.1.0-6e4c9bdc36eeb9121f27ccbbcb62e3f3)
    ghc(blaze-builder-0.3.1.0-316b0e68f80ee32ff786c8cf5345f501)
    ghc(byteorder-1.0.3-1911ade9e85813fca1b9d820cc27734e)
    ghc(bytestring-0.9.2.1-503e91bb155301fdb1956cb5c26ce6e9)
    ghc(case-insensitive-0.4.0.3-2e1950bbd06bb002e45affc090ce10da)
    ghc(date-cache-0.3.0-86518e3c1346869eaba0aa79b2f3e7f3)
    ghc(fast-logger-0.3.1-6134d633df28913ee75a1d4dbb9305e4)
    ghc(http-types-0.7.3.0.1-58237e97c8645fca8a174e7253be8120)
    ghc(network-2.3.1.0-efa1c7220c576804829351b700849052)
    ghc(wai-1.3.0.1-301777701df2228bc6e660cfbd7cdbf1)
    libHSarray-0.4.0.0-ghc7.4.2.so()(64bit)
    libHSbase-4.5.1.0-ghc7.4.2.so()(64bit)
    libHSbase-unicode-symbols-0.2.2.4-ghc7.4.2.so()(64bit)
    libHSblaze-builder-0.3.1.0-ghc7.4.2.so()(64bit)
    libHSbyteorder-1.0.3-ghc7.4.2.so()(64bit)
    libHSbytestring-0.9.2.1-ghc7.4.2.so()(64bit)
    libHScase-insensitive-0.4.0.3-ghc7.4.2.so()(64bit)
    libHSconduit-0.5.2.7-ghc7.4.2.so()(64bit)
    libHScontainers-0.4.2.1-ghc7.4.2.so()(64bit)
    libHSdate-cache-0.3.0-ghc7.4.2.so()(64bit)
    libHSdeepseq-1.3.0.0-ghc7.4.2.so()(64bit)
    libHSdirectory-1.1.0.2-ghc7.4.2.so()(64bit)
    libHSfast-logger-0.3.1-ghc7.4.2.so()(64bit)
    libHSfilepath-1.3.0.0-ghc7.4.2.so()(64bit)
    libHSghc-prim-0.2.0.0-ghc7.4.2.so()(64bit)
    libHShashable-1.1.2.5-ghc7.4.2.so()(64bit)
    libHShttp-types-0.7.3.0.1-ghc7.4.2.so()(64bit)
    libHSinteger-gmp-0.4.0.0-ghc7.4.2.so()(64bit)
    libHSlifted-base-0.1.2-ghc7.4.2.so()(64bit)
    libHSmonad-control-0.3.1.4-ghc7.4.2.so()(64bit)
    libHSmtl-2.1.2-ghc7.4.2.so()(64bit)
    libHSnetwork-2.3.1.0-ghc7.4.2.so()(64bit)
    libHSold-locale-1.0.0.4-ghc7.4.2.so()(64bit)
    libHSold-time-1.1.0.0-ghc7.4.2.so()(64bit)
    libHSparsec-3.1.3-ghc7.4.2.so()(64bit)
    libHSresourcet-0.4.0.2-ghc7.4.2.so()(64bit)
    libHSsemigroups-0.8.4.1-ghc7.4.2.so()(64bit)
    libHStext-0.11.2.3-ghc7.4.2.so()(64bit)
    libHStime-1.4-ghc7.4.2.so()(64bit)
    libHStransformers-0.3.0.0-ghc7.4.2.so()(64bit)
    libHStransformers-base-0.4.1-ghc7.4.2.so()(64bit)
    libHSunix-2.5.1.1-ghc7.4.2.so()(64bit)
    libHSunordered-containers-0.2.2.1-ghc7.4.2.so()(64bit)
    libHSvault-0.2.0.1-ghc7.4.2.so()(64bit)
    libHSvoid-0.5.8-ghc7.4.2.so()(64bit)
    libHSwai-1.3.0.1-ghc7.4.2.so()(64bit)
    libc.so.6()(64bit)
    libdl.so.2()(64bit)
    libgmp.so.10()(64bit)
    libpthread.so.0()(64bit)
    librt.so.1()(64bit)
    libutil.so.1()(64bit)
    rtld(GNU_HASH)

ghc-wai-logger-devel-0.3.0-1.fc19.x86_64.rpm (rpmlib, GLIBC filtered):
    
    /bin/sh
    ghc(wai-logger-0.3.0-a0eadb049a07f383c80b6c7ff2ad4873)
    ghc-compiler = 7.4.2
    ghc-devel(base-4.5.1.0-6e4c9bdc36eeb9121f27ccbbcb62e3f3)
    ghc-devel(blaze-builder-0.3.1.0-316b0e68f80ee32ff786c8cf5345f501)
    ghc-devel(byteorder-1.0.3-1911ade9e85813fca1b9d820cc27734e)
    ghc-devel(bytestring-0.9.2.1-503e91bb155301fdb1956cb5c26ce6e9)
    ghc-devel(case-insensitive-0.4.0.3-2e1950bbd06bb002e45affc090ce10da)
    ghc-devel(date-cache-0.3.0-86518e3c1346869eaba0aa79b2f3e7f3)
    ghc-devel(fast-logger-0.3.1-6134d633df28913ee75a1d4dbb9305e4)
    ghc-devel(http-types-0.7.3.0.1-58237e97c8645fca8a174e7253be8120)
    ghc-devel(network-2.3.1.0-efa1c7220c576804829351b700849052)
    ghc-devel(wai-1.3.0.1-301777701df2228bc6e660cfbd7cdbf1)
    ghc-wai-logger = 0.3.0-1.fc19



Provides
--------
ghc-wai-logger-0.3.0-1.fc19.x86_64.rpm:
    
    ghc(wai-logger-0.3.0-a0eadb049a07f383c80b6c7ff2ad4873)
    ghc-wai-logger = 0.3.0-1.fc19
    ghc-wai-logger(x86-64) = 0.3.0-1.fc19
    libHSwai-logger-0.3.0-ghc7.4.2.so()(64bit)

ghc-wai-logger-devel-0.3.0-1.fc19.x86_64.rpm:
    
    ghc-devel(wai-logger-0.3.0-a0eadb049a07f383c80b6c7ff2ad4873)
    ghc-wai-logger-devel = 0.3.0-1.fc19
    ghc-wai-logger-devel(x86-64) = 0.3.0-1.fc19
    ghc-wai-logger-doc = 0.3.0-1.fc19
    ghc-wai-logger-prof = 0.3.0-1.fc19



Unversioned so-files
--------------------
ghc-wai-logger-0.3.0-1.fc19.x86_64.rpm: /usr/lib64/ghc-7.4.2/wai-logger-0.3.0/libHSwai-logger-0.3.0-ghc7.4.2.so

MD5-sum check
-------------
http://hackage.haskell.org/packages/archive/wai-logger/0.3.0/wai-logger-0.3.0.tar.gz :
  CHECKSUM(SHA256) this package     : d80b264861eaeef7b37d35a49dd1a720b286fabeaaa67da2637d9d8cbd64528c
  CHECKSUM(SHA256) upstream package : d80b264861eaeef7b37d35a49dd1a720b286fabeaaa67da2637d9d8cbd64528c


Generated by fedora-review 0.3.1 (b71abc1) last change: 2012-10-16
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 885349
Comment 6 Jens Petersen 2013-02-12 01:42:57 EST
Package looks good to me.

If you could just add/update the changelog to include
the initial package version for the record
when importing that would be perfect.

APPROVED
Comment 7 Ben Boeckel 2013-02-13 13:38:59 EST
New Package SCM Request
=======================
Package Name: ghc-wai-logger
Short Description: A logging system for WAI
Owners: mathstuf
Branches: f17 f18
InitialCC: haskell-sig
Comment 8 Jon Ciesla 2013-02-13 13:55:26 EST
Git done (by process-git-requests).
Comment 9 Jens Petersen 2013-02-15 05:22:02 EST
Built for rawhide http://koji.fedoraproject.org/koji/buildinfo?buildID=385340

I tried building 0.3.0 for f18 locally but it seems a bit tricky since

1) it requires newer fast-logger: at at least fast-logger-0.3.1 breaks wai-extra-1.2
2) wai*-1.3 needs conduit-0.5 stack so I would rather wait with that,
   even though we really want it

So either we leave it for now or try to find an old version of fast-logger
and/or wai-logger that won't break wai*-1.2 for f18 (and even f17).
Comment 10 Jens Petersen 2013-02-17 21:47:16 EST
(In reply to comment #9)
> So either we leave it for now or try to find an old version of fast-logger
> and/or wai-logger that won't break wai*-1.2 for f18 (and even f17).

Looks like the simplest would be wai-logger-0.1.4 which should build
with current f18 fast-logger.
Comment 11 Fedora Update System 2013-02-19 01:07:29 EST
ghc-wai-logger-0.1.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ghc-wai-logger-0.1.4-1.fc18
Comment 12 Fedora Update System 2013-02-19 01:07:45 EST
ghc-wai-logger-0.1.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ghc-wai-logger-0.1.4-1.fc17
Comment 13 Fedora Update System 2013-02-19 23:00:02 EST
ghc-wai-logger-0.1.4-1.fc18 has been pushed to the Fedora 18 testing repository.
Comment 14 Fedora Update System 2013-03-08 18:52:26 EST
ghc-wai-logger-0.1.4-1.fc18 has been pushed to the Fedora 18 stable repository.
Comment 15 Fedora Update System 2013-03-12 19:23:31 EDT
ghc-wai-logger-0.1.4-1.fc17 has been pushed to the Fedora 17 stable repository.

Note You need to log in before you can comment on or make changes to this bug.