Bug 886842 - 3.2 - [vdsm] lease files are not removed when removing volumes in file SDs v3
3.2 - [vdsm] lease files are not removed when removing volumes in file SDs v3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Yeela Kaplan
Elad
storage
: ZStream
Depends On:
Blocks: 891343 891345 915537
  Show dependency treegraph
 
Reported: 2012-12-13 05:32 EST by Yeela Kaplan
Modified: 2016-02-10 13:40 EST (History)
12 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-4.0
Doc Type: Release Note
Doc Text:
Previously, removing a file storage domain did not remove its lease files, so the virtual machines on the storage domain could not be deleted. Now, VDSM renames the lease files when a storage domain is removed, so its virtual machines can be deleted.
Story Points: ---
Clone Of:
: 891345 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (818.07 KB, application/octet-stream)
2012-12-13 05:32 EST, Yeela Kaplan
no flags Details
relevant vdsm log (675.87 KB, application/x-xz)
2012-12-17 07:56 EST, Yeela Kaplan
no flags Details

  None (edit)
Description Yeela Kaplan 2012-12-13 05:32:31 EST
Created attachment 662870 [details]
vdsm log

Description of problem:
Fail to delete a vm on file SD after delete snapshot of the vm.

Version-Release number of selected component (if applicable):
vdsm-4.10.2-0

How reproducible:
100%


Steps to Reproduce:
1.create a vm on file SD v3 and create a snapshot.
2.Delete the snapshot.
3.Delete the vm.
  
Actual results:
Failed to remove VM
Comment 1 RHEL Product and Program Management 2012-12-17 01:48:23 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 Yeela Kaplan 2012-12-17 07:56:58 EST
Created attachment 664825 [details]
relevant vdsm log
Comment 3 Yeela Kaplan 2012-12-18 12:21:54 EST
fix:
http://gerrit.ovirt.org/#/c/10208/
Comment 5 Leonid Natapov 2013-01-27 04:55:26 EST
vdsm-4.10.2-1.2.el6.x86_64.
tested according steps to reproduce.
VM on file SD successfully deleted after snapshot creation and deletion.
Comment 6 Leonid Natapov 2013-01-27 04:57:08 EST
putting ON_QA again since was marked as verified by mistake. sorry.
Comment 8 Elad 2013-03-03 06:41:54 EST
Tested on SF8
Comment 10 Itamar Heim 2013-06-11 04:24:32 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:25:59 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.