Bug 891345 - 3.1.z - [vdsm] lease files are not removed when removing volumes in file SDs v3
3.1.z - [vdsm] lease files are not removed when removing volumes in file SDs v3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: 6.4
Assigned To: Yeela Kaplan
Leonid Natapov
storage
: ZStream
Depends On: 886842
Blocks: 891343
  Show dependency treegraph
 
Reported: 2013-01-02 11:39 EST by Chris Pelland
Modified: 2016-02-02 17:40 EST (History)
10 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-1.1.el6
Doc Type: Bug Fix
Doc Text:
Previously, removing volumes from version 3 storage domains did not delete the corresponding lease files. Consequently, after the snapshot of a virtual machine was deleted, the virtual machine could not be removed. An update renames lease files on v3 storage domains when virtual machine data and metadata files are deleted, so a virtual machine can be successfully deleted after its snapshots are deleted.
Story Points: ---
Clone Of: 886842
Environment:
Last Closed: 2013-02-25 14:07:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ayal Baron 2013-01-02 16:54:19 EST
Change-Id: If3b3a2cf3499cc50b35b384ca72624d7f71c041a
Comment 3 Leonid Natapov 2013-01-27 04:56:12 EST
vdsm-4.10.2-1.2.el6.x86_64.
tested according steps to reproduce.
VM on file SD successfully deleted after snapshot creation and deletion.
Comment 5 errata-xmlrpc 2013-02-25 14:07:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0555.html

Note You need to log in before you can comment on or make changes to this bug.