This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 891343 - 3.1.z - [vdsm] lease files are not removed when removing volumes in file SDs v3
3.1.z - [vdsm] lease files are not removed when removing volumes in file SDs v3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: 6.3
Assigned To: Yeela Kaplan
Dafna Ron
storage
: ZStream
Depends On: 886842 891345
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-02 11:36 EST by Chris Pelland
Modified: 2016-02-02 17:40 EST (History)
12 users (show)

See Also:
Fixed In Version: vdsm-4.9.6-45.0
Doc Type: Bug Fix
Doc Text:
Previously, removing volumes from version 3 storage domains did not delete the corresponding lease files. Consequently, after the snapshot of a virtual machine was deleted, the virtual machine could not be removed. This update renames lease files on v3 storage domains when virtual machine data and metadata files are deleted, so a virtual machine can be successfully deleted after its snapshots are deleted.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 16:12:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2013-01-02 11:36:12 EST
This bug has been copied from bug #886842 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 4 Ayal Baron 2013-01-02 16:55:54 EST
Change-Id: If3b3a2cf3499cc50b35b384ca72624d7f71c041a
Comment 5 Dafna Ron 2013-01-17 09:36:43 EST
verified on si26
Comment 9 errata-xmlrpc 2013-02-04 16:12:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0228.html

Note You need to log in before you can comment on or make changes to this bug.