Bug 98880 - htsearch hangs when entering search string with ()
Summary: htsearch hangs when entering search string with ()
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: htdig   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-09 20:15 UTC by Stijn Jonker
Modified: 2015-03-05 01:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-02 14:20:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is where it goes wrong. (19.71 KB, text/plain)
2003-07-09 20:22 UTC, Stijn Jonker
no flags Details
Correct run (64.24 KB, text/plain)
2003-07-09 20:23 UTC, Stijn Jonker
no flags Details

Description Stijn Jonker 2003-07-09 20:15:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1; MultiZilla
v1.4.0.3J) Gecko/20030225

Description of problem:
Although i compiled htdig from the source RPM with slightly diffrent paths. 

I quickly confirmed is with the "official" raw hide version also.

When entering an search string with () in there it hangs short list:
String =  result
"()"=hang, "("=hang, ")"=hang, "() a"=ok, "()a"=ok, "a ()"=hang, "a()"=hang, "a
)"=hang, "a)"=hang, "a("=hang, "a)"=hang, "( a"=ok,
"( a )"=hang,"a ("=hang

P.s. off course enter them without the quotes.

I'll include an logfile of strace -f -F -o <file> htsearch -c
/var/http/search/new.conf

Where <file> will be htsearch-hang.txt & htsearch-ok.txt

Version-Release number of selected component (if applicable):
htdig-3.2.0-19.20030601

How reproducible:
Always

Steps to Reproduce:
1. Start htsearch, either on command line, or through webform
2. enter ()
3. hangs.
    

Actual Results:  Hangs, waited 5 minutes for it. classified as hang. ;-)

Expected Results:  Returned search result or syntax error, or not found.

Additional info: Maybe security related?

Comment 1 Stijn Jonker 2003-07-09 20:17:02 UTC
Might offcourse also apply to RH9, my actual platform.

Comment 2 Stijn Jonker 2003-07-09 20:22:45 UTC
Created attachment 92850 [details]
This is where it goes wrong.

You see as the last entry the line in regards to bad_words. But this exact
issues happens at the correct run also. The input i gave here was "()". 

I guess last time i didn't wait the full 5 minutes, because this time it was
killed by the alarm signal.

Comment 3 Stijn Jonker 2003-07-09 20:23:49 UTC
Created attachment 92851 [details]
Correct run

This is a normal search. it works fine.

Comment 4 Phil Knirsch 2003-09-02 14:06:48 UTC
Thats because the common_dir has changed to /usr/share/htdig from
/var/www/html/htdig.

You can either set thae common_dir in the htdig.conf yourself or create a
symlink from /usrH/share/htdig to /var/www/html/htdig.

It's fixed in the latest enterprise version.

Read ya, Phil

*** This bug has been marked as a duplicate of 88746 ***

Comment 5 Stijn Jonker 2003-09-02 14:13:14 UTC
This might fix the empty page, but it doesn't fix the hang here. Is there a way
i can test the enterprise version of htdig, as i'm on RH 9.0.



Comment 6 Phil Knirsch 2003-09-02 14:20:04 UTC
I'll put the srpm on

  http://people.redhat.com/pknirsch

from which a simple rebuild should do the job.

I've tested your examples which hung for you an they worked fine on my latest
package for the enterprise version.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.