Bug 88942 - Wrong keyboard layout used when entering root password
Wrong keyboard layout used when entering root password
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 106912 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-15 13:12 EDT by Jens Öhlund
Modified: 2007-04-18 12:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:12:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Öhlund 2003-04-15 13:12:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
When entering root password during clean install it seems to use US keyboard 
layout, even if SE keyboard layout was choosen in the beginning of the install.

The problem is not detected until root tries to log in for the first time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Make clean install of RHL 9, in graphical mode.
2.Choose Swedish keyboard layout
3.Enter rootpassord using nonstandard characters(with - in the password 
preferably)
4.Make a clean server install. Do not add any packages.
5.Finish install
6.Reboot machine
7.Try to login as root
    

Actual Results:  I could NOT log in as root.
I had to figure out what my password entering my "swedish" password on an US 
keyboard layout. Then I knew what to write and log in and then I could change 
root password.

Expected Results:  That the swedish keyboard layout was used when entering the 
root password.

Additional info:

USB keyboard and mouse was used.
Comment 1 David Balažic 2003-04-22 11:10:42 EDT
Looks like a duplicate of bug 78060
Comment 2 Jeremy Katz 2003-10-15 16:30:12 EDT
I can't reproduce this here at all.  What sort of installation are you doing? 
How are you booting?  Are there any error messages on tty3 or tty4 about loading
the keymap?
Comment 3 Jens Öhlund 2003-10-16 12:05:07 EDT
When I did this I:
1. booted from CD
2. choose graphical install
3. Choose swedish keyboard layout and +1 GMT time.
4. Made up my own partitions
5. Made up a root password with non characters in it. Lika - \ < and such that 
are placed on different places on a US or SE keyboard.
6. Waited for formating of disk, for files to install and restart of machine.

Then I could not log in. For an example try to press the keys producing these 
signs on different keymaps.
SE: <-:;_
US: \/><?

It's the same physical keys.

My problem ended that I had to (in windows) turn to US keymap, write my 
rootpassword in notepad, see the actual signs it became and enter that on my 
linux box. The funny thing is that the swedish keymap has been turned on AFTER 
the restart of the newly installed machine. 
So during install I write a password on a SE keyboard, but with a US keymap it 
seems. And when I log in the first time I write my password on a SE keyboard 
with a SE keymap.

I hope I described it clear enough, please ask again otherwise. I don't know 
anything about tty3 or tty4, since I'm a newbie and menthos, who helped me 
during the process, also asked me to submit this.
Comment 4 Michael Fulbright 2003-10-20 14:36:00 EDT
*** Bug 106912 has been marked as a duplicate of this bug. ***
Comment 5 Patrick Bégou 2003-12-10 04:57:21 EST
Same problem with Fedora core 1 with graphic install mode.
Additional information:

1) The selected language for install process is ENGLISH
2) The selected Keymap is French (AZERTY keyboard)
3) It is possible to see the problem earlier when partitioning the
disk with diskdruid. If you wont to create a local mount point for a
partition (ex: /tempo) when entering this mount point, the keyboard is
in QWERTY mode, not the AZERTY mode selected.

Mays be the problem is related to the English language/non english
Keyboard.

Patrick
Comment 6 Jeremy Katz 2004-10-04 23:12:06 EDT
This looks like it should be better in our current releases.

Note You need to log in before you can comment on or make changes to this bug.