Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 891377 - msgid "deprecated, see auto-attach-interval"
Summary: msgid "deprecated, see auto-attach-interval"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 5.10
Assignee: candlepin-bugs
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel510 rhsm-2013
TreeView+ depends on / blocked
 
Reported: 2013-01-02 18:43 UTC by John Sefler
Modified: 2013-09-30 22:54 UTC (History)
3 users (show)

Fixed In Version: 1.8.2
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2013-09-30 22:54:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1332 0 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-09-30 22:49:24 UTC

Description John Sefler 2013-01-02 18:43:43 UTC
Description of problem:
The following msgid is problematic for the translators because they want to translated the string "auto-attach-interval".  Instead, include "--" in the msgid as a prefix to "auto-attach-interval".

msgid "deprecated, see auto-attach-interval"


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-6 ~]# rhsmcertd --help
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -h, --help                             Show help options

Application Options:
  -c, --cert-interval=MINUTES            interval to run cert check (in minutes)
  --heal-interval=MINUTES                deprecated, see auto-attach-interval
  -i, --auto-attach-interval=MINUTES     interval to run auto-attach (in minutes)
  -n, --now                              run the initial checks immediately, with no delay
  -d, --debug                            show debug messages

  
Actual results:
deprecated, see auto-attach-interval

Expected results:
deprecated, see --auto-attach-interval
                ^^
                CHANGE MSGID "deprecated, see auto-attach-interval"
                TO           "deprecated, see --auto-attach-interval"

Additional info:

Comment 1 Bryan Kearney 2013-01-25 18:35:25 UTC
commit 23579a59f1a9c5ca8f8bd17bbdbf429ae40110c2
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Fri Jan 25 13:33:31 2013 -0500

    891377: Note in deprecated string that auto-attach-interval is a command option

Comment 2 Bryan Kearney 2013-02-08 17:18:26 UTC
Fixed in the 1.8.2 version of subscription-manager or python-rhsm

Comment 3 Shwetha Kallesh 2013-02-11 09:20:33 UTC
Marking verified!!

Version:
[root@rhel7 entitlement]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.7.24-1
subscription-manager: 1.8.2-1.el7
python-rhsm: 1.8.2-1.el7


[root@rhel7 entitlement]# rhsmcertd --help | grep deprecated
  --heal-interval=MINUTES                deprecated, see --auto-attach-interval

Comment 4 RHEL Program Management 2013-04-09 19:59:51 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 6 errata-xmlrpc 2013-09-30 22:54:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html


Note You need to log in before you can comment on or make changes to this bug.