Bug 89139 - RHN update prevents installing additional software through r-c-p
RHN update prevents installing additional software through r-c-p
Status: CLOSED DUPLICATE of bug 83485
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
: 97459 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-18 02:12 EDT by TReebe
Modified: 2007-03-27 00:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description TReebe 2003-04-18 02:12:07 EDT
Description of problem:

when trying to install the full GNOME software_engeneering_package (with
redhat-config-packages) for the first time (no prog of this package was
installed) after automaticaly upgrading gtkhtml-1.1.8-5 to 1.1.9-0.9 with rhnt
service announces gtkhtml-devel is missing gtkhtml-1.1.8-5 so that no component
of this package could be installed because the devel is within the standard
packages! 

Version-Release number of selected component (if applicable):
gtkhtml-devel-1.1.8-5 i think
Comment 1 Tim Bingham 2003-06-11 00:32:08 EDT
I was able to work around this by

 1) temporarily downgrading gtkhtml (# rpm --upgrade --force
gtkhtml-1.1.8-5.i386.rpm)
 2) running "System Settings" -> "Add/Remove Applications" and installing the
"GNOME Software Development" package group
 3) run "Redhat Update Agent" to install the latest versions (1.1.9-0.9) of
gtkhtml and gtkhtml-devel

Hope this helps
Cheers,
Tim.

Comment 2 Owen Taylor 2003-10-06 17:08:16 EDT
Basically, redhat-config-packages needs to be aware of errata, so it
can go and fetch the newer redhat-config-packages from RHN. 

There's nothing GtkHTML specific about this ... gtkhtml and gtkhtml-devel
have to match in version, but when you updated via RHN, you only had
gtkhtml installed, so the newer gtkhtml-devel that was on RHN wasn't
installed.

Then when you went to install gtkhtml-devel (etc.) from r-c-p, r-c-p
didn't know where to get the newer version.
Comment 3 Owen Taylor 2003-10-06 17:22:11 EDT
*** Bug 97459 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2003-10-06 17:23:01 EDT

*** This bug has been marked as a duplicate of 83485 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.