Bug 892596 - engine- No Statisitics for Disk Read/Write in Views (v3_2 & v3_1) vm_disk_samples_history_view (hence no statistics in DWH)
engine- No Statisitics for Disk Read/Write in Views (v3_2 & v3_1) vm_disk_sam...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.0
Assigned To: Vered Volansky
David Botzer
storage
: Regression
Depends On:
Blocks: 876085 920211 948448
  Show dependency treegraph
 
Reported: 2013-01-07 06:11 EST by David Botzer
Modified: 2016-02-10 11:38 EST (History)
12 users (show)

See Also:
Fixed In Version: sf11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 920211 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
scohen: Triaged+


Attachments (Terms of Use)
rhevm-logs (122.28 KB, application/x-gzip)
2013-01-07 06:11 EST, David Botzer
no flags Details
vdsm (471.32 KB, application/x-gzip)
2013-01-07 06:11 EST, David Botzer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12961 None None None Never

  None (edit)
Description David Botzer 2013-01-07 06:11:00 EST
Created attachment 673922 [details]
rhevm-logs

Description of problem:
No Statisitics for Disk Read/Write in Views (v3_2 & v3_1) vm_disk_samples_history_view (if there is no data in samples it affects both hours & days)

This applies for both DC's versions 3.1 & 3.2 on rhevm 3.2

Version-Release number of selected component (if applicable):
3.2/SF3

How reproducible:
always

Steps to Reproduce:
1.Installrhevm+dwh+reports on RHEL64 Hosts
2.Create DC 3.1 or 3.2 with 1 host
3.Create 1VM Winxp from template or new with IOLoadGenerator
4.run IOLoadGenerator.exe -f iozone/iozone.exe
  
Actual results:
Data is not saved in the correct tables/views for vm_disk_samples_history

Expected results:
Should save & display the Read/Write data

Additional info:
Comment 1 David Botzer 2013-01-07 06:11:40 EST
Created attachment 673923 [details]
vdsm
Comment 2 David Botzer 2013-01-07 06:15:15 EST
Data is also missing from:
v3_2_statistics_vms_disks_resources_usage_samples, 
v3_1_vm_disk_samples_history_view
v3_0_vm_disk_samples_history_view
Comment 4 David Botzer 2013-01-07 07:49:37 EST
Yes, added regression in keyword
Comment 6 David Botzer 2013-01-08 07:39:55 EST
DWH gather data correctly where engine has NULL in Read/Write,
Engine View is dwh_vm_disks_history_view
Table disk_image_dynamic
Comment 7 Yair Zaslavsky 2013-01-20 07:47:57 EST
Adding storage keyword, looks like we are missing some statistics report.
Comment 10 David Botzer 2013-02-07 07:34:07 EST
Reproduced on 3.2/SF5
Comment 11 Allon Mureinik 2013-02-07 08:32:56 EST
(In reply to comment #10)
> Reproduced on 3.2/SF5

David, why are you testing this?
The bug is in "ASSIGNED" status - it was never fixed.
Comment 12 David Botzer 2013-02-07 10:35:31 EST
Ok,

As a response to Vered
Comment 13 Allon Mureinik 2013-03-06 05:17:43 EST
This bug is marked as REGRESSION - when was was the last time that it worked? (3.1? 3.0?)
Comment 14 Vered Volansky 2013-03-06 05:47:56 EST
According to Yaniv Dary the actual select query creating dwh_vm_disks_history_view returns no records, which means this is not a reports/dwh issue and can be fixed on the engine alone. I.e., no need for winXP/dwh/reports installations.
We expect to see data on disks of currently running VMs in the system.
Comment 15 David Botzer 2013-03-06 06:05:39 EST
Same as Vered, Issue is at the engine DB
Comment 16 Allon Mureinik 2013-03-06 07:23:25 EST
(In reply to comment #15)
> Same as Vered, Issue is at the engine DB

This is not the question.

I ask again:
In what version was this last confirmed to work?
Comment 17 David Botzer 2013-03-06 08:30:53 EST
The Disk IO stats were working at 3.0/ic138.1
(Bug 733290)

Same issue as the this BZ was Also reported
In 891322 - 3.1/si24
Comment 19 Vered Volansky 2013-03-11 10:48:26 EDT
disk_image_dynamic table does not gather statistics, hence related dwh views are empty.
3.1 introduced DiskImage entity to the system, separating (engine) image group and image id (or image and volume in vdsm, respectively). The data received from vdsm is (correctly so) for image group, while the data in the table is updated by image id (volume). Hence no data is actually updated.
Comment 21 David Botzer 2013-04-22 05:05:51 EDT
Hi Vered,
Is this BZ fixed for 3.2/sf13 ?
Comment 22 Vered Volansky 2013-04-22 06:50:35 EDT
(In reply to comment #21)
> Hi Vered,
> Is this BZ fixed for 3.2/sf13 ?

Yep, see external tracker for more info.
Comment 23 David Botzer 2013-04-22 07:31:05 EDT
Fixed, 3.2/sf13
History DB has data in all 3 views
samples/hours/daily - VM_DISK_Read/Write
Fixed, 3.2/sf13
Comment 24 Itamar Heim 2013-06-11 04:31:43 EDT
3.2 has been released
Comment 25 Itamar Heim 2013-06-11 04:31:52 EDT
3.2 has been released
Comment 26 Itamar Heim 2013-06-11 04:33:11 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.