This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 894155 - matahari not obseleting matahari-debuginfo rpm
matahari not obseleting matahari-debuginfo rpm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jeff Peeler
IDM QE LIST
:
: 893672 (view as bug list)
Depends On:
Blocks: 830087 895654
  Show dependency treegraph
 
Reported: 2013-01-10 15:54 EST by Dave Johnson
Modified: 2016-04-26 12:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.6.0-18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:11:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2013-01-10 15:54:33 EST
Description of problem:
===============================================
Upgrading matahari is not removing -debuginfo package....

[root@x8664 tmp]# yum upgrade /mnt/redhat/brewroot/packages/matahari/0.6.0/16/x86_64/matahari-0.6.0-16.x86_64.rpm
Loaded plugins: aliases, auto-update-debuginfo, changelog, downloadonly, fastestmirror, filter-data, fs-snapshot, kabi, keys, list-data, merge-conf, post-transaction-actions,
              : presto, priorities, product-id, protectbase, ps, refresh-packagekit, remove-with-leaves, rhnplugin, rpm-warm-cache, security, show-leaves, subscription-
              : manager, tmprepo, tsflags, upgrade-helper, verify, versionlock
Updating certificate-based repositories.
Unable to read consumer identity
Loading support for Red Hat kernel ABI
Loading mirror speeds from cached hostfile
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Upgrade Process
Examining /mnt/redhat/brewroot/packages/matahari/0.6.0/16/x86_64/matahari-0.6.0-16.x86_64.rpm: matahari-0.6.0-16.x86_64
Marking /mnt/redhat/brewroot/packages/matahari/0.6.0/16/x86_64/matahari-0.6.0-16.x86_64.rpm as an update to matahari-0.6.0-14.el6.x86_64
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package matahari.x86_64 0:0.6.0-14.el6 will be updated
---> Package matahari.x86_64 0:0.6.0-16 will be obsoleting
---> Package matahari-agent-lib.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-broker.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-consoles.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-core.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-host.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-lib.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-network.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-python.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-rpc.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-service.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-shell.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-sysconfig.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-vios-proxy-guest.x86_64 0:0.6.0-14.el6 will be obsoleted
---> Package matahari-vios-proxy-host.x86_64 0:0.6.0-14.el6 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================
 Package                               Arch                                Version                               Repository                                              Size
==============================================================================================================================================================================
Installing:
 matahari                              x86_64                              0.6.0-16                              /matahari-0.6.0-16.x86_64                              0.0  
     replacing  matahari-agent-lib.x86_64 0.6.0-14.el6
     replacing  matahari-broker.x86_64 0.6.0-14.el6
     replacing  matahari-consoles.x86_64 0.6.0-14.el6
     replacing  matahari-core.x86_64 0.6.0-14.el6
     replacing  matahari-host.x86_64 0.6.0-14.el6
     replacing  matahari-lib.x86_64 0.6.0-14.el6
     replacing  matahari-network.x86_64 0.6.0-14.el6
     replacing  matahari-python.x86_64 0.6.0-14.el6
     replacing  matahari-rpc.x86_64 0.6.0-14.el6
     replacing  matahari-service.x86_64 0.6.0-14.el6
     replacing  matahari-shell.x86_64 0.6.0-14.el6
     replacing  matahari-sysconfig.x86_64 0.6.0-14.el6
     replacing  matahari-vios-proxy-guest.x86_64 0.6.0-14.el6
     replacing  matahari-vios-proxy-host.x86_64 0.6.0-14.el6

Transaction Summary
==============================================================================================================================================================================
Install       1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : matahari-0.6.0-16.x86_64                                                                                                                                  1/16 
  Cleanup    : matahari-0.6.0-14.el6.x86_64                                                                                                                              2/16 
  Erasing    : matahari-vios-proxy-host-0.6.0-14.el6.x86_64                                                                                                              3/16 
  Erasing    : matahari-vios-proxy-guest-0.6.0-14.el6.x86_64                                                                                                             4/16 
  Erasing    : matahari-shell-0.6.0-14.el6.x86_64                                                                                                                        5/16 
  Erasing    : matahari-rpc-0.6.0-14.el6.x86_64                                                                                                                          6/16 
  Erasing    : matahari-host-0.6.0-14.el6.x86_64                                                                                                                         7/16 
  Erasing    : matahari-network-0.6.0-14.el6.x86_64                                                                                                                      8/16 
  Erasing    : matahari-service-0.6.0-14.el6.x86_64                                                                                                                      9/16 
  Erasing    : matahari-sysconfig-0.6.0-14.el6.x86_64                                                                                                                   10/16 
  Erasing    : matahari-broker-0.6.0-14.el6.x86_64                                                                                                                      11/16 
  Erasing    : matahari-consoles-0.6.0-14.el6.x86_64                                                                                                                    12/16 
  Erasing    : matahari-python-0.6.0-14.el6.x86_64                                                                                                                      13/16 
  Erasing    : matahari-agent-lib-0.6.0-14.el6.x86_64                                                                                                                   14/16 
  Erasing    : matahari-lib-0.6.0-14.el6.x86_64                                                                                                                         15/16 
  Erasing    : matahari-core-0.6.0-14.el6.x86_64                                                                                                                        16/16 
Installed products updated.
  Verifying  : matahari-0.6.0-16.x86_64                                                                                                                                  1/16 
  Verifying  : matahari-lib-0.6.0-14.el6.x86_64                                                                                                                          2/16 
  Verifying  : matahari-consoles-0.6.0-14.el6.x86_64                                                                                                                     3/16 
  Verifying  : matahari-shell-0.6.0-14.el6.x86_64                                                                                                                        4/16 
  Verifying  : matahari-rpc-0.6.0-14.el6.x86_64                                                                                                                          5/16 
  Verifying  : matahari-network-0.6.0-14.el6.x86_64                                                                                                                      6/16 
  Verifying  : matahari-core-0.6.0-14.el6.x86_64                                                                                                                         7/16 
  Verifying  : matahari-python-0.6.0-14.el6.x86_64                                                                                                                       8/16 
  Verifying  : matahari-sysconfig-0.6.0-14.el6.x86_64                                                                                                                    9/16 
  Verifying  : matahari-vios-proxy-guest-0.6.0-14.el6.x86_64                                                                                                            10/16 
  Verifying  : matahari-broker-0.6.0-14.el6.x86_64                                                                                                                      11/16 
  Verifying  : matahari-0.6.0-14.el6.x86_64                                                                                                                             12/16 
  Verifying  : matahari-agent-lib-0.6.0-14.el6.x86_64                                                                                                                   13/16 
  Verifying  : matahari-vios-proxy-host-0.6.0-14.el6.x86_64                                                                                                             14/16 
  Verifying  : matahari-host-0.6.0-14.el6.x86_64                                                                                                                        15/16 
  Verifying  : matahari-service-0.6.0-14.el6.x86_64                                                                                                                     16/16 

Installed:
  matahari.x86_64 0:0.6.0-16                                                                                                                                                  

Replaced:
  matahari-agent-lib.x86_64 0:0.6.0-14.el6                    matahari-broker.x86_64 0:0.6.0-14.el6                      matahari-consoles.x86_64 0:0.6.0-14.el6             
  matahari-core.x86_64 0:0.6.0-14.el6                         matahari-host.x86_64 0:0.6.0-14.el6                        matahari-lib.x86_64 0:0.6.0-14.el6                  
  matahari-network.x86_64 0:0.6.0-14.el6                      matahari-python.x86_64 0:0.6.0-14.el6                      matahari-rpc.x86_64 0:0.6.0-14.el6                  
  matahari-service.x86_64 0:0.6.0-14.el6                      matahari-shell.x86_64 0:0.6.0-14.el6                       matahari-sysconfig.x86_64 0:0.6.0-14.el6            
  matahari-vios-proxy-guest.x86_64 0:0.6.0-14.el6             matahari-vios-proxy-host.x86_64 0:0.6.0-14.el6            

Complete!
New leaves:
  qpid-cpp-server-ssl.x86_64
  qpid-tools.noarch
  tuned.noarch
  vios-proxy-guest.x86_64
  vios-proxy-host.x86_64

[root@x8664 tmp]#
[root@x8664 tmp]# rpm -qa | grep matahari
mingw32-matahari-0.4.4-13.el6.noarch
matahari-0.6.0-16.x86_64
matahari-debuginfo-0.6.0-14.el6.x86_64


Version-Release number of selected component (if applicable):
=====================================================================
0.6.0-16


Additional info:
========================
Should installing this obsolete mingw32-matahari as well?
Comment 2 RHEL Product and Program Management 2013-01-14 01:47:48 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Zane Bitter 2013-01-14 13:32:00 EST
The spec file contains the following line:

Obsoletes:  mingw32-matahari <= 0.4.4-13

so mingw32-matahari ought to have been removed also.

Perhaps the issue there is that mingw32-matahari is noarch instead of x86_64?
Comment 7 Perry Myers 2013-01-15 12:59:42 EST
*** Bug 893672 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2013-02-21 05:11:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0404.html

Note You need to log in before you can comment on or make changes to this bug.