Bug 903048 - [fr_FR] various manpages missing from man-pages-fr
[fr_FR] various manpages missing from man-pages-fr
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-fr (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Mike FABIAN
QE Internationalization Bugs
: i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 20:49 EST by Lijun Li
Modified: 2013-07-18 05:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 05:36:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
phony-targets.patch (2.88 KB, patch)
2013-01-30 03:40 EST, Mike FABIAN
no flags Details | Diff
0001-fix-Makefile-in-man-pages-extras-fr-0.8.1.tar.bz2-to.patch (4.96 KB, patch)
2013-01-30 03:42 EST, Mike FABIAN
no flags Details | Diff

  None (edit)
Description Lijun Li 2013-01-22 20:49:39 EST
Description of problem:
[fr_FR] man echo manuals are still English.

Version-Release number of selected component (if applicable):
# rpm -q man-pages-fr
man-pages-fr-3.23-9.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1. Install latest rhel6.4 client build.
2. Install man-pages-fr package.
3. Type followings to check translations

# man less

# man more

# man bash

# man echo

# man man
  
Actual results:
# man echo  manuals are still English.

Expected results:
# man echo should be localized.

Additional info:
Comment 2 Mike FABIAN 2013-01-30 03:40:48 EST
Created attachment 690211 [details]
phony-targets.patch

Patch to fix the problem.

in man-pages-extras-fr-0.8.1/Makefile, the target “afaire :”
does not work:

mfabian@ari:~/rpmsources/fedora/man-pages-fr/man-pages-extras-fr-0.8.1 (master)
$ LANG=fr_FR.UTF-8 make afaire
make: « afaire » est à jour.
mfabian@ari:~/rpmsources/fedora/man-pages-fr/man-pages-extras-fr-0.8.1 (master)
$ 

(Problem is the same in f18 and rhel-6.4).

This is because the existing folder “afaire/” has exactly the same
name as the target. To make it work nevertheless, the target needs
to be declared .PHONY like this:

+.PHONY : afaire
 afaire :
        cd afaire ; \
        make install ;

http://www.gnu.org/software/make/manual/html_node/Phony-Targets.html
Comment 3 Mike FABIAN 2013-01-30 03:42:47 EST
Created attachment 690212 [details]
0001-fix-Makefile-in-man-pages-extras-fr-0.8.1.tar.bz2-to.patch

Patch for man-pages-fr.spec in rhel-6.4 branch.
Comment 4 Mike FABIAN 2013-01-30 03:50:39 EST
These are the French man-pages added by the fix:

mfabian@ari:~/rpmsources/rhel/man-pages-fr (rhel-6.4)
$ ls man-pages-fr-3.23/afaire/
Makefile    dirname.1  fold.1     nice.1     printenv.1  sum.1   tty.1       yes.1
basename.1  echo.1     groups.1   nl.1       printf.1    tac.1   uname.1
cat.1       env.1      head.1     nohup.1    pwd.1       tail.1  unexpand.1
cksum.1     expand.1   hostid.1   od.1       sleep.1     tar.1   uniq.1
comm.1      expr.1     id.1       passwd.1   sort.1      tee.1   users.1
csplit.1    false.1    join.1     paste.1    split.1     test.1  wc.1
cut.1       find.1     logname.1  pathchk.1  stty.1      tr.1    who.1
date.1      fmt.1      md5sum.1   pr.1       su.1        true.1  whoami.1
mfabian@ari:~/rpmsources/rhel/man-pages-fr (rhel-6.4)
$
Comment 5 Mike FABIAN 2013-01-30 04:23:34 EST
The same bug exist in Fedora 18, see bug#905826.
Comment 6 Mike FABIAN 2013-02-07 01:57:19 EST
Fixed for Fedora 18 now:

https://bugzilla.redhat.com/show_bug.cgi?id=905826#c6
Comment 9 Mike FABIAN 2013-03-26 03:34:21 EDT
Fix pushed to  rhel-6.5 branch:

commit 6ed81737a291ac3cd3ab76bf0d44a5f802f7c586
Author: Mike FABIAN <mfabian@redhat.com>
Date:   Wed Jan 30 08:44:39 2013 +0100

    fix Makefile in man-pages-extras-fr-0.8.1.tar.bz2 to install missing man-pages
    
    Resolves: #903048 - [fr_FR] man echo manuals are still English.
Comment 13 errata-xmlrpc 2013-07-18 05:36:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1093.html

Note You need to log in before you can comment on or make changes to this bug.