Bug 905826 - Due to problems in the man-pages-fr.spec file and the Makefile in man-pages-extras-fr-0.8.1.tar.bz2, many French man-pages are not included in man-pages-fr
Due to problems in the man-pages-fr.spec file and the Makefile in man-pages-e...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-pages-fr (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
: i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 04:13 EST by Mike FABIAN
Modified: 2013-03-02 14:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-02 14:59:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
phony-targets.patch (2.88 KB, patch)
2013-01-30 04:14 EST, Mike FABIAN
no flags Details | Diff

  None (edit)
Description Mike FABIAN 2013-01-30 04:13:48 EST
For example the man-page of “echo” is missing and of “xinetd”
although these are in the tar balls of the translated man-pages.
Comment 1 Mike FABIAN 2013-01-30 04:14:47 EST
Created attachment 690223 [details]
phony-targets.patch

Patch to fix the part of the problem cause by the buggy Makefile.
Comment 2 Mike FABIAN 2013-01-30 04:20:54 EST
mfabian@ari:~/rpmsources/fedora/man-pages-fr (master)
$ ls man-pages-fr-3.45/afaire/
Makefile    dirname.1  fold.1     nice.1     printenv.1  sum.1   tty.1       yes.1
basename.1  echo.1     groups.1   nl.1       printf.1    tac.1   uname.1
cat.1       env.1      head.1     nohup.1    pwd.1       tail.1  unexpand.1
cksum.1     expand.1   hostid.1   od.1       sleep.1     tar.1   uniq.1
comm.1      expr.1     id.1       passwd.1   sort.1      tee.1   users.1
csplit.1    false.1    join.1     paste.1    split.1     test.1  wc.1
cut.1       find.1     logname.1  pathchk.1  stty.1      tr.1    who.1
date.1      fmt.1      md5sum.1   pr.1       su.1        true.1  whoami.1
mfabian@ari:~/rpmsources/fedora/man-pages-fr (master)
$
Comment 3 Mike FABIAN 2013-01-30 04:21:43 EST
The man-pages listed in comment#2 are added by the patch attached to comment#1.
Comment 4 Mike FABIAN 2013-01-30 04:28:02 EST
None of the manpages from the mansupfr.tar.bz2 tarball are
included in the built package either because they are not installed
in the man-pages-fr.spec file.

Fix for this for the %install section of the man-pages-fr.spec file:

+# Install pages from mansupfr.tar.bz2:
+for i in 1 2 3 4 5 6 7 8 9; do
+    if [ -d man${i} ] ; then
+        cd man${i};
+        for j in *.${i}; do
+            if [ ! -f $RPM_BUILD_ROOT%{_mandir}/fr/man${i}/$j ] ; then
+                echo "installing $j"
+                %{__install} -m 0644 "${j}" "$RPM_BUILD_ROOT%{_mandir}/fr/man${i}/${
j}"
+            else
+                echo "$j already exists"
+            fi
+        done
+        cd ..
+    fi
+done
+
Comment 5 Mike FABIAN 2013-01-30 04:33:38 EST
Among the missing man-pages which are installed by the fix in comment#4
is xinetd.8, this page is badly out of date and I added it to the list
of pages which are edited in the man-pages-fr.spec file to add
a warning that they are out of date:

for i in mail.1 yum.8 xinetd.8; do
  name=`echo ${i} | awk -F"." '{print$1}'`
  find . -name ${i} -exec sed -i "s/\(\(\.SH\) *SYNOPSIS\)/.br\n\2 Attention\\\\ :\nLa traduction de  cette page de manuel pour \"$name\" est obsolète par rapport à la version actuelle de \"$name\". Pour avoir la dernière version de la page de manuel, veuillez utiliser la version anglaise. La version anglaise est disponible avec la commande suivante :\n.nf\nLANG=en_US.UTF-8 man $name\n.fi\n\1/gi" {} \;
done

Not only the problem mentioned in bug#891277 and bug#891278

> the xinetd page mentions an option that doesn't exist anymore :
>  -loop. it doesn't exist in the english manpage

exists, there are more problems, I think a full retranslation of this
page seems necessary, nothing I can do, therefore I just added
the warning that this page is out of date.
Comment 6 Fedora Update System 2013-02-07 01:43:24 EST
man-pages-fr-3.45-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/man-pages-fr-3.45-1.fc18
Comment 7 Fedora Update System 2013-02-08 12:04:37 EST
Package man-pages-fr-3.45-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-pages-fr-3.45-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2155/man-pages-fr-3.45-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-02-21 12:44:25 EST
man-pages-fr-3.45-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/man-pages-fr-3.45-2.fc18
Comment 9 Fedora Update System 2013-03-02 14:59:27 EST
man-pages-fr-3.45-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.