This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 908037 - [hi][it][ml][ru] character ¶ should not appear in translated msgstr
[hi][it][ml][ru] character ¶ should not appear in translated msgstr
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.10
Assigned To: candlepin-bugs
IDM QE LIST
: i18n, Translation
Depends On:
Blocks: rhsm-rhel510 rhsm-2013
  Show dependency treegraph
 
Reported: 2013-02-05 12:22 EST by John Sefler
Modified: 2013-09-30 18:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 18:55:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-02-05 12:22:43 EST
Description of problem:
Please incorporate the same translation fixes from bug 893120 into subscription-manager-1.8.

Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.8.1-1.git.9.f23e0b0.el7.x86_64
https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.8.X


How reproducible:


Steps to Reproduce:
[root@jsefler-7 ~]# for L in `rpm -ql subscription-manager | grep rhsm.mo`; do echo ""; echo "LOOKING FOR CHARACTER '¶' IN LANG FILE $L..."; msgunfmt --no-wrap $L | grep '¶' -B2; done;

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/as/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/fr/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/gu/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/hi/LC_MESSAGES/rhsm.mo...

msgid "Invalid argument specified: %s\n"
msgstr "अवैध वितर्क निर्दिष्ट: %s¶\n"

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/it/LC_MESSAGES/rhsm.mo...
"Questo software è sotto licenza GNU General Public License, versione 2 (GPLv2). Questo software non ha ALCUNA GARANZIA, espressa o implicita, nemmeno la garanzia implicita di COMMERCIABILITÀ o APPLICABILITÀ PER UNO SCOPO PARTICOLARE. Una copia della GPLv2 dovrebbe essere stata fornita con questo software; in caso contrario consultare: \n"
"\n"
"http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt¶\n"

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ja/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/kn/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ko/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ml/LC_MESSAGES/rhsm.mo...
msgstr ""
"\n"
"രജിസ്ടര്‍ ചെയ്യുവാന്‍ സാധ്യമല്ല.¶\n"
--
msgstr ""
"\n"
"ഈ ചാനലുകള്‍ വേണ്ടെന്നു് വയ്ക്കുന്നതിനും മൈഗ്രേഷനുമായി തുടരുന്നതിനായി --force ഉപയോഗിയ്ക്കുക.¶\n"
--

msgid "For more information run: rhsmcertd --help\n"
msgstr "കൂടുതല്‍ വിവരങ്ങള്‍ക്കായി  rhsmcertd --help നടപ്പിലാക്കുക¶\n"
--

msgid "Must be root user to execute\n"
msgstr "പ്രവര്‍ത്തിപ്പിയ്ക്കുന്നതിനു് റൂട്ടായിരിയ്ക്കണം ¶\n"
--
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr "സബ്സ്ക്രിപ്ഷന്‍ ലഭ്യമാക്കുന്നതിനു് ആല്‍പം സമയമെടുക്കുന്നു.¶ ഇതു് പൂര്‍ത്തിയാക്കുമ്പോള്‍ അറിയിയ്ക്കുന്നതിനുള്ള¶ ഈമെയില്‍ വിലാസം നല്‍കുക."
--

msgid "WARN: Deprecated CLI arguments are being used.\n"
msgstr "മുന്നറിയിപ്പു്: നീക്കം ചെയ്ത സിഎല്‍ഐ ആര്‍ഗ്യുമെന്റുകള്‍ ഉപയോഗിയ്ക്കുന്നു.¶\n"

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/mr/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/or/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/pa/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ru/LC_MESSAGES/rhsm.mo...

msgid "Invalid argument specified: %s\n"
msgstr "Указан неверный аргумент:  %s¶\n"
--

msgid "Invalid option: %s\n"
msgstr "Недопустимый параметр: %s¶\n"

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/te/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo...
Comment 1 Yulia 2013-02-05 18:57:39 EST
Russian corrected
Comment 2 Adrian Likins 2013-03-25 17:34:57 EDT
commit 008c5cb336b141f300d647d6c71750b2cd15e066
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Mar 25 15:03:16 2013 -0400

    921126: latest string updates from zanata
    
    921126,911779,911776,911772,911764,911762,911759,
    911757,908886,908879,908869,908866,908521,908511,
    908488,908434,908108,908059,908037,906967,906552,
    842784
Comment 3 John Sefler 2013-03-26 17:49:31 EDT
This test continues to fail on langs ml it hi
DO NOT USE THE "¶" CHARACTER IN THE TRANSLATION msgstr.  USE "\n" FOR NEW LINES.


[root@jsefler-7 ~]# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo | grep "¶" -B6

msgid ""
"\n"
"Unable to register.\n"
"For further assistance, please contact Red Hat Global Support Services."
msgstr ""
"\n"
"രജിസ്ടര്‍ ചെയ്യുവാന്‍ സാധ്യമല്ല.¶\n"
--

msgid ""
"\n"
"Use --force to ignore these channels and continue the migration.\n"
msgstr ""
"\n"
"ഈ ചാനലുകള്‍ വേണ്ടെന്നു് വയ്ക്കുന്നതിനും മൈഗ്രേഷനുമായി തുടരുന്നതിനായി --force ഉപയോഗിയ്ക്കുക.¶\n"
--

msgid "For more information run: rhsmcertd --help\n"
msgstr "കൂടുതല്‍ വിവരങ്ങള്‍ക്കായി  rhsmcertd --help നടപ്പിലാക്കുക¶\n"
--

msgid "Must be root user to execute\n"
msgstr "പ്രവര്‍ത്തിപ്പിയ്ക്കുന്നതിനു് റൂട്ടായിരിയ്ക്കണം ¶\n"
--

msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr "സബ്സ്ക്രിപ്ഷന്‍ ലഭ്യമാക്കുന്നതിനു് ആല്‍പം സമയമെടുക്കുന്നു.¶ ഇതു് പൂര്‍ത്തിയാക്കുമ്പോള്‍ അറിയിയ്ക്കുന്നതിനുള്ള¶ ഈമെയില്‍ വിലാസം നല്‍കുക."
--

msgid "WARN: Deprecated CLI arguments are being used.\n"
msgstr "മുന്നറിയിപ്പു്: നീക്കം ചെയ്ത സിഎല്‍ഐ ആര്‍ഗ്യുമെന്റുകള്‍ ഉപയോഗിയ്ക്കുന്നു.¶\n"




[root@jsefler-7 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo | grep "¶"
"http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt¶\n"



[root@jsefler-7 ~]# msgunfmt --no-wrap /usr/share/locale/hi/LC_MESSAGES/rhsm.mo | grep "¶" -B1
msgid "Invalid argument specified: %s\n"
msgstr "अवैध वितर्क निर्दिष्ट: %s¶\n"


Moving back to ASSIGNED/FailedQA
Comment 4 Rajesh Ranjan 2013-03-28 02:37:19 EDT
done for Hindi.
Comment 5 RHEL Product and Program Management 2013-04-09 16:14:16 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 Bryan Kearney 2013-04-19 14:27:37 EDT
Issues remain in ml.po

[bkearney@bkearney po]$ for L in *.po ; do echo ""; echo "LOOKING FOR MSGID 'subscription-manager:' IN LANG FILE $L..."; grep -i '¶' -A1 $L ; done;


LOOKING FOR MSGID 'subscription-manager:' IN LANG FILE ml.po...
"ഈ ചാനലുകള്‍ വേണ്ടെന്നു് വയ്ക്കുന്നതിനും മൈഗ്രേഷനുമായി തുടരുന്നതിനായി --force ഉപയോഗിയ്ക്കുക.¶\n"

--
"രജിസ്ടര്‍ ചെയ്യുവാന്‍ സാധ്യമല്ല.¶\n"
"കൂടുതല്‍ വിവരങ്ങള്‍ക്കായി ദയവായി Red Hat ഗ്ലോബല്‍ സപ്പോര്‍ട്ട് സര്‍വീസുകളുമായി ബന്ധപ്പെടുക."
--
"സബ്സ്ക്രിപ്ഷന്‍ ലഭ്യമാക്കുന്നതിനു് ആല്‍പം സമയമെടുക്കുന്നു.¶ ഇതു് "
"പൂര്‍ത്തിയാക്കുമ്പോള്‍ അറിയിയ്ക്കുന്നതിനുള്ള¶ ഈമെയില്‍ വിലാസം നല്‍കുക."

--
msgstr "പ്രവര്‍ത്തിപ്പിയ്ക്കുന്നതിനു് റൂട്ടായിരിയ്ക്കണം ¶\n"

--
msgstr "കൂടുതല്‍ വിവരങ്ങള്‍ക്കായി  rhsmcertd --help നടപ്പിലാക്കുക¶\n"

--
"മുന്നറിയിപ്പു്: നീക്കം ചെയ്ത സിഎല്‍ഐ ആര്‍ഗ്യുമെന്റുകള്‍ ഉപയോഗിയ്ക്കുന്നു.¶\n"
Comment 7 Bryan Kearney 2013-04-19 14:49:56 EDT
commit b3f4bbf63251bba8b3e9c24cc2051067dec7e2f5
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Fri Apr 19 14:49:30 2013 -0400

    908037: remove all ¶ characters from the ml.po file. Zanata was also updated
Comment 8 Bryan Kearney 2013-06-05 08:21:30 EDT
in the latest errata
Comment 9 Sharath Dwaral 2013-06-05 11:27:03 EDT
Version
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-migration-1.8.10-1.git.1.b44c4b1.el5
python-rhsm-1.8.12-1.git.0.d747a65.el5
subscription-manager-firstboot-1.8.10-1.git.1.b44c4b1.el5
subscription-manager-1.8.10-1.git.1.b44c4b1.el5
subscription-manager-gui-1.8.10-1.git.1.b44c4b1.el5


# for L in `rpm -ql subscription-manager | grep rhsm.mo`; do echo ""; echo "LOOKING FOR CHARACTER '¶' IN LANG FILE $L..."; msgunfmt --no-wrap $L | grep '¶' -B2; done;

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/as/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/fr/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/gu/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/hi/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/it/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ja/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/kn/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ko/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ml/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/mr/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/or/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/pa/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ru/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/te/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo...

LOOKING FOR CHARACTER '¶' IN LANG FILE /usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo...



Clean run for  [hi] [ru] [ml] [it]

VERIFIED
Comment 11 errata-xmlrpc 2013-09-30 18:55:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.