Bug 908756 - Attaches backtrace and other data encoded
Attaches backtrace and other data encoded
Status: CLOSED DUPLICATE of bug 908762
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
18
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On: 908210 908762
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-07 07:48 EST by Jakub Filak
Modified: 2016-11-30 19:43 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 908210
Environment:
Last Closed: 2013-02-07 10:28:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Filak 2013-02-07 07:48:25 EST
+++ This bug was initially created as a clone of Bug #908210 +++

I just got a rawhide report (bug #908143) and the first two attachments are unreadable, one of them is backtrace. They are encoded in base64 (and seem to be incomplete).

--- Additional comment from Jakub Filak on 2013-02-07 10:34:37 CET ---

fixed in git

commit b911a7075296f1560f3ea56ef4739159d5349ce8
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Feb 7 09:07:14 2013 +0100

    reporter-bugzilla: use base64 XMLRPC type for encoded data instead of string type
    
    - obsolete: 'bugzilla.addAttachment' accepted base64 data in string variable
      and stored them in database decoded
    
    - current: 'Bug.add_attachment' accepts base64 data but it must be stored in
      base64 type, otherwise server doesn't decode the data and stores them as they
      are
    
    - related to issue #117
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>

--- Additional comment from Milan Crha on 2013-02-07 10:39:13 CET ---

Does it solve the strip issue too? I took the encoded string and after decode it didn't show full backtrace to me.

--- Additional comment from Jakub Filak on 2013-02-07 11:26:47 CET ---

(In reply to comment #2)
> Does it solve the strip issue too? I took the encoded string and after
> decode it didn't show full backtrace to me.

I hope so ;) We tested it and the backtrace was ok. Anyway, an update was pushed to the rawhide. If you have time to update the package and re-test, please do so and report the results here.
Comment 1 Jakub Filak 2013-02-07 10:28:54 EST

*** This bug has been marked as a duplicate of bug 908762 ***

Note You need to log in before you can comment on or make changes to this bug.