Bug 908762 - Attaches backtrace and other data encoded
Attaches backtrace and other data encoded
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
18
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
: 908755 908756 (view as bug list)
Depends On: 908210
Blocks: 908755 908756
  Show dependency treegraph
 
Reported: 2013-02-07 07:56 EST by Jiri Moskovcak
Modified: 2015-02-01 17:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 908210
Environment:
Last Closed: 2013-03-25 19:02:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2013-02-07 07:56:36 EST
+++ This bug was initially created as a clone of Bug #908210 +++

I just got a rawhide report (bug #908143) and the first two attachments are unreadable, one of them is backtrace. They are encoded in base64 (and seem to be incomplete).

--- Additional comment from Jakub Filak on 2013-02-07 04:34:37 EST ---

fixed in git

commit b911a7075296f1560f3ea56ef4739159d5349ce8
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu Feb 7 09:07:14 2013 +0100

    reporter-bugzilla: use base64 XMLRPC type for encoded data instead of string type
    
    - obsolete: 'bugzilla.addAttachment' accepted base64 data in string variable
      and stored them in database decoded
    
    - current: 'Bug.add_attachment' accepts base64 data but it must be stored in
      base64 type, otherwise server doesn't decode the data and stores them as they
      are
    
    - related to issue #117
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>

--- Additional comment from Milan Crha on 2013-02-07 04:39:13 EST ---

Does it solve the strip issue too? I took the encoded string and after decode it didn't show full backtrace to me.

--- Additional comment from Jakub Filak on 2013-02-07 05:26:47 EST ---

(In reply to comment #2)
> Does it solve the strip issue too? I took the encoded string and after
> decode it didn't show full backtrace to me.

I hope so ;) We tested it and the backtrace was ok. Anyway, an update was pushed to the rawhide. If you have time to update the package and re-test, please do so and report the results here.
Comment 1 Fedora Update System 2013-02-07 08:03:15 EST
abrt-2.1.1-1.fc17,libreport-2.1.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.1.1-1.fc17,libreport-2.1.1-1.fc17
Comment 2 Fedora Update System 2013-02-07 08:05:22 EST
abrt-2.1.1-1.fc18,libreport-2.1.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.1.1-1.fc18,libreport-2.1.1-1.fc18
Comment 3 Jakub Filak 2013-02-07 10:28:47 EST
*** Bug 908755 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Filak 2013-02-07 10:28:54 EST
*** Bug 908756 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-02-08 11:53:31 EST
Package abrt-2.1.1-1.fc18, libreport-2.1.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.1.1-1.fc18 libreport-2.1.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2111/abrt-2.1.1-1.fc18,libreport-2.1.1-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-03-20 04:44:18 EDT
abrt-2.1.2-1.fc17,libreport-2.1.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.1.2-1.fc17,libreport-2.1.2-1.fc17
Comment 7 Fedora Update System 2013-03-20 04:55:42 EDT
abrt-2.1.2-1.fc18,libreport-2.1.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.1.2-1.fc18,libreport-2.1.2-1.fc18
Comment 8 Fedora Update System 2013-03-25 19:03:08 EDT
abrt-2.1.2-2.fc18, libreport-2.1.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.