Bug 90985 - quotas fail with kernel-2.4.20-13.7
quotas fail with kernel-2.4.20-13.7
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On: 90914
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-16 00:11 EDT by Craig Richardson
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-03 06:16:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Richardson 2003-05-16 00:11:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I upgraded my kernel RPMS via Red Hat network to kernel-2.4.20-13.7

Now it will not enable quota management and when you try to use the
quotaon/quotaoff commands you get the error;

- quotaon: using /home/quota.user on /dev/sda2: Invalid argument

However in all previous 7.3 kernels the quota file has been called aquota.user
and thats what I've used.  I tried making a quota.user file for this new kernel
and it still gives the same error when the quotaon command is issued.

Booting into an previous kernel (ie kernel-2.4.18-27.7.x) fixes the problem. 
However seeing the new buggy version is a security release I'd rather not do this.

I have had this problem on multiple production 7.3 machines.  One of which is
using the SMP kernel.  The SMP version also would not mount my  partitions as
read/write with the "defaults" option specified in /etc/fstab.  It would if I
specified "defaults,rw,usrquota", however this is still a bug as the default
should be read/write.  Perhaps this should be another bug report.

Version-Release number of selected component (if applicable):
kernel-2.4.20-13.7

How reproducible:
Always

Steps to Reproduce:
1. Boot into affected kernel
2. add usrquota option to /etc/fstab
3. mount -o remount /home
4. touch /home/aquota.user
5. checkquota /home
6. quotaon /home

Once this is done it will also produce the error when it tried to start quotas
during bootup. The command "dmesg | less" will show the error.

Actual Results:  quotaon: using /home/quota.user on /dev/sda2: Invalid argument

Expected Results:  Quota management should be enabled

Additional info:
Comment 1 Craig Richardson 2003-05-16 00:18:53 EDT
Thought I should also mention that I have some production RH 8.0 machines with
quotas enabled and they dont suffer from this.  They are running kernel-2.4.20-13.8
Comment 2 Danny Yee 2003-05-16 04:30:57 EDT
This is a dupe of bug 90939.
Comment 3 Petri T. Koistinen 2003-06-02 13:46:37 EDT
Please, close this bug as duplicate and wait for kernel and quota update.
Comment 4 Arjan van de Ven 2003-06-03 06:16:18 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2003-187.html

Note You need to log in before you can comment on or make changes to this bug.