Bug 90939 - Quotas problem with new kernel 2.4.20-13.7
Quotas problem with new kernel 2.4.20-13.7
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brock Organ
: Security
: 91048 (view as bug list)
Depends On: 73608 90914
  Show dependency treegraph
Reported: 2003-05-15 12:43 EDT by Abel Hernandez Zanatta
Modified: 2007-03-27 00:03 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-03 06:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Abel Hernandez Zanatta 2003-05-15 12:43:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After update to the latest security update kernel-2.4.20-13.7 quotas didn't work
Apparently something is broke with the new kernel, because of an error at the
booting time of the computer with the new kernel.

It reports an error like:

quotaon using /data/quota.user on /dev/hdc1: inavlid argument

It is using quota.user instead of aquota.user

With the previous kernel 2.4.18-27.7.x everything was working fine.

Version-Release number of selected component (if applicable):
quota-3.03-1 and kernel-2.4.20-13.7

How reproducible:

Steps to Reproduce:
1.boot with latest kernel release

Actual Results:  Same error:

quotaon using /data/quota.user on /dev/hdc1: inavlid argument

Expected Results:  start quotoas without a problem

Additional info:
Comment 1 Chris Jaeger 2003-05-15 15:28:47 EDT
I've encountered this as well
Comment 2 Juanjo Villaplana 2003-05-16 03:26:08 EDT
I have found the same problem on Red Hat Linux 7.2 with quota-3.01pre9-3 and

With kernel-smp-2.4.18-27.7.x quotas work fine.
Comment 3 Leos Bitto 2003-05-16 13:14:31 EDT
It happened to me too: RH 7.3, kernel 2.4.20-13.7smp
Comment 4 Byron Miller 2003-05-17 10:32:38 EDT
I have the same issues.  Running RedHat 7.3 server and quota's no longer work 
correctly after upgrade.

May 14 19:21:12 svr1 kernel: Loaded 17298 symbols from /boot/System.map-2.4.20-
May 14 19:21:12 svr1 kernel: Symbols match kernel version 2.4.20.
May 14 19:21:12 svr1 kernel: Loaded 219 symbols from 7 modules.
May 14 19:21:12 svr1 kernel: Linux version 2.4.20-13.7 
(bhcompile@stripples.devel.redhat.com) (gcc version 2.96 20000731 (Red Hat Li
nux 7.3 2.96-113)) #1 Mon May 12 13:13:52 EDT 2003
May 14 19:21:13 svr1 kernel: 127MB HIGHMEM available.
May 14 19:21:13 svr1 kernel: 896MB LOWMEM available.
May 14 19:21:13 svr1 kernel: On node 0 totalpages: 262128
May 14 19:21:13 svr1 kernel: zone(0): 4096 pages.
May 14 19:21:13 svr1 : virtualhosting: [warning] /sbin/quotaon -au failed
May 14 19:21:13 svr1 kernel: zone(1): 225280 pages.
May 14 19:21:13 svr1 : virtualhosting: [warning] /sbin/quotaon -ag failed
May 14 19:21:13 svr1 kernel: zone(2): 32752 pages.
May 14 19:21:13 svr1 virtualhosting: 
May 14 19:21:13 svr1 kernel: Kernel command line: auto BOOT_IMAGE=linux.newa 
ro root=302 BOOT_FILE=/boot/vmlinuz-2.4.20-13.7
May 14 19:21:13 svr1 rc: Starting virtualhosting:  succeeded
May 14 19:21:13 svr1 kernel: Initializing CPU#0
May 14 19:21:13 svr1 kernel: Detected 1992.652 MHz processor.
May 14 19:21:13 svr1 kernel: Console: colour VGA+ 80x25

rpm -qa | grep quota

Comment 5 Petri T. Koistinen 2003-05-17 11:07:23 EDT
bug #91048 is a duplicate of this. Please, raise your priority to high and
severity to security.
Comment 6 Petri T. Koistinen 2003-05-17 11:11:15 EDT
bug 91022 might be releated bug about quotacheck.
Comment 7 Petri T. Koistinen 2003-05-17 11:13:50 EDT
*** Bug 91048 has been marked as a duplicate of this bug. ***
Comment 8 Petri T. Koistinen 2003-05-17 16:06:26 EDT
On bug 90985 Craig Richardson says that this bug is not present with RHL 8.0.
I am just wondering if this bug has something to do with bug 73244?
Comment 9 Michael Schwendt 2003-05-17 16:21:46 EDT
This bug is not present with RHL 9 (2.4.20-13.9 kernel) either. That's why it
was reported about RHL 7.3. It seems to be specific to 7.3.
Comment 10 Petri T. Koistinen 2003-05-17 17:31:41 EDT
Juanjo Villaplana said before on this bugreport that this applies to 7.2 too.
Comment 11 Petri T. Koistinen 2003-05-18 09:52:11 EDT
I got message to track this bug, so seems that Red Hat Security Response Team
have acknowledged this bug, this is good sign. I hope errata will be available soon.
Comment 12 Need Real Name 2003-05-18 09:53:22 EDT
Me too:

kernel-2.4.20-13.7, quota-3.03-1:

[root@ns]# quotaon -uga
quotaon: using //quota.group on /dev/hda2: Invalid argument
quotaon: using //quota.user on /dev/hda2: Invalid argument

Redhat 7.3.

Comment 13 David Brieck Jr. 2003-05-19 11:13:18 EDT
Me too, 7.3, had to downgrade back to 2.4.18-27.7.xsmp
Comment 14 Eric Pare 2003-05-26 11:02:09 EDT
Applies to RHL 7.1 kernel 2.4.20-13.7smp quota quota-3.01pre9-0.7.1
Comment 15 Petri T. Koistinen 2003-05-26 11:03:34 EDT
Is it Red Hat's policy to not give official acknowledgement that bug existsbefore the errata is released? Well, this bug proofs that there isn't suchthing as free and fast security service. There is something wrong with therelease engineering process as this kind of bug could slip in. Maybe they arenow doing extra sanity checks so this won't happen again. There is no silverbullet nor free lunch. On the other hand there is free distributed debugingprocess available to Red Hat, that's us. ;-)
Comment 16 Arjan van de Ven 2003-05-26 11:08:28 EDT
our quota maintainer is investigating this issue but hasn't come up with a
solution yet.
Comment 17 Diego Soldano 2003-05-27 04:28:18 EDT

  I have the same problem.

If it can help  to find the    solution, this is what I did to
get quota working:


 - downloaded  kernel-source-2.4.20-13.7.i386.rpm

 - I ran "make menuconfig" and configured the following options

      [*] Quota support
      <*>   Old quota format support
      <*>   VFS v0 quota format support
      [*]   Compatible quota interfaces 
      (VFSv0)      Compatible quota interfaces

With this kernel it seems working . The system has quota-3.03-1.i386.rpm
installed, and the   quota is the version 2 ( aquota.user ) 

 Of course it would be nice to avoid recompiling the kernel , but
 to have the kernel binary rpm ready to install.


Comment 18 Petri T. Koistinen 2003-05-27 07:10:14 EDT
So is this realy quota or kernel default configuration problem?
Comment 19 Diego Soldano 2003-05-27 07:24:48 EDT
I do not know...
I'm waiting for a response from RedHat quota maintainer( see comment

I suppose the problem could be in the kernel configuration;
the Configure.help file coming with the kernel source rpm  2.4.20-13.7
is not upto date because it's referring to kernel 2.4.19+; there is no help
about "quota format support".  
Comment 20 Need Real Name 2003-05-29 10:44:14 EDT
I am also seeing this on RH 7.2 - same kernel  2.4.20-13.7

#> quotaon -auv
quotaon: using /export/home/quota.user on /dev/sda5: Invalid argument
quotaon: using /export/home1/quota.user on /dev/sdb1: Invalid argument
quotaon: using /export/home2/quota.user on /dev/sdb3: Invalid argument
#> uname -a
Linux clamp.thebook.com 2.4.20-13.7smp #1 SMP Mon May 12 12:31:27 EDT 2003 i686 

If I reboot back to the prior kernel 2.4.18-27.7.xsmp  the quotas are working 

#> quotaon -f -auv
/dev/sda5 [/export/home]: user quotas turned off
/dev/sdb1 [/export/home1]: user quotas turned off
/dev/sdb3 [/export/home2]: user quotas turned off
#> quotaon -auv
/dev/sda5 [/export/home]: user quotas turned on
/dev/sdb1 [/export/home1]: user quotas turned on
/dev/sdb3 [/export/home2]: user quotas turned on
#> uname -a 
Linux clamp.thebook.com 2.4.18-27.7.xsmp #1 SMP Fri Mar 14 05:52:30 EST 2003 
i686 unknown
Comment 21 clemdog 2003-05-31 08:10:34 EDT
I read somewhere that RH 9 quota-3.06-9 would fix this issue on Rh 7.3. If you 
download the quota-3.06-9.src.rpm from RH9 and do a rpm --rebuild quota-3.06-
9.src.rpm and then install the new rpm it corrects the quota problem with 
Kernel 2.4.20-13.7 on RH 7.3. It worked for me.
Comment 22 Gilles CHAUVIN 2003-05-31 11:48:02 EDT
This bug is a duplicate of bug #90914.
Comment 23 Petri T. Koistinen 2003-06-02 13:52:12 EDT
Reporter: Please close as this is duplicate of bug #90914.
Comment 24 Eric Pare 2003-06-02 14:22:44 EDT
This bug applies to RHL 7.1.  Installing the latest version of quota needs newer
version of initscripts, needs newer version of mount and so on (HELL).  Will
there be a newer version of quota for RHL 7.1 and 7.2 or will this issue be
closed ?  Should I simply recompile the bundled kernel (2.4.20-13.7) ?  Should I
simply wait a little more ?
Comment 25 Arjan van de Ven 2003-06-03 06:16:12 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

Comment 26 Marcis 2003-06-24 19:22:41 EDT
I am still getting the same problem even after upgrading to kernel 2.4.20-
I edited my 
/etc/fstab to have LABEL=/  /  ext3  defaults,grpquota,usrquota  0  1.  
Rebooted the computer, but when I use quotaon -aug I get

quotaon: using //quota.group on /dev/hda2: Invalid argument
quotaon: using //quota.user on /dev/hda2: Invalid argument

quota-3.03-1  Can I upgrade my quota software somehow?  I couldn't find any 
rpms for i686
Comment 27 Michael Schwendt 2003-06-25 04:37:48 EDT
Don't say you haven't installed any i386 package before!

Note You need to log in before you can comment on or make changes to this bug.