Bug 914030 - geronimo-saaj: FTBFS in rawhide
geronimo-saaj: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: geronimo-saaj (Show other bugs)
rawhide
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Triaged
Depends On: 914651
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:26 EST by Dennis Gilmore
Modified: 2013-03-12 04:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 04:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:26:07 EST
Your package geronimo-saaj failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4961736

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/1736/4961736/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/1736/4961736/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/1736/4961736/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Mikolaj Izdebski 2013-02-22 07:33:18 EST
So far this package doesn't build in rawhide because
of broken bouncycastle-main, see bug #914574 for more details.

I am adding dependency on bug #914574 and I will investigate
the real cause of the FTBFS once bouncycastle-mail is fixed.
Comment 2 Mikolaj Izdebski 2013-02-22 07:36:57 EST
In comment #1 I meant bug #914651, not bug #914574.
Fixing bug dependency. Sorry.
Comment 3 Mikolaj Izdebski 2013-02-26 04:01:22 EST
Cause:

geronimo-saaj requires artifact org.apache.geronimo.specs:geronimo-activation_1.1_spec which is not provided by any package.
Comment 4 Mikolaj Izdebski 2013-02-28 08:04:52 EST
I just sis a scratch build and this package still
fails to build from source in rawhide:

Package geronimo-saaj (5064086):
  noarch (5064150):
    build.log           : http://kojipkgs.fedoraproject.org/work/tasks/4150/5064150/build.log
    state.log           : http://kojipkgs.fedoraproject.org/work/tasks/4150/5064150/state.log
    mock_output.log     : http://kojipkgs.fedoraproject.org/work/tasks/4150/5064150/mock_output.log
    root.log            : http://kojipkgs.fedoraproject.org/work/tasks/4150/5064150/root.log
Comment 5 Mikolaj Izdebski 2013-02-28 08:20:31 EST
Geronimo parent POM missing.
Comment 6 Mikolaj Izdebski 2013-03-12 04:31:22 EDT
Fixed in geronimo-saaj-1.1-11
Comment 7 Mikolaj Izdebski 2013-03-12 04:44:38 EDT
I believe that this bug is fixed in geronimo-saaj-1.1-11,
which is available in Fedora Rawhide, so I am closing this bug now.
Thank you for reporting it.  You are welcome to submit any further reports.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=401857

Note You need to log in before you can comment on or make changes to this bug.