Bug 914173 - maven-plugin-bundle: FTBFS in rawhide
maven-plugin-bundle: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-plugin-bundle (Show other bugs)
rawhide
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Triaged
Depends On: 920042
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 04:43 EST by Dennis Gilmore
Modified: 2013-03-11 10:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.3.7-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 10:47:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 04:43:53 EST
Your package maven-plugin-bundle failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4967975

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/7975/4967975/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/7975/4967975/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/7975/4967975/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Mikolaj Izdebski 2013-02-22 07:33:17 EST
So far this package doesn't build in rawhide because
of broken bouncycastle-main, see bug #914574 for more details.

I am adding dependency on bug #914574 and I will investigate
the real cause of the FTBFS once bouncycastle-mail is fixed.
Comment 2 Mikolaj Izdebski 2013-02-22 07:36:56 EST
In comment #1 I meant bug #914651, not bug #914574.
Fixing bug dependency. Sorry.
Comment 3 Mikolaj Izdebski 2013-02-28 08:05:14 EST
I just sis a scratch build and this package still
fails to build from source in rawhide:

Package maven-plugin-bundle (5064099):
  noarch (5064144):
    build.log           : http://kojipkgs.fedoraproject.org/work/tasks/4144/5064144/build.log
    state.log           : http://kojipkgs.fedoraproject.org/work/tasks/4144/5064144/state.log
    mock_output.log     : http://kojipkgs.fedoraproject.org/work/tasks/4144/5064144/mock_output.log
    root.log            : http://kojipkgs.fedoraproject.org/work/tasks/4144/5064144/root.log
Comment 4 Mikolaj Izdebski 2013-02-28 08:23:47 EST
NPE in maven-plugin-plugin
Comment 5 Mikolaj Izdebski 2013-03-11 10:28:40 EDT
Fixed in maven-plugin-bundle-2.3.7-6
Comment 6 Mikolaj Izdebski 2013-03-11 10:47:35 EDT
I believe that this bug is fixed in maven-plugin-bundle-2.3.7-6,
which is available in Fedora Rawhide, so I am closing this bug now.
Thank you for reporting it.  You are welcome to submit any further reports.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=389525

Note You need to log in before you can comment on or make changes to this bug.