Bug 916672 (perl-Any-URI-Escape) - Review Request: perl-Any-URI-Escape - Load URI::Escape::XS preferentially over URI::Escape
Summary: Review Request: perl-Any-URI-Escape - Load URI::Escape::XS preferentially ove...
Keywords:
Status: CLOSED ERRATA
Alias: perl-Any-URI-Escape
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 916670
Blocks: 916679
TreeView+ depends on / blocked
 
Reported: 2013-02-28 16:10 UTC by Emmanuel Seyman
Modified: 2013-04-19 04:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-19 04:51:18 UTC
psabata: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Emmanuel Seyman 2013-02-28 16:10:58 UTC
Spec URL: http://people.parinux.org/~seyman/fedora/perl-Any-URI-Escape/perl-Any-URI-Escape.spec
SRPM URL: http://people.parinux.org/~seyman/fedora/perl-Any-URI-Escape/perl-Any-URI-Escape-0.01-1.fc18.src.rpm
Description:
URI::Escape is great, but URI::Escape::XS is faster. This module loads
URI::Escape::XS and imports the two most common methods if XS is installed.

Fedora Account System Username: eseyman

Comment 1 Petr Šabata 2013-03-08 09:55:08 UTC
Missing BRs:
perl(base) from lib/Any/URI/Escape.pm:14
perl(Exporter) from lib/Any/URI/Escape.pm:14

Again, line 33 could be safely removed.

You could also utilize your other new package instead of URI::Escape to make the test slightly faster :)

And finally, you have to run-require either perl(URI::Escape) or perl(URI::Escape::XS).  Neither is autodetected by RPM.

Comment 2 Emmanuel Seyman 2013-03-10 18:05:03 UTC
(In reply to comment #1)
>
> Missing BRs:
> perl(base) from lib/Any/URI/Escape.pm:14
> perl(Exporter) from lib/Any/URI/Escape.pm:14

Done.

> Again, line 33 could be safely removed.

Done.

 
> And finally, you have to run-require either perl(URI::Escape) or
> perl(URI::Escape::XS).  Neither is autodetected by RPM.

I've required perl(URI::Escape).

Spec URL: http://people.parinux.org/~seyman/fedora/perl-Any-URI-Escape/perl-Any-URI-Escape.spec
SRPM URL: http://people.parinux.org/~seyman/fedora/perl-Any-URI-Escape/perl-Any-URI-Escape-0.01-2.fc18.src.rpm

Comment 3 Petr Šabata 2013-03-11 12:34:07 UTC
Wonderful.  Approving.

Comment 4 Emmanuel Seyman 2013-03-12 20:03:13 UTC
New Package SCM Request
=======================
Package Name: perl-Any-URI-Escape
Short Description: Load URI::Escape::XS preferentially over URI::Escape
Owners: eseyman
Branches: f18 f19
InitialCC: perl-sig

Comment 5 Gwyn Ciesla 2013-03-12 20:05:23 UTC
Git done (by process-git-requests).

Comment 6 Petr Šabata 2013-04-10 08:44:41 UTC
I see you've imported and built this package for f18+ a month ago.  I can't see any updates in bodhi, though.  Do you plan to push them?

Comment 7 Fedora Update System 2013-04-10 09:29:47 UTC
perl-Any-URI-Escape-0.01-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Any-URI-Escape-0.01-2.fc18

Comment 8 Emmanuel Seyman 2013-04-10 09:30:58 UTC
I forgot about this package. Thanks for the reminder.

Comment 9 Petr Šabata 2013-04-10 13:16:54 UTC
Don't forget you need to submit an f19 update now too :)

Comment 10 Fedora Update System 2013-04-11 10:04:44 UTC
Package perl-Any-URI-Escape-0.01-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Any-URI-Escape-0.01-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5361/perl-Any-URI-Escape-0.01-2.fc18
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-04-19 04:51:21 UTC
perl-Any-URI-Escape-0.01-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.