Bug 91689 - gnome help system show russian man pages in raw utf-8
gnome help system show russian man pages in raw utf-8
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: yelp (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 104045 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-05-27 04:33 EDT by Leonid Kanter
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-14 06:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yelp snapshot with raw utf-8 (38.04 KB, image/png)
2003-05-27 04:38 EDT, Leonid Kanter
no flags Details
patch that fixes this problem (2.57 KB, patch)
2003-05-27 04:57 EDT, Leonid Kanter
no flags Details | Diff
This is how it looks with patch applied (58.54 KB, text/plain)
2003-05-27 05:16 EDT, Leonid Kanter
no flags Details

  None (edit)
Description Leonid Kanter 2003-05-27 04:33:42 EDT
Description of problem:

If you install beta2 in Russian and try to open any translated manual page in
gnome help system (yelp), it will be shown in raw utf8. All other languages are
affected too.

Version-Release number of selected component (if applicable):

libgnome-2.2.0.1-8

How reproducible:

always

Steps to Reproduce:
1. install alpha2 with Russian language support enabled
2. try to open man cp in yelp
    
Actual results:

raw utf-8

Expected results:

cyrillic text

Additional info:

yelp is using gtkhtml2 and acts like regular browser. If encoding of html isn't
set, browser don't know how to show this page properly. Since all international
man pages in redhat are in utf-8, /usr/libexec/gnome2-man2html must always add
encoding=utf-8 to resulting html.
Comment 1 Leonid Kanter 2003-05-27 04:38:05 EDT
Created attachment 91988 [details]
yelp snapshot with raw utf-8
Comment 2 Leonid Kanter 2003-05-27 04:57:49 EDT
Created attachment 91989 [details]
patch that fixes this problem

This patch always adds <META http-equiv="Content-Type" content="text/html;
charset=UTF-8"> to resulting html
Comment 3 Leonid Kanter 2003-05-27 05:16:54 EDT
Created attachment 91990 [details]
This is how it looks with patch applied
Comment 4 Alexander Larsson 2003-08-27 12:40:37 EDT
Fixed in yelp 2.3.6-2.
Comment 5 Alexander Larsson 2003-08-27 13:02:48 EDT
Hmm, it doesn't work perfectly. Now it works in a utf8 locale, but not in a
non-utf8 locale. It really needs to set the charset when calling man.
Comment 6 Alexander Larsson 2003-09-10 11:46:39 EDT
Should be fixed in yelp 2.4.0-1
Comment 7 Alexander Larsson 2003-09-11 03:41:26 EDT
*** Bug 104045 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2005-05-12 11:52:36 EDT
Hi,
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)
Comment 9 Leonid Kanter 2005-05-14 06:34:17 EDT
Tested yelp-2.9.3 on man rpm - russian is ok

Note You need to log in before you can comment on or make changes to this bug.