Bug 92222 - elinks dialog boxes and menus are garbled at text console
Summary: elinks dialog boxes and menus are garbled at text console
Status: CLOSED DUPLICATE of bug 76445
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: elinks   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-06-03 22:40 UTC by Barry K. Nathan
Modified: 2007-04-18 16:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:53:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Barry K. Nathan 2003-06-03 22:40:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030530

Description of problem:
When elinks is run at a text console, the borders on the dialog boxes and menus
are terribly garbled. This does not happen in xterm, gnome-terminal, or konsole.

For all I know, this could be some kind of library problem or something, and not
a bug in elinks itself. However, in Red Hat 9 and Raw Hide I have not seen this
problem in any other programs.

Version-Release number of selected component (if applicable):
elinks-0.4.2-4.1

How reproducible:
Always

Steps to Reproduce:
1. Log in at a text console.
2. Run "links".
3. Press "G".
4. Enter a URL (such as "http://slashdot.org/", although any valid page will do).
5. Press "Escape".
6. Use the arrow keys to scroll up/down a menu.
    

Actual Results:  At steps 3/4, the dialog box border is garbled. At step 6, the
menu's borders are not (re)drawn properly and also look like garbage.

Expected Results:  Dialog box and menu borders with the proper appearance.

Additional info:

[barryn@i5000e barryn]$ set | egrep '^(LC|LANG)'
LANG=en_US.UTF-8
[barryn@i5000e barryn]$ cat /etc/redhat-release
Raw Hide 20030603

This bug also happens with the RHL 9 version of elinks on an RHL 9 system.

Running "unicode_stop" before "links" seems to be a workaround.

Comment 1 Bill Nottingham 2003-07-24 22:42:44 UTC
elinks has it's own linedrawing code, IIRC.

Comment 2 Miloslav Trmac 2003-07-28 21:21:44 UTC
As a "new" user:
* Start links
* Press Esc to open the menu
* Setup//Terminal Options//UTF-8 I/O
* Enjoy correctly drawn menus.

Maybe this should be set by default, or the value should be autodetected
from locale name.

Comment 3 Barry K. Nathan 2004-03-14 04:59:51 UTC

*** This bug has been marked as a duplicate of 76445 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:53:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.