Bug 76445 - elinks cannot display UTF-8
Summary: elinks cannot display UTF-8
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: elinks   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 92222 100429 107352 117156 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-21 21:16 UTC by Christian Rose
Modified: 2007-04-18 16:47 UTC (History)
6 users (show)

Fixed In Version: 0.9.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-28 08:20:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Makes UTF-8 I/O the default (532 bytes, patch)
2004-05-27 21:43 UTC, Daniel Hokka Zakrisson
no flags Details | Diff

Description Christian Rose 2002-10-21 21:16:21 UTC
elinks seems to be unable of displaying UTF-8 (it's not available in the 
encoding menu at least), which is very unfortunate in a UTF-8 locale 
environment like is being installed by default in RHL 8.0. It would be great if 
elinks could support UTF-8.

Comment 1 Miloslav Trmac 2002-10-23 09:44:02 UTC
As a workaround, set character set to iso-8859-1 (or what you would
usually use), and run
        LC_ALL=your-locale_without_utf8 luit links
You get only 256 characters, but it works about as well as in RHL 7.3.

Comment 2 Tim Waugh 2003-07-22 10:44:17 UTC
*** Bug 100429 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2003-10-17 10:34:47 UTC
*** Bug 107352 has been marked as a duplicate of this bug. ***

Comment 4 Tim Waugh 2004-03-11 16:43:50 UTC
*** Bug 117156 has been marked as a duplicate of this bug. ***

Comment 5 Tim Waugh 2004-03-11 17:21:56 UTC
Set UTF-8 I/O on in your terminal options -- does that make the
problem go away?

Comment 6 Barry K. Nathan 2004-03-14 04:59:53 UTC
*** Bug 92222 has been marked as a duplicate of this bug. ***

Comment 7 Barry K. Nathan 2004-03-14 05:00:58 UTC
In my case, at least, setting UTF-8 I/O in the terminal options does
make the problem go away.

Comment 8 Daniel Hokka Zakrisson 2004-05-25 21:34:26 UTC
This bug is still present on Fedora Core 2, in a no-X environment.

Comment 9 Daniel Hokka Zakrisson 2004-05-27 21:43:56 UTC
Created attachment 100644 [details]
Makes UTF-8 I/O the default

... and now that I've learned to read, turning on UTF-8 I/O does indeed make
the problem go away.

Comment 10 Tim Waugh 2004-05-28 08:20:29 UTC
Thanks.  Patch applied in 0.9.1-2.


Note You need to log in before you can comment on or make changes to this bug.