Bug 929177 - in text install, "Create user" and "Set root password" are swapped in i386 vs. x86_64
Summary: in text install, "Create user" and "Set root password" are swapped in i386 vs...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Samantha N. Bueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedFreezeException
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-29 11:46 UTC by Andre Robatino
Modified: 2013-11-29 21:23 UTC (History)
12 users (show)

Fixed In Version: python-blivet-0.23.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-29 13:55:56 UTC


Attachments (Terms of Use)
screenshot for 19 Alpha TC3 i386 install image (15.71 KB, image/png)
2013-03-29 11:46 UTC, Andre Robatino
no flags Details
screenshot for 19 Alpha TC3 x86_64 install image (15.73 KB, image/png)
2013-03-29 11:47 UTC, Andre Robatino
no flags Details

Description Andre Robatino 2013-03-29 11:46:20 UTC
Created attachment 718040 [details]
screenshot for 19 Alpha TC3 i386 install image

Description of problem:
Doing a text install from a 19 Alpha TC3 install image (either netinst or DVD), for i386, "Create user" and "Set root password" are numbered 3 and 4, resp. For x86_64, it's 4 and 3. I believe that in TC1 and TC2, it was always 4 and 3.

Version-Release number of selected component (if applicable):
19 Alpha TC3 install images

How reproducible:
Probably always. Either that or it's random. Either way, it's wrong.

Comment 1 Andre Robatino 2013-03-29 11:47:11 UTC
Created attachment 718041 [details]
screenshot for 19 Alpha TC3 x86_64 install image

Comment 2 Andre Robatino 2013-03-29 11:49:11 UTC
Kamil Páral thought bug 750527 might be related.

Comment 3 Andre Robatino 2013-03-30 08:02:31 UTC
In TC1 and TC2, I believe "Set root password" was always on the left (numbered 3), which also matches the layout in the GUI (root account on left, user account on right).

Comment 4 Chris Lumens 2013-04-01 14:40:30 UTC
This might just be due to sorting problems.  The GUI sorts by title.  I don't know that the text UI sorts by anything.

Comment 5 Andre Robatino 2013-04-04 08:32:18 UTC
In 19 Alpha TC4 (anaconda 19.15), all four install images have "Set root password" on the left again (numbered 3). Was there a fix?

Comment 6 Andre Robatino 2013-04-05 15:35:14 UTC
In 19 Alpha TC5, all four install images have "Set root password" on the right.

Comment 7 Andre Robatino 2013-04-09 03:48:01 UTC
In 19 Alpha RC1, both 32-bit install images have "Set root password" on the left, and both 64-bit install images have it on the right.

Comment 8 Andre Robatino 2013-04-10 11:52:42 UTC
In 19 Alpha RC2, "Set root password" is on the right for all four install images.

Comment 9 Andre Robatino 2013-04-13 12:14:54 UTC
In 19 Alpha TC6, "Set root password" is on the right for both 32-bit install images, and on the left for both 64-bit install images.

Comment 10 Andre Robatino 2013-04-16 08:42:05 UTC
In 19 Alpha RC3, "Set root password" is on the left for both 32-bit install images, and on the right for both 64-bit install images.

Comment 11 Andre Robatino 2013-04-17 19:28:51 UTC
In 19 Alpha RC4, "Set root password" is on the right for both 32-bit install images, and on the left for both 64-bit install images.

As far as I remember, "Timezone settings" is always 1), and "Install Destination" is always 2). It's only 3) and 4) which get swapped.

Comment 12 Andre Robatino 2013-05-02 02:52:38 UTC
In 19 Beta TC2, "Set root password" is on the left for 32-bit, and on the right for 64-bit. From now on I'm going to indicate the current random order on the install test matrix instead of in this bug.

Comment 13 Pavel Holica 2013-05-17 08:19:30 UTC
I've just seen this issue on armhfp (which is 32bit too) on Fedora 19 Beta RC2.

"Set root password" is on the right side, on x86_64 on the left side.

Comment 14 Kamil Páral 2013-10-21 06:35:50 UTC
The same problem was reported with F20 Beta TC5 in https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_TC5_Install . Changing version.

Comment 15 Tao Wu 2013-11-01 08:42:10 UTC
In F20 Beta TC6 i386, "Set root password" is no 2 while "Create user" is no3.

Comment 16 Samantha N. Bueno 2013-11-01 16:38:02 UTC
Patch posted for review.

Comment 17 Andre Robatino 2013-11-01 16:48:09 UTC
Thanks. The Summary is a little misleading - it doesn't just switch randomly between i386 and x86_64, but in each compose. The only thing that's consistent is that the DVD and netinst for each arch are always the same (for example, i386 DVD and i386 netinst). I've been posting the position of "Set root password" for both i386 an x86_64 in the install test matrices for each TC and RC. Is the patch intended to make the root password always come before the user password? This would be consistent with the GUI where root and user passwords are on the left and right, resp.

Comment 18 Samantha N. Bueno 2013-11-01 17:38:51 UTC
(In reply to Andre Robatino from comment #17)
> Is the patch intended to make the root password always come
> before the user password? This would be consistent with the GUI where root
> and user passwords are on the left and right, resp.

There was different/bad logic used for sorting the spokes in text-mode. My patch fixes it so that text-mode uses the same logic as graphical mode to sort the spokes.

All spokes will display in an order closely resembling the GUI. This means the root password and user creation are now at the end as well, since this mirrors graphical behavior as closely as possible.
The root password spoke will always come before the user creation spoke, numerically. Its placement on the screen is dependent upon whether there are an even or odd number of spokes.

Here's a screenshot of the new order: http://sbueno.fedorapeople.org/images/spokes-sorted.png

If you want to test it out, there is an updates.img posted here: http://sbueno.fedorapeople.org/updates/929177.img

It should work with F20 Beta TC06.

Comment 19 Fedora Blocker Bugs Application 2013-11-01 18:07:59 UTC
Proposed as a Freeze Exception for 20-beta by Fedora user sbueno using the blocker tracking app because:

 Fix for this syncs behavior visible to users between graphical and text mode, as well as under-lying logic.

Comment 20 Andre Robatino 2013-11-01 18:31:46 UTC
I checked the i386 and x86_64 DVD and netinst for 20 Beta TC4, TC5, and TC6 (total of 12 images) with this updates.img, and the spokes are as shown in your screenshot in each case. I didn't attempt any actual installs. Without the updates.img, there would be several differences, as documented in the test matrices. Thanks.

Comment 21 Samantha N. Bueno 2013-11-01 18:59:08 UTC
Good to hear. Patch pushed to master, commit ebf5aef. If this is an approved FE, I'll cherry pick the commit to f20-branch as well. For now I'll leave this in POST since it's filed against f20.

Comment 22 Andre Robatino 2013-11-01 20:14:18 UTC
I did a test install from Fedora-20-Beta-TC6-x86_64-DVD.iso and at first hit bug 1011555 by going into the "Installation source" spoke and selecting "CD/DVD drive" (see https://bugzilla.redhat.com/show_bug.cgi?id=1011555#c14 ). But I was then able to hit the same bug without the updates.img file, so the bug isn't related to this. Normally I don't go into that spoke, and by doing the install as usual, the install was successful.

Comment 23 Mike Ruckman 2013-11-06 17:56:01 UTC
Discussed in 2013-11-06 Blocker Review Meeting [1]. Voted as a RejectedFreezeException because the fix for this bug can bring more problems then benefits to bring it before go/no-go.Please push the patch once Beta freeze is over.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-06/

Comment 24 Andre Robatino 2013-11-21 04:31:39 UTC
Beta Freeze ended on Nov. 13. Final Freeze is scheduled for Nov. 26. This is still not fixed in 20 Final TC2.

Comment 25 Adam Williamson 2013-11-22 04:55:07 UTC
Samantha, can you please pull the patch into the 20 tree now?

Comment 26 Samantha N. Bueno 2013-11-25 16:47:24 UTC
Sure thing, thanks for the reminder. Commit d4417b299d9732b2c7608f55384395ec4ce30172 in f20-branch.

Comment 27 Fedora Update System 2013-11-26 02:34:58 UTC
python-blivet-0.23.6-1.fc20, anaconda-20.25.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/python-blivet-0.23.6-1.fc20,anaconda-20.25.11-1.fc20

Comment 28 Fedora Update System 2013-11-26 17:57:10 UTC
Package python-blivet-0.23.6-1.fc20, anaconda-20.25.11-1.fc20, pykickstart-1.99.48-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.23.6-1.fc20 anaconda-20.25.11-1.fc20 pykickstart-1.99.48-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21928/pykickstart-1.99.48-1.fc20,python-blivet-0.23.6-1.fc20,anaconda-20.25.11-1.fc20
then log in and leave karma (feedback).

Comment 29 Fedora Update System 2013-11-29 13:55:56 UTC
python-blivet-0.23.7-1.fc20, anaconda-20.25.12-1.fc20, pykickstart-1.99.48-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Pavel Holica 2013-11-29 14:07:56 UTC
I don't understand why this bug was closed because of bliveth? Something wrong going on here?

Comment 31 Adam Williamson 2013-11-29 16:59:19 UTC
it was closed by an update with blivet and anaconda and pykickstart in it. The 'fixed in version' field was wrongly changed by the update system, but it does look like anaconda 20.25.12 has the fix for this. check TC4 when it comes out and re-open if not.

Comment 32 Andre Robatino 2013-11-29 21:23:19 UTC
I did confirm that it was fixed in 20 Final TC3 (with anaconda-20.25.11-1).


Note You need to log in before you can comment on or make changes to this bug.