Bug 948099 - Apper ignores "never check for updates" option (also on the live image)
Summary: Apper ignores "never check for updates" option (also on the live image)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 928296 948685 (view as bug list)
Depends On: 953239
Blocks: F19Beta, F19BetaBlocker F19Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2013-04-04 01:53 UTC by nucleo
Modified: 2013-12-12 14:15 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-19 19:51:05 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 317838 0 None None None Never

Description nucleo 2013-04-04 01:53:47 UTC
Description of problem:
Never check for new updates Apper option ignored.

Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. Start F19 Alpha TC3 live image
2.
3.
  
Actual results:
Apper option "Check for new updates" set to Never but updates checked when KDE started that slows down live image.

Expected results:
Updates should not be checked.

Additional info:
After I removed "Software Updater" from systray and restarted KDE session new updates notification still appeared.

Comment 1 nucleo 2013-04-04 01:54:30 UTC
Version-Release number of selected component (if applicable):
apper-0.8.0-3.fc19

Comment 2 Kevin Kofler 2013-04-05 12:30:24 UTC
Nominating as Beta blocker and Alpha freeze exception because bug #948685 is nominated as these and it's a duplicate of this bug.

Comment 3 Kevin Kofler 2013-04-05 12:31:09 UTC
*** Bug 948685 has been marked as a duplicate of this bug. ***

Comment 4 Kevin Kofler 2013-04-05 12:34:38 UTC
Actually, it looks like the problem is not the plasmoid, but the underlying kded4 service (which is also part of the apper package).

Comment 5 Martin Krizek 2013-04-09 12:04:48 UTC
This has been already proposed as beta blocker: bug #928296 (http://qa.fedoraproject.org/blockerbugs/milestone/19/beta/buglist).

Comment 6 Rex Dieter 2013-04-23 15:44:19 UTC
*** Bug 928296 has been marked as a duplicate of this bug. ***

Comment 7 Adam Williamson 2013-04-24 00:15:06 UTC
why close the older one as a dupe of the newer one? oh well, no biggy.

Comment 8 nucleo 2013-04-24 00:24:06 UTC
This bug not only about live image, ignoring apper settings should be fixed also for installed systems.

Comment 9 Adam Williamson 2013-04-24 16:29:31 UTC
Discussed at 2013-04-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-24/f19beta-blocker-review-1.2013-04-24-16.00.log.txt . Accepted as a blocker per criterion https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Update_notification : "Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image."

Comment 10 Daniel Nicoletti 2013-04-29 13:21:03 UTC
Is it a is the bug about checking for new updates or about showing notification about updates?
Right now there is no way to disable the later, and the text is NOT about notification it's about to check with servers if there are updates.

Comment 11 Rex Dieter 2013-04-29 13:23:33 UTC
The former.  In short, we really do not want packagekitd to fetch repo metadata *at all* on the live image.

Comment 12 Rex Dieter 2013-04-29 13:24:16 UTC
(at least, not automatically on it's own accord)

Comment 13 Daniel Nicoletti 2013-04-29 13:29:38 UTC
So if the former I believe this is a yum backend bug, if you set to never check for updates what kded module will do is a call to GetUpdates just to see how much it has without asking to refresh-cache, I dunno why yum thinks it needs to be smarter and got refresh the cache first.

Comment 14 Daniel Nicoletti 2013-04-29 13:35:53 UTC
BTW not sure Richard told me this should fix something around yum:
https://bugzilla.redhat.com/show_bug.cgi?id=953239

Tho doesn't seem much related imo you should actually disable apper kded module on the live cd, it will eat less RAM and avoid this issue.

Comment 15 Fedora Update System 2013-04-29 14:22:52 UTC
apper-0.8.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/apper-0.8.0-4.fc19

Comment 16 Fedora Update System 2013-04-29 17:43:59 UTC
Package apper-0.8.0-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apper-0.8.0-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6940/apper-0.8.0-5.fc19
then log in and leave karma (feedback).

Comment 17 Rex Dieter 2013-04-29 17:48:49 UTC
Arg, still seeing /var/cache/yum ... get re-populated when empty

Try harder, by disabling apper kded module too:
https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=19912d72a1b0751532980a03a9520a88174c1361


Reassigning to PackageKit... Richard, Daniel asserts this to be a yum backend bug in comment #13 , can you verify or refute that claim?

Comment 18 Rex Dieter 2013-04-29 17:59:00 UTC
Tried the upstream fix referenced in comment #14 (see below), doesn't seem to help here.

-----------------------------------------------------

From 34f4863060ef804c075f3f0a1fc2ff88d458eb1f Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Wed, 24 Apr 2013 10:59:54 +0100
Subject: yum: Ensure conf.cache is set before repo.cache is created

This should fix the offline updates failures reported in
https://bugzilla.redhat.com/show_bug.cgi?id=953239 and others.
---
 backends/yum/yumBackend.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/backends/yum/yumBackend.py b/backends/yum/yumBackend.py
index 7c6f6f0..a5cbb18 100755
--- a/backends/yum/yumBackend.py
+++ b/backends/yum/yumBackend.py
@@ -3101,9 +3101,9 @@ class PackageKitYumBackend(PackageKitBaseBackend, PackagekitPackage):

         # we are working offline
         if not self.has_network:
+            self.yumbase.conf.cache = 1
             for repo in self.yumbase.repos.listEnabled():
                 repo.metadata_expire = -1  # never refresh
-            self.yumbase.conf.cache = 1

         # choose a good default if the client didn't specify a timeout
         if self.cache_age == 0:
-- 
1.8.1.4

Comment 19 Rex Dieter 2013-04-29 19:00:31 UTC
resorted to killing the plasma-update-applet altogether on kde live:

https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=95e68dc29e12c3777794fa27e1d2c7425418be7e

Comment 20 Adam Williamson 2013-05-03 00:55:20 UTC
That kickstart should have been used for Beta TC2, so can people please check with Beta TC2 and verify that this is fixed? Thanks!

Comment 21 nucleo 2013-05-03 01:30:38 UTC
Still appears notification about 96 updates on Fedora-Live-KDE-i686-19-Beta-TC2-1.iso

Comment 22 nucleo 2013-05-03 01:53:17 UTC
Both enabled Apper Monitor service and Software Updater in systray.

Comment 23 Rex Dieter 2013-05-03 03:00:06 UTC
Odd, the kickstart referenced here,
http://koji.fedoraproject.org/koji/taskinfo?taskID=5322177

Doesn't seem to include my latest commits.

Looking closer... oh fooey, looks like I only made the commits to spin-kickstarts master/ branch, not f19 yet. :(

OK, cherry-picked things to f19 branch now too.

Comment 24 nucleo 2013-05-04 12:55:59 UTC
Apper service disabled on TC3 but Software Updater in systray still shows 173 available updates.

Comment 25 Adam Williamson 2013-05-04 16:27:41 UTC
TC3 was built with the latest kickstart, but it did not have the changed 'apper' package; rdieter didn't think it was needed, but just noting this for the record.

Comment 26 Kevin Kofler 2013-05-07 16:10:00 UTC
Unfortunately, the kickstart changes try to disable the plasmoid using X-KDE-PluginInfo-EnabledByDefault. That just cannot work, that key has no effect for plasmoids. http://pkgs.fedoraproject.org/cgit/apper.git/tree/01-fedora-apper-updater.js needs to get disabled for live sessions instead.

The reasons Rex did not notice this during testing is that Plasma update scripts are run only once. So once you remove the plasmoid, it stays removed. Plasmoids are not autostarted on log in, they're added persistently and removed persistently.

Comment 27 Rex Dieter 2013-05-13 17:27:51 UTC
OK, prepping new apper builds with modified plasma scriptlets to not add applet for liveuser.

Comment 28 Rex Dieter 2013-05-13 18:16:44 UTC
nucleo confirmed that my first attempt apper-0.8.0-6.fc19 was a botch job on my part.

apper-0.8.1-0.2.20130511.fc19 (with PackageKit-Qt-0.8.8-1.fc19) should work better.

Comment 29 Adam Williamson 2013-05-13 18:24:07 UTC
If you can submit it as an update that'd be great, I'll ensure it's pulled into the next compose.

Comment 30 Martin Krizek 2013-05-16 07:47:21 UTC
Updates are not checked on live images, so this is fixed in F19 Beta RC1.

Comment 31 Adam Williamson 2013-05-16 16:16:36 UTC
Thanks!

Comment 32 Fedora Update System 2013-05-18 04:56:29 UTC
apper-0.8.1-0.2.20130511.fc19, PackageKit-Qt-0.8.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Adam Williamson 2013-05-19 19:51:05 UTC
Bodhi's not closing things again...

Comment 34 Germano Massullo 2013-12-12 14:15:47 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1039923


Note You need to log in before you can comment on or make changes to this bug.