Bug 954054 - [abrt] gnome-shell-3.8.1-1.fc19: _gdk_x11_display_error_event: Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
Summary: [abrt] gnome-shell-3.8.1-1.fc19: _gdk_x11_display_error_event: Process /usr/b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clutter
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9c77a90f1f8305d55be56c43661...
: 879864 893865 974762 977031 (view as bug list)
Depends On:
Blocks: 972628
TreeView+ depends on / blocked
 
Reported: 2013-04-20 07:11 UTC by Daniel Cabral
Modified: 2013-07-05 11:46 UTC (History)
19 users (show)

Fixed In Version: clutter-1.14.4-4.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-29 18:40:12 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (55.91 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: cgroup (131 bytes, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: core_backtrace (3.11 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: dso_list (22.19 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: environ (1.34 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: limits (1.29 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: maps (92.52 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: open_fds (4.61 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: proc_pid_status (1.04 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
File: var_log_messages (3.25 KB, text/plain)
2013-04-20 07:11 UTC, Daniel Cabral
no flags Details
gnome-shell strace file (7.42 MB, text/plain)
2013-07-05 06:13 UTC, Ken Sugawara
no flags Details
gdb session log (gdb gnome-shell /var/tmp/ccpp-*/coredump ) (19.88 KB, text/plain)
2013-07-05 07:45 UTC, Ken Sugawara
no flags Details

Description Daniel Cabral 2013-04-20 07:11:06 UTC
Version-Release number of selected component:
gnome-shell-3.8.1-1.fc19

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _gdk_x11_display_error_event
executable:     /usr/bin/gnome-shell
kernel:         3.9.0-0.rc6.git2.3.fc19.x86_64
runlevel:       N 5
uid:            1000
ureports_counter: 1

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 _gdk_x11_display_error_event at gdkdisplay-x11.c:2556
 #5 handle_error at xcb_io.c:212
 #7 XIQueryDevice at XIQueryDevice.c:60
 #8 translate_hierarchy_event at x11/clutter-device-manager-xi2.c:411
 #9 clutter_device_manager_xi2_translate_event at x11/clutter-device-manager-xi2.c:725
 #10 clutter_backend_real_translate_event at ./clutter-backend.c:572
 #11 clutter_x11_handle_event at x11/clutter-event-x11.c:199
 #12 gnome_shell_plugin_xevent_filter at gnome-shell-plugin.c:392
 #13 meta_compositor_process_event at compositor/compositor.c:958
 #14 event_callback at core/display.c:2917

Comment 1 Daniel Cabral 2013-04-20 07:11:09 UTC
Created attachment 737922 [details]
File: backtrace

Comment 2 Daniel Cabral 2013-04-20 07:11:12 UTC
Created attachment 737923 [details]
File: cgroup

Comment 3 Daniel Cabral 2013-04-20 07:11:13 UTC
Created attachment 737924 [details]
File: core_backtrace

Comment 4 Daniel Cabral 2013-04-20 07:11:15 UTC
Created attachment 737925 [details]
File: dso_list

Comment 5 Daniel Cabral 2013-04-20 07:11:17 UTC
Created attachment 737926 [details]
File: environ

Comment 6 Daniel Cabral 2013-04-20 07:11:19 UTC
Created attachment 737927 [details]
File: limits

Comment 7 Daniel Cabral 2013-04-20 07:11:21 UTC
Created attachment 737928 [details]
File: maps

Comment 8 Daniel Cabral 2013-04-20 07:11:24 UTC
Created attachment 737929 [details]
File: open_fds

Comment 9 Daniel Cabral 2013-04-20 07:11:25 UTC
Created attachment 737930 [details]
File: proc_pid_status

Comment 10 Daniel Cabral 2013-04-20 07:11:27 UTC
Created attachment 737931 [details]
File: var_log_messages

Comment 11 Mads Kiilerich 2013-06-08 16:03:19 UTC
It was immediately after resuming, I think the unlock prompt came up ... and then it crashed before I entered the password and I was in and gnome shell was working as expected.

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: _gdk_x11_display_error_event
executable:     /usr/bin/gnome-shell
kernel:         3.9.4-301.fc19.x86_64
package:        gnome-shell-3.8.2-3.fc19
reason:         Process /usr/bin/gnome-shell was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            1000

Comment 12 Matthias Clasen 2013-06-11 01:25:10 UTC
GDK traps errors when calling XIQueryDevice, since devices can disappear at any time. Clutter should do the same.

Comment 13 Matthias Clasen 2013-06-11 01:46:42 UTC
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=701974

Comment 14 Christophe Fergeau 2013-06-11 10:05:21 UTC
*** Bug 879864 has been marked as a duplicate of this bug. ***

Comment 15 Christophe Fergeau 2013-06-11 10:05:23 UTC
*** Bug 893865 has been marked as a duplicate of this bug. ***

Comment 16 Florian Weimer 2013-06-21 11:15:48 UTC
Can we get this fixed in F19, please?

I wonder why it isn't as visible with older GNOME versions.

Comment 17 Fedora Update System 2013-06-23 17:21:27 UTC
clutter-1.14.4-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/clutter-1.14.4-3.fc19

Comment 18 Fedora Blocker Bugs Application 2013-06-23 17:23:26 UTC
Proposed as a Freeze Exception for 19-final by Fedora user mclasen using the blocker tracking app because:

 crash in critpath

Comment 19 Adam Williamson 2013-06-24 18:17:41 UTC
Discussed at 2013-06-24 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-24/f19final-blocker-review-8.2013-06-24-16.00.log.txt . This is obviously a significant issue, but as user accounts on the live images are not valuable in any way, there are only corner cases which would benefit from fixing this in the release package set (users of the live media persistency features with 'valuable' user accounts). Given this, and the fact that it's only 3 days till go/no-go, we decided to go 'safety first' and reject this as an FE issue for now. If we wind up slipping the release, we'll probably make this acceptedFE and slip it into one of the early post-slip builds.

Comment 20 Fedora Update System 2013-06-24 18:50:43 UTC
Package clutter-1.14.4-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing clutter-1.14.4-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11606/clutter-1.14.4-3.fc19
then log in and leave karma (feedback).

Comment 21 Fedora Update System 2013-06-26 08:43:38 UTC
clutter-1.14.4-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/clutter-1.14.4-4.fc19

Comment 22 Fedora Update System 2013-06-29 18:40:12 UTC
clutter-1.14.4-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 markus 2013-06-29 19:37:08 UTC
after standby, there is no passwort required

clutter1.14.4-4.fc19
Gnome 64bit
AMD Graphic os driver
sabertooth 990fx r2
luks

My Notebook is working fine, 32bit, HP NC2400

Comment 24 Matthias Clasen 2013-06-30 01:25:04 UTC
*** Bug 977031 has been marked as a duplicate of this bug. ***

Comment 25 Matthias Clasen 2013-06-30 01:25:41 UTC
*** Bug 974762 has been marked as a duplicate of this bug. ***

Comment 26 markus 2013-07-01 19:08:16 UTC
thx its working.
;)

Comment 27 markus 2013-07-04 09:44:52 UTC
edit:
same problem, after standby no password is required

Comment 28 Florian Weimer 2013-07-04 10:35:50 UTC
(In reply to markus from comment #27)
> edit:
> same problem, after standby no password is required

What's your version of clutter?  Please run "rpm -q clutter".

Comment 29 Ken Sugawara 2013-07-05 05:58:31 UTC
(In reply to Florian Weimer from comment #28)
> (In reply to markus from comment #27)
> > edit:
> > same problem, after standby no password is required
> 
> What's your version of clutter?  Please run "rpm -q clutter".

Hi,

I'm not Markus, but I'm using clutter-1.14.4-4.fc19 and gnome-shell-3.8.3-3.fc19 and getting the same error it seems. I don't seem to get any core dumped, so I straced gnome-shell and got the attached files.

Currently I'm unable to run GUI desktop on my main work box, so this is kinda urgent.

Comment 30 Ken Sugawara 2013-07-05 06:13:26 UTC
Created attachment 769107 [details]
gnome-shell strace file

Sorry. This is the attachment I mentioned in the previous comment.

Comment 31 Florian Weimer 2013-07-05 06:56:49 UTC
(In reply to Ken Sugawara from comment #30)
> Created attachment 769107 [details]
> gnome-shell strace file
> 
> Sorry. This is the attachment I mentioned in the previous comment.

Hmm.  Can you provide us with a backtrace (attach GDB to the running process from a VTY console) and the warning messages printed to stderr?  They are truncated in the strace output.

I suspect this is a different bug.  In my case, there weren't as many Cogl warnings.

Comment 32 Ken Sugawara 2013-07-05 07:45:39 UTC
Created attachment 769132 [details]
gdb session log (gdb gnome-shell /var/tmp/ccpp-*/coredump )

Ok, I found a half baked abrt report (?) in /var/tmp/abrt/ccpp-* where coredump file was of gnome-shell killed by SIGTRAP. The attached file is the log of gdb session.

If it turns out to be a different bug, I'll submit a new bug.

Thanks,

Comment 33 Florian Weimer 2013-07-05 07:50:47 UTC
(In reply to Ken Sugawara from comment #32)
> Created attachment 769132 [details]
> gdb session log (gdb gnome-shell /var/tmp/ccpp-*/coredump )
> 
> Ok, I found a half baked abrt report (?) in /var/tmp/abrt/ccpp-* where
> coredump file was of gnome-shell killed by SIGTRAP. The attached file is the
> log of gdb session.
> 
> If it turns out to be a different bug, I'll submit a new bug.

Your Cogl error is "Failed to create an OpenGL framebuffer object", that's different from the error reported in this bug, "The program 'gnome-shell' received an X Window System error.\nThis probably reflects a bug in the program.\nThe error was 'XI_BadDevice (invalid Device parameter)'.\n  (Details: serial 70478 error_code 1".  This is probably a different bug.

Comment 34 Ken Sugawara 2013-07-05 08:14:12 UTC
(In reply to Florian Weimer from comment #33)
> Your Cogl error is "Failed to create an OpenGL framebuffer object", that's
> different from the error reported in this bug, "The program 'gnome-shell'
> received an X Window System error.\nThis probably reflects a bug in the
> program.\nThe error was 'XI_BadDevice (invalid Device parameter)'.\n 
> (Details: serial 70478 error_code 1".  This is probably a different bug.

Thanks. I'll submit a new one.

Comment 35 markus 2013-07-05 11:46:16 UTC
[root@localhost markus]# rpm -q clutter

clutter-1.14.4-4.fc19.x86_64


Note You need to log in before you can comment on or make changes to this bug.