Bug 957593 - [RFE][Tracker] - local user editable config file/registry settings to hard code the guest monitors on to the client monitors
Summary: [RFE][Tracker] - local user editable config file/registry settings to hard co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Scott Herold
QA Contact: SPICE QE bug list
URL:
Whiteboard:
: 957595 (view as bug list)
Depends On: 1129477 1129479 1181289 1233422
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-29 06:40 UTC by Mark Huth
Modified: 2019-09-12 07:44 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
In multiple-monitor setups, it is now possible to specify which monitors are to be used by a virtual guest, and which are to be reserved for the local machine. This is done by editing the ~/.config/virt-viewer/settings file.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:31:01 UTC
oVirt Team: Spice


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Mark Huth 2013-04-29 06:40:15 UTC
Description of problem:
remote-viewer should have a local user editable config file/registry settings to hard code the guest monitors on to the client monitors.  For example, our VDI users have 3 monitors (1 x 19" and 2 x 24") and they want their VM to put its screens on the 24" monitors.  We should be able to tell remote-view that it should use physical monitor X for the first guest screen, monitor Y for the second guest screen and so on.

Comment 1 Marc-Andre Lureau 2013-04-29 10:06:21 UTC
(In reply to comment #0)
> Description of problem:
> remote-viewer should have a local user editable config file/registry
> settings to hard code the guest monitors on to the client monitors.  For
> example, our VDI users have 3 monitors (1 x 19" and 2 x 24") and they want
> their VM to put its screens on the 24" monitors.  We should be able to tell
> remote-view that it should use physical monitor X for the first guest
> screen, monitor Y for the second guest screen and so on.

Could you explain why mapping the guest configuration to match client configuration isn't suitable?

Do I understand correctly you are asking for the guest to be configured with 2 monitors shown on monitor 2 & 3 of the client?

Should this setting be per client/guest configuration? per client only? per guest only? any combination? Should it be configurable from RHEVM instead?

This brings a lot of questions on how to provide such feature, when you can  just place the client monitor windows manually, like any other application.

Comment 2 Christophe Fergeau 2013-04-29 11:06:39 UTC
For what it's worth, devil's pie may be able to do this kind of positioning.

Comment 3 Marc-Andre Lureau 2013-04-30 11:04:36 UTC
(In reply to comment #2)
> For what it's worth, devil's pie may be able to do this kind of positioning.

only on RHEL

Comment 4 Marc-Andre Lureau 2013-05-17 12:45:42 UTC
*** Bug 957595 has been marked as a duplicate of this bug. ***

Comment 17 Scott Herold 2014-10-23 16:05:06 UTC
Flagging for discussion for 3.6 prioritization in Spice

Comment 18 Leo Liu 2014-11-07 23:53:43 UTC
(In reply to Scott Herold from comment #17)
> Flagging for discussion for 3.6 prioritization in Spice

Hello Scott,

Any update about this request for 3.6?

Thanks!

Comment 26 Yaniv Lavi 2015-06-30 11:42:38 UTC
This should be in MODIFIED, right? Since the rebase of virt-viewer will include this?

Comment 27 David Blechter 2015-06-30 11:50:40 UTC
(In reply to Yaniv Dary from comment #26)
> This should be in MODIFIED, right? Since the rebase of virt-viewer will
> include this?

I consider it as the tracker bug, no place in errata.
https://bugzilla.redhat.com/show_bug.cgi?id=1233422 is ON_QA

Comment 28 Yaniv Lavi 2015-06-30 12:02:06 UTC
(In reply to David Blechter from comment #27)
> (In reply to Yaniv Dary from comment #26)
> > This should be in MODIFIED, right? Since the rebase of virt-viewer will
> > include this?
> 
> I consider it as the tracker bug, no place in errata.
> https://bugzilla.redhat.com/show_bug.cgi?id=1233422 is ON_QA

Changing this to bug tracker then.

Comment 29 Yaniv Lavi 2015-08-27 14:07:55 UTC
Should this be on_qa?

Comment 30 Yaniv Lavi 2015-08-27 14:09:27 UTC
I understand it is a tracker, but if the dependent bugs are ON_QA this should be on qa.

Comment 33 errata-xmlrpc 2016-03-09 20:31:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.