Bug 962613 - system-config-services-0.101.9-1.fc18 fails to start with error 'ImportError: No module named gui' [Fedora 18]
system-config-services-0.101.9-1.fc18 fails to start with error 'ImportError:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 23:29 EDT by Nix\
Modified: 2013-05-24 16:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: system-config-services-0.101.10-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 22:51:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nix\ 2013-05-13 23:29:10 EDT
Description of problem:

After the update on Fedora 18 (today, May the 14th 2013), with a new version of system-config-services, not run anymore, the same bug of the same version in Fedora 19 beta, reported by me.

Version-Release number of selected component (if applicable):
Fedora 18 KDE x86_64 up to date
system-config-services-0.101.9-1.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
1.install Fedora 18
2.Want execute system-config-services
3.ImportError: No module named gui
  
Actual results:
system-config-services is unusable

Expected results:
system-config-services usable

Additional info:

The same bug on the same version of system-config-services (system-config-services-0.101.9-1) reported for Fedora 19 beta and not solved yet.
Is a problem of packaging maybe, because the .tar.bz2 yes exists the module:

wget https://fedorahosted.org/released/system-config-services/system-config-services-0.101.9.tar.bz2

After extracting the tarball:

$ ls system-config-services-0.101.9/src/scservices/gui/*
__init__.py

(class UIController found in line 1162).

https://bugzilla.redhat.com/show_bug.cgi?id=960478
Comment 1 Fedora Update System 2013-05-14 12:02:37 EDT
system-config-services-0.101.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/system-config-services-0.101.10-1.fc18
Comment 2 Fedora Update System 2013-05-14 12:02:59 EDT
system-config-services-0.101.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-services-0.101.10-1.fc17
Comment 3 Fedora Update System 2013-05-14 12:03:22 EDT
system-config-services-0.101.10-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-services-0.101.10-1.fc19
Comment 4 Fedora Update System 2013-05-14 13:45:47 EDT
Package system-config-services-0.101.10-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-services-0.101.10-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8137/system-config-services-0.101.10-1.fc19
then log in and leave karma (feedback).
Comment 5 Nix\ 2013-05-15 01:45:08 EDT
Solved using system-config-services-0.101.10-1.fc19, so, is a good idea package the same version for Fedora 18 stable and move from testing to stable, because the actual version of system-config-services, no work on Fedora 18 stable branch.
Comment 6 Eduard Vopicka 2013-05-15 04:46:56 EDT
system-config-services-0.101.10-1.fc17.noarch fixes the startup problem on F17, both i686 and x86_64. Tested on single system of each architecture.
Comment 7 Nils Philippsen 2013-05-15 05:33:33 EDT
(In reply to comment #6)
> system-config-services-0.101.10-1.fc17.noarch fixes the startup problem on
> F17, both i686 and x86_64. Tested on single system of each architecture.

In that case, please give karma here (log in, then add comment checking "works for me") so that the package gets pushed to stable:

https://admin.fedoraproject.org/updates/FEDORA-2013-8210/system-config-services-0.101.10-1.fc17

Thanks!
Comment 8 Nils Philippsen 2013-05-15 05:35:17 EDT
(In reply to comment #5)
> Solved using system-config-services-0.101.10-1.fc19, so, is a good idea
> package the same version for Fedora 18 stable and move from testing to
> stable, because the actual version of system-config-services, no work on
> Fedora 18 stable branch.

I've set the stable threshold for this update to 1, so your adding positive karma on the update submitted it for being pushed to stable. It should come with the next round of updates. Thanks!
Comment 9 Eduard Vopicka 2013-05-15 06:16:47 EDT
> In that case, please give karma here (log in, then add comment checking
> "works for me")

Uh oh, so now I am happy owner of brandly new fedora account. :-) Added +1 to karma...
Comment 10 Nils Philippsen 2013-05-15 07:28:06 EDT
(In reply to comment #9)
> > In that case, please give karma here (log in, then add comment checking
> > "works for me")
> 
> Uh oh, so now I am happy owner of brandly new fedora account. :-) Added +1
> to karma...

Ahh... where your account came from, there are still more, no worries :-). Thanks for the karma, the update will be pushed to stable during the next round of updates.
Comment 11 Eduard Vopicka 2013-05-15 14:35:14 EDT
> Ahh... where your account came from, there are still more, no worries :-).
> Thanks for the karma, the update will be pushed to stable during the next
> round of updates.

:-) I certainly do not worry. I am running RedHat and then also Fedora since the original (not RHEL) RedHat Linux 4.x. :-)
Comment 12 Fedora Update System 2013-05-15 22:51:24 EDT
system-config-services-0.101.10-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-05-15 23:04:17 EDT
system-config-services-0.101.10-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-05-24 16:49:54 EDT
system-config-services-0.101.10-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.