Bug 962933 - The instance multiplier logic applies to virtual guests when it shouldn't
The instance multiplier logic applies to virtual guests when it shouldn't
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-14 15:21 EDT by J.C. Molet
Modified: 2013-09-30 19:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:08:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
instance multiplier does not apply to virtual guests (142.58 KB, image/png)
2013-06-10 10:48 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description J.C. Molet 2013-05-14 15:21:03 EDT
Description of problem:
The instance multiplier logic (for example in the quantity scrollers in the gui) applies to virtual guests when it shouldn't.  This is according to the design dock here: https://engineering.redhat.com/trac/Entitlement/wiki/InstanceBasedDesign

Version-Release number of selected component (if applicable):
subscription-manager: 1.8.7-1.git.39.c802238.el5
subscription management server: 0.8.7-1

How reproducible:
always

Steps to Reproduce:
1. Run subscription-manager-gui where the fact 'virt.is_guest: True' is set
2. Register to your candlepin
3. Try to adjust the quantity on a subscription that has the instance_multiplier (in the TESTDATA, "Awesome OS Instance Based (Standard Support)" is a good example).
  
Actual results:
The instance_multiplier logic is enforced on virtual guests.

Expected results:
The instance_multiplier logic is not enforced on virtual guests.

Additional info:
Comment 1 RHEL Product and Program Management 2013-05-14 15:27:56 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Ondrej Vasik 2013-05-15 07:41:34 EDT
Could you please set devel_ack/condnack for 5.10 or postpone/close this bugzilla? Erratas should be filed by May 21st, so development phase is nearing its exit.
Comment 3 Devan Goodwin 2013-05-22 13:45:16 EDT
Should be fixed as a result of bug #921249. Moving to POST.
Comment 4 Sharath Dwaral 2013-06-10 10:48:13 EDT
Created attachment 759225 [details]
instance multiplier does not apply to virtual guests

Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.8.10-1.git.17.f96cf80.el5
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
python-rhsm-1.8.12-1.git.0.d747a65.el5
subscription-manager-1.8.10-1.git.17.f96cf80.el5
subscription-manager-gui-1.8.10-1.git.17.f96cf80.el5
subscription-manager-firstboot-1.8.10-1.git.17.f96cf80.el5

Please see attachment. Instance multiplier does not apply to Virtual guests

VERIFIED
Comment 7 errata-xmlrpc 2013-09-30 19:08:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.