Bug 963958 - dialog-warning-symbolic.svg (used as the 'warning triangle' emblem in anaconda) is now grey; if anaconda wants the old orange one, anaconda should ship it
dialog-warning-symbolic.svg (used as the 'warning triangle' emblem in anacond...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All All
unspecified Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 965589 973598 (view as bug list)
Depends On:
Blocks: F19Alpha/F19AlphaBlocker F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-05-16 17:09 EDT by Adam Williamson
Modified: 2013-08-21 15:16 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-19.30.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 17:46:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TC4, with nice orange warning icon (79.24 KB, image/png)
2013-05-16 17:09 EDT, Adam Williamson
no flags Details
RC1, with bad-looking grey warning icon (78.03 KB, image/png)
2013-05-16 17:10 EDT, Adam Williamson
no flags Details
screenshot F19b RC2 (3.30 MB, image/jpeg)
2013-05-21 11:32 EDT, Reartes Guillermo
no flags Details
The 'stop' icon is now also gray (it was red, as most known STOPs) (29.85 KB, image/png)
2013-05-26 19:26 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Adam Williamson 2013-05-16 17:09:30 EDT
Created attachment 749066 [details]
TC4, with nice orange warning icon

It looks like /usr/share/icons/gnome/scalable/status/dialog-warning-symbolic.svg changed from being orange in 3.8.0.1-1 to being grey in 3.8.2.1-1 or 3.8.2.2-1 .

Anaconda's UI kinda relies on this being orange. See the attached screenshots. In Beta TC4 (with the older gnome-icon-theme-symbolic), the spoke that needs attention is obvious. In Beta RC1 (with the newer gnome-icon-theme-symbolic), it looks like some kind of graphical glitch.

Can this go back to being orange? Or is anaconda going to have to take a private copy of the old icon?
Comment 1 Adam Williamson 2013-05-16 17:10:09 EDT
Created attachment 749067 [details]
RC1, with bad-looking grey warning icon
Comment 2 Adam Williamson 2013-05-16 17:14:06 EDT
Upstream commit looks to have been https://git.gnome.org/browse/gnome-icon-theme-symbolic/commit/?id=b9394628a89b42995a254f5eb428f9b27c484993 .
Comment 3 Adam Williamson 2013-05-16 17:15:37 EDT
Proposing as Beta FE: this is just cosmetic, but it's pretty obvious, looks pretty weird, is a 'regression' from Alpha, and we're still early in freeze.
Comment 4 Adam Williamson 2013-05-17 00:00:38 EDT
anaconda team, the feedback I got from desktop team on this was pretty unambiguous: if anaconda wants the icon to look a certain way, it'd better ship it itself. So, re-assigning this to anaconda. Suggested course of action below. :)

<mclasen> adamw: bummer, but they are pretty clearly labeled as 'dialog' icons, not 'fancy colored icons for your random uses'
<adamw> mclasen: is there a fancy colored icon for your random use somewhere? :)
* adamw trying to find one
<elad> adamw: 1) take this icon 2) color it using inkscape 3) shove it in the anaconda git tree
<adamw> elad: well that's the obvious 'workaround', just dunno if there's anything better to do.
<mclasen> no inkscape required
<adamw> or rather, 'take the one from 3.8.0 and shove that in the anaconda tree'
<mclasen> just take the icon as is from the 3.8.0 tarball
<adamw> right
Comment 5 Adam Williamson 2013-05-20 13:55:17 EDT
Discussed at 2013-05-20 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-20/f19beta-blocker-review-7.2013-05-20-16.07.log.txt . Accepted as an FE issue: this is a pretty visible aesthetic issue, makes it harder to spot spokes in 'warning' status, and the fix would be easy and safe.
Comment 6 Reartes Guillermo 2013-05-21 11:32:12 EDT
Created attachment 751228 [details]
screenshot F19b RC2

The Software Selection icon is the most affected one, it is nearly invisible because the "!" in the new icon is not solid.
Comment 7 Reartes Guillermo 2013-05-26 19:26:56 EDT
Created attachment 753425 [details]
The 'stop' icon is now also gray (it was red, as most known STOPs)
Comment 8 Adam Williamson 2013-05-28 19:39:43 EDT
Submitting as a Final freeze exception issue, we *really* ought to fix this for final, it looks crappy and it's confusing. I'd propose as a blocker but I can't currently come up with a criteria justification...
Comment 9 Adam Williamson 2013-05-29 22:44:25 EDT
I'll check for other icons we may need private copies of if I get time, but the warning triangle was definitely the most important, and confirmed fixed in 19.30.1-1.
Comment 10 Adam Williamson 2013-05-30 14:40:55 EDT
Discussed at 2013-05-30 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-30/f19final-blocker-review-1.1.2013-05-30-16.02.log.txt . Accepted as a freeze exception issue as this was a significant visual problem that confused many people and can't be fixed with an update.
Comment 11 Tim Flink 2013-05-31 13:34:35 EDT
*** Bug 965589 has been marked as a duplicate of this bug. ***
Comment 12 Adam Williamson 2013-06-12 17:46:06 EDT
We're well past 19.30.1-1 now, so closing.
Comment 13 Chris Lumens 2013-08-21 15:16:00 EDT
*** Bug 973598 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.