Bug 964967 - PRD33 - [RFE] vdsm-tool for offline usages
PRD33 - [RFE] vdsm-tool for offline usages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Yaniv Bronhaim
Artyom
infra
: FutureFeature
Depends On: 982266
Blocks: 916095 1019470
  Show dependency treegraph
 
Reported: 2013-05-20 04:25 EDT by Alon Bar-Lev
Modified: 2016-02-10 14:27 EST (History)
15 users (show)

See Also:
Fixed In Version: is2
Doc Type: Enhancement
Doc Text:
The VDSM tool can now be used offline for tasks that do not require VDSM to be configured or up. This tool can be used to return the VDSM ID, check its status, start and stop VDSM, and validate certificates.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:07:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14866 None None None Never
oVirt gerrit 15216 None None None Never

  None (edit)
Description Alon Bar-Lev 2013-05-20 04:25:26 EDT
Hello,

Per bug#916095, discussion at[1] and other uses, it would be great if we have offline vdsm tool for tasks that do not require vdsm to be configured nor up.

Examples:

1. get vdsm id (bug#916095)

engine may use utility to return vdsm id, without duplicate the logic into the engine.

2. libvirt reconfigure

remove the logic from the init script which is not supported by systemd into common place.

3. certificate issue sequence [FUTURE]

ability to issue a certificate, perform the request accept the chain in a user friendly manner (and program friendly), this will enable host-deploy to perform enrollment without depend on the artifacts locations.

4. stop/start [FUTURE]

stop/start the entire component. handy when there are several services around.

Thanks!

[1] http://gerrit.ovirt.org/#/c/14402/
Comment 5 Eyal Edri 2013-06-19 11:45:00 EDT
according to tracker, patch is merged.
moving to MODIFIED.
Comment 6 Alon Bar-Lev 2013-06-27 06:02:28 EDT
*** Bug 978906 has been marked as a duplicate of this bug. ***
Comment 7 Barak Dagan 2013-07-04 05:20:04 EDT
1) libvirt-configure part is not merged - why is it on_qa ?
2) missing libvirt-configure usage in help
3) missing service-like usage in help
4) missing vdsm-id usage in help
Comment 8 Yaniv Bronhaim 2013-07-04 05:29:18 EDT
1) still in progress.
2) its part of the patch that hasn't been merged yet.
3,4) "vdsm-id: Printing host uuid"  -> that's what it does, if its lack of more information, let me know what do you think we should add?
and the service like is quite informative:
  service-disable          Disable a system service
  service-is-managed       Check the existence of a service
  service-reload           Notify a system service to reload
                      configurations
  service-restart          Restart a system service
  service-start            Start a system service
  service-status           Get status of a system service
  service-stop             Stop a system service
Comment 9 Artyom 2013-07-08 06:07:40 EDT
Also when run command vdsm-tool service-restart vdsmd for example, not any information messages appear
Comment 11 Artyom 2013-07-28 04:58:24 EDT
If I need to verify for sections 3 and 4(id and services) or wait until libvirt-configure part?
Comment 12 Dan Kenigsberg 2013-07-28 05:48:02 EDT
http://gerrit.ovirt.org/15216 with libvirt-configure is in.
Comment 13 Artyom 2013-07-28 08:34:47 EDT
Verified on is7
vdsm-tool vdsm-id return host id
vdsm-tool service-* not return any information message and return traceback instead of user friendly message, but work fine checking via service status

example of return vdsm-tool service-stop vdsm 1
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 143, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 140, in main
    return tool_command[cmd]["command"](*args[1:])
TypeError: service_stop() takes exactly 1 argument (2 given)
Comment 14 Charlie 2013-11-27 19:29:35 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 15 errata-xmlrpc 2014-01-21 11:07:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.