Bug 982266 - Fence via power management type apc_snmp not working
Fence via power management type apc_snmp not working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Eli Mesika
sefi litmanovich
infra
: Regression, Triaged
: 993110 (view as bug list)
Depends On: 1014513
Blocks: 964967 977689 3.3snap2
  Show dependency treegraph
 
Reported: 2013-07-08 10:06 EDT by Artyom
Modified: 2016-02-10 14:26 EST (History)
13 users (show)

See Also:
Fixed In Version: is21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:16:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (1.16 MB, text/x-log)
2013-07-08 10:06 EDT, Artyom
no flags Details
screenshoot (161.72 KB, image/png)
2013-07-25 01:51 EDT, Artyom
no flags Details
vdsm_logs (1.30 MB, text/x-log)
2013-08-07 03:08 EDT, Artyom
no flags Details
How to fill parameters for apc_snmp agent (28.62 KB, image/png)
2013-10-10 12:33 EDT, Eli Mesika
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20090 None None None Never

  None (edit)
Description Artyom 2013-07-08 10:06:26 EDT
Created attachment 770513 [details]
engine.log

Description of problem:
Fence via power management type apc_snmp not working

Version-Release number of selected component (if applicable):

rhevm - is4
host -vdsm-4.10.2-17.0.el6ev 

How reproducible:
Add data center, add cluster, add two hosts, one with power management of type acp_snmp,  configure correct power management to host, click test button to check if power management work ok.

Steps to Reproduce:
1. See above
2.
3.

Actual results:
Test Failed, Parse error: Ignoring unknown option '=4' Failed: You have to enter plug number Please use '-h' for usage

Expected results:
Test Succeeded, on

Additional info:
Under sf18 power management work fine
Comment 1 Artyom 2013-07-08 10:08:11 EDT
Power management type ipmilan work fine.
Comment 2 Artyom 2013-07-08 10:29:42 EDT
Via power management type bladecenter fence also work
Comment 3 Itamar Heim 2013-07-08 11:22:31 EDT
this was verified in 3.2 in https://bugzilla.redhat.com/show_bug.cgi?id=916570#c3
Comment 6 Eli Mesika 2013-07-24 12:34:25 EDT
Please add a screenshot of the UI screen with all parameters where you pushed the TEST button
Comment 7 Artyom 2013-07-25 01:51:16 EDT
Created attachment 778064 [details]
screenshoot
Comment 8 Barak 2013-08-06 05:18:37 EDT
from the log above:

2013-07-08 15:20:13,797 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FenceVdsVDSCommand] (ajp-/127.0.0.1:8702-8) [17fd6c8c] FINISH, FenceVdsVDSCommand, return: Test Failed, Parse error: Ignoring unknown option '=no'
Failed: You have to enter plug number
Please use '-h' for usage
, log id: 298d342b

It looks like the error was returend from the fence agent itself:

Artyom,

Can you please provide versions of vdsm & fence-agents on the proxy host.
+ what cluster level were the hosts in ?
Comment 9 Artyom 2013-08-06 05:48:16 EDT
Hosts on the same cluster
Host with power management - vdsm-4.12.0-rc3.12.git139ec2f.el6ev
Proxy Host - vdsm-4.12.0-rc3.12.git139ec2f.el6ev.x86_64
             fence-agents-3.1.5-25.el6_4.2.x86_64
Comment 10 Barak 2013-08-06 08:52:22 EDT
(In reply to Artyom from comment #9)
> Hosts on the same cluster
> Host with power management - vdsm-4.12.0-rc3.12.git139ec2f.el6ev
> Proxy Host - vdsm-4.12.0-rc3.12.git139ec2f.el6ev.x86_64
>              fence-agents-3.1.5-25.el6_4.2.x86_64

So cluster level was 3.3 ?

Can we also get the vdsm logs as well ?
Comment 11 Artyom 2013-08-07 03:08:21 EDT
Created attachment 783698 [details]
vdsm_logs

Vdsm.log proxy host, and pm host
Comment 12 Artyom 2013-08-07 03:18:00 EDT
Cluster level 3.3
Comment 13 Eli Mesika 2013-09-11 06:09:38 EDT
*** Bug 993110 has been marked as a duplicate of this bug. ***
Comment 14 Eli Mesika 2013-10-10 12:31:15 EDT
Was indirectly solved by resolving BZ 1014513
For apc_snmp you should provide the port in the SSH Port field
(see attachment)
Comment 15 Eli Mesika 2013-10-10 12:33:14 EDT
Created attachment 810642 [details]
How to fill parameters for apc_snmp agent
Comment 18 sefi litmanovich 2013-11-11 06:56:23 EST
Verified on RHEVM 3.3, IS22
Comment 19 Itamar Heim 2014-01-21 17:16:33 EST
Closing - RHEV 3.3 Released
Comment 20 Itamar Heim 2014-01-21 17:23:21 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.