Bug 965556 - UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 0: unexpected end of data
UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 0: unexpe...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
abrt_hash:f7c1074965f82e774fed487fb5c...
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-05-21 07:02 EDT by Pavel Holica
Modified: 2014-04-07 14:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-07 14:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (167.63 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: anaconda.log (3.35 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: backtrace (715 bytes, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: environ (759 bytes, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: ifcfg.log (486 bytes, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: lsblk_output (1.42 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: nmcli_dev_list (3.44 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: packaging.log (11.19 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: program.log (23.71 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: storage.log (46.57 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details
File: syslog (67.38 KB, text/plain)
2013-05-21 07:03 EDT, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2013-05-21 07:02:53 EDT
Description of problem:

The following was filed automatically by anaconda:
anaconda 19.28-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 623, in <genexpr>
    return u"\n".join(u"".join(l) for l in self._buffer)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 623, in __unicode__
    return u"\n".join(u"".join(l) for l in self._buffer)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 527, in show_all
    print unicode(w)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 281, in _do_redraw
    screen.window.show_all()
UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 0: unexpected end of data

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet text keymap=cz BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 281, in _do_redraw
    screen.window.show_all()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 527, in show_all
    print unicode(w)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 623, in __unicode__
    return u"\n".join(u"".join(l) for l in self._buffer)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 623, in <genexpr>
    return u"\n".join(u"".join(l) for l in self._buffer)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 0: unexpected end of data
Comment 1 Pavel Holica 2013-05-21 07:03:02 EDT
Created attachment 751014 [details]
File: anaconda-tb
Comment 2 Pavel Holica 2013-05-21 07:03:06 EDT
Created attachment 751015 [details]
File: anaconda.log
Comment 3 Pavel Holica 2013-05-21 07:03:10 EDT
Created attachment 751016 [details]
File: backtrace
Comment 4 Pavel Holica 2013-05-21 07:03:14 EDT
Created attachment 751017 [details]
File: environ
Comment 5 Pavel Holica 2013-05-21 07:03:18 EDT
Created attachment 751018 [details]
File: ifcfg.log
Comment 6 Pavel Holica 2013-05-21 07:03:22 EDT
Created attachment 751019 [details]
File: lsblk_output
Comment 7 Pavel Holica 2013-05-21 07:03:26 EDT
Created attachment 751020 [details]
File: nmcli_dev_list
Comment 8 Pavel Holica 2013-05-21 07:03:30 EDT
Created attachment 751021 [details]
File: packaging.log
Comment 9 Pavel Holica 2013-05-21 07:03:35 EDT
Created attachment 751022 [details]
File: program.log
Comment 10 Pavel Holica 2013-05-21 07:03:44 EDT
Created attachment 751023 [details]
File: storage.log
Comment 11 Pavel Holica 2013-05-21 07:03:48 EDT
Created attachment 751024 [details]
File: syslog
Comment 12 Brian Lane 2013-06-24 12:39:41 EDT
Can you reproduce this with TC6?
Comment 13 Adam Williamson 2013-06-24 12:44:17 EDT
How exactly does one reproduce this bug? Is it still valid with Final TC6? Thanks!
Comment 14 Pavel Holica 2013-06-26 03:55:01 EDT
Sorry for late reply.

Yes, I was able to reproduce this on TC6.

Steps to reproduce:
1. add "text vconsole.keymap=cz" to kernel command line at boot
2. select text mode when asked
3. select create user
4. create user
5. select Fullname
6. enter something non-ascii like: Tomáš Marný
traceback occurs
Comment 15 Samantha N. Bueno 2014-04-07 14:09:18 EDT
There was a similar bug in RHEL07; looks like the commit (c5ed8eda) went into master branch October 2013, so this should be fixed in F20. Please re-open if the issue persists.

Note You need to log in before you can comment on or make changes to this bug.