Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 973384 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
Summary: UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: tolarewa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2b310f1b50361715e1954a1112e...
: 976576 976630 (view as bug list)
Depends On:
Blocks: F19Blocker, F19FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2013-06-11 19:59 UTC by Alexey Torkhov
Modified: 2013-08-12 01:37 UTC (History)
13 users (show)

Fixed In Version: pyparted-3.9-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-26 04:28:17 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (787.18 KB, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: anaconda.log (72.26 KB, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: backtrace (1.04 KB, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: environ (840 bytes, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: ifcfg.log (919 bytes, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: lsblk_output (2.96 KB, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: messages (229.30 KB, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: nmcli_dev_list (6.99 KB, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: program.log (79.50 KB, text/plain)
2013-06-11 19:59 UTC, Alexey Torkhov
no flags Details
File: storage.log (571.81 KB, text/plain)
2013-06-11 20:00 UTC, Alexey Torkhov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 965556 0 unspecified CLOSED UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 0: unexpected end of data 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 973019 0 unspecified CLOSED UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 0: ordinal not in range(128) 2021-02-22 00:41:40 UTC

Internal Links: 965556 973019

Description Alexey Torkhov 2013-06-11 19:59:09 UTC
Description of problem:
Tried install F19 with custom partitioning.
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 451, in execute
    msg = _("Creating %(type)s on %(device)s") % {"type": self.device.format.type, "device": self.device.path}
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=c91d471e-7d4b-444f-8f66-a8904f1ada07 rootfstype=ext4 rw rd.live.image overlay=UUID=c91d471e-7d4b-444f-8f66-a8904f1ada07 quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.14-1.fc19.noarch
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 451, in execute
    msg = _("Creating %(type)s on %(device)s") % {"type": self.device.format.type, "device": self.device.path}
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Comment 1 Alexey Torkhov 2013-06-11 19:59:17 UTC
Created attachment 759806 [details]
File: anaconda-tb

Comment 2 Alexey Torkhov 2013-06-11 19:59:22 UTC
Created attachment 759807 [details]
File: anaconda.log

Comment 3 Alexey Torkhov 2013-06-11 19:59:26 UTC
Created attachment 759808 [details]
File: backtrace

Comment 4 Alexey Torkhov 2013-06-11 19:59:32 UTC
Created attachment 759809 [details]
File: environ

Comment 5 Alexey Torkhov 2013-06-11 19:59:36 UTC
Created attachment 759810 [details]
File: ifcfg.log

Comment 6 Alexey Torkhov 2013-06-11 19:59:40 UTC
Created attachment 759811 [details]
File: lsblk_output

Comment 7 Alexey Torkhov 2013-06-11 19:59:45 UTC
Created attachment 759812 [details]
File: messages

Comment 8 Alexey Torkhov 2013-06-11 19:59:49 UTC
Created attachment 759813 [details]
File: nmcli_dev_list

Comment 9 Alexey Torkhov 2013-06-11 19:59:54 UTC
Created attachment 759814 [details]
File: program.log

Comment 10 Alexey Torkhov 2013-06-11 20:00:00 UTC
Created attachment 759815 [details]
File: storage.log

Comment 11 Alexey Torkhov 2013-06-11 20:01:59 UTC
Description of problem:
Tried install F19 with custom partitioning.

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:UUID=c91d471e-7d4b-444f-8f66-a8904f1ada07 rootfstype=ext4 rw rd.live.image overlay=UUID=c91d471e-7d4b-444f-8f66-a8904f1ada07 quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.14-1.fc19.noarch
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 451, in execute
    msg = _("Creating %(type)s on %(device)s") % {"type": self.device.format.type, "device": self.device.path}
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Comment 12 Adam Williamson 2013-06-24 16:42:53 UTC
*** Bug 976576 has been marked as a duplicate of this bug. ***

Comment 13 Adam Williamson 2013-06-24 16:43:29 UTC
*** Bug 976630 has been marked as a duplicate of this bug. ***

Comment 14 Adam Williamson 2013-06-24 16:54:46 UTC
Proposing as a final blocker: this affects a fresh install with a blank disk in auto-detected Czech, apparently. kparal will add a more detailed comment soon.

Comment 15 Kamil Páral 2013-06-24 17:04:13 UTC
I can reproduce this reliably with F19 TC6 Live (not DVD!) x86_64. You just need to run the installer, pick Czech as a language and let the installer auto-create the layout (I used a completely new, blank, freshly created disk in a VM). Anaconda crashes during device creation.

Comment 16 Adam Williamson 2013-06-24 17:23:30 UTC
Discussed at 2013-06-24 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-24/f19final-blocker-review-8.2013-06-24-16.00.log.txt . Accepted as a blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (in the case of apparently several non-English languages).

Comment 17 Adam Williamson 2013-06-24 20:07:31 UTC
For the record I can re-create this as described by Kamil in c#15.

We have a fix for this and 973019 currently in the works and a live image will shortly be available for testing; I'm going to check if it fixes it for me.

Comment 18 Adam Williamson 2013-06-24 20:10:19 UTC
http://adamwill.fedorapeople.org/20130624-desktop-x86_64.iso ought to fix this (we hope). It seems to for me: I can reproduce the bug as described in c#15 with TC6, I can no longer reproduce it following the same procedure with this image. Please, if as many people as possible can confirm, that'd be great.

Comment 19 Fedora Update System 2013-06-24 20:10:51 UTC
pyparted-3.9-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pyparted-3.9-3.fc19

Comment 20 Kamil Páral 2013-06-25 05:38:20 UTC
Verified fixed with RC1.

Comment 21 Fedora Update System 2013-06-26 04:28:17 UTC
pyparted-3.9-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.