Bug 968157 - packages shown as zero size
packages shown as zero size
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hawkey (Show other bugs)
19
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 973319 (view as bug list)
Depends On:
Blocks: 871892
  Show dependency treegraph
 
Reported: 2013-05-29 02:49 EDT by Rahul Sundaram
Modified: 2013-06-26 02:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: hawkey-0.3.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 02:36:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2013-05-29 02:49:19 EDT
Description of problem:


I downloaded the F19 version of dnf (and dependencies) from koji and tried to install them together on my f18 system and repository is shown as @system and size as zero.  This seems to happen only when multiple local packages are installed together. 

dnf install ./dnf-0.3.6-1.git24ce938.fc19.noarch.rpm ./hawkey-0.3.13-2.git15db39f.fc19.x86_64.rpm ./python-hawkey-0.3.13-2.git15db39f.fc19.x86_64.rpm 
Setting up Install Process
Resolving Dependencies
--> Starting dependency resolution
---> Package dnf.noarch 0.3.5-1.git85c924f.fc20 will be upgraded
---> Package dnf.noarch 0.3.6-1.git24ce938.fc19 will be an upgrade
---> Package hawkey.x86_64 0.3.12-1.git60cc1cc.fc20 will be upgraded
---> Package hawkey.x86_64 0.3.13-2.git15db39f.fc19 will be an upgrade
---> Package python-hawkey.x86_64 0.3.12-1.git60cc1cc.fc20 will be upgraded
---> Package python-hawkey.x86_64 0.3.13-2.git15db39f.fc19 will be an upgrade
--> Finished dependency resolution

Dependencies Resolved

================================================================================
 Package           Arch       Version                         Repository   Size
================================================================================
Upgrading:
 dnf               noarch     0.3.5-1.git85c924f.fc20         @System       0  
 hawkey            x86_64     0.3.12-1.git60cc1cc.fc20        @System       0  
 python-hawkey     x86_64     0.3.12-1.git60cc1cc.fc20        @System       0  

Transaction Summary
================================================================================
Upgrade  3 Packages

Total size: 514 k
Is this ok [y/N]:
Comment 1 Ales Kozumplik 2013-05-29 03:20:05 EDT
the transaction overview table shows the package that are being upgraded, not the new ones. And because hawkey currently won't tell us the size of installed packages, they're 0.
Comment 2 Panu Matilainen 2013-05-30 02:23:11 EDT
(In reply to Ales Kozumplik from comment #1)
> the transaction overview table shows the package that are being upgraded,
> not the new ones. 

Hmm, why? For one, this differs from yum which shows the "target version" and that is what I'd think people are more interested in wrt the summary.

> And because hawkey currently won't tell us the size of
> installed packages, they're 0.

The size of installed packages isn't particularly interesting anyway, at least in this context.
Comment 3 Pavel Lisý 2013-05-30 02:48:18 EDT
I can confirm this behaviour and I think it is bug. When I run 
dnf update 
it shows new release on installed packages but old (actually installed) version on packages which should be upgraded. 

It doesn't make sense, it is really confusing

Example:

# dnf update
RPM Fusion for Fedora 19 - Nonfree - Test Updates        | 4.4 kB     00:00     
RPM Fusion for Fedora 19 - Free - Test Updates           | 5.0 kB     00:00     
Fedora 19 - x86_64 - Test Updates                        |  18 MB     00:11     
RPM Fusion for Fedora 19 - Free - Updates                |  399 B     00:00     
Adobe Systems Incorporated                               | 1.8 kB     00:00     
RPM Fusion for Fedora 19 - Nonfree - Updates             |  399 B     00:00     
RPM Fusion for Fedora 19 - Free                          | 503 kB     00:00     
RPM Fusion for Fedora 19 - Nonfree                       | 381 kB     00:00     
Příprava průběhu upgrade
Řešení závislostí...
--> Starting dependency resolution
...
Závislosti vyřešeny.

================================================================================
 Package                    Arch   Verze                  Repozitář        Vel.
================================================================================
Instalování:
 libodfgen                  x86_64 0.0.2-1.fc19           updates-testing 107 k
 libmwaw                    x86_64 0.1.8-1.fc19           updates-testing 1.1 M
Upgrading:
 ModemManager               x86_64 0.6.0.0-3.fc19         @System           0  
 argyllcms                  x86_64 1.4.0-9.fc19           @System           0  
 autocorr-cs                noarch 1:4.0.3.3-3.fc19       @System           0  
 autocorr-en                noarch 1:4.0.3.3-3.fc19       @System           0  
 dnf                        noarch 0.3.6-1.git24ce938.fc19
                                                          @System           0  
...
Shrnutí transakce
================================================================================
Instalovat    2 
Aktualizace  65 Balíček

Celková velikost ke stahování: 181 M
V pořádku [a/N]: y
Stahování balíčků:
(1/67): libodfgen-0.0.2-1.fc19.x86_64.rpm                | 107 kB     00:00     
(2/67): libmwaw-0.1.8-1.fc19.x86_64.rpm                  | 1.1 MB     00:00     
(3/67): ModemManager-0.6.0.0-4.git20130528.fc19.x86_64.r | 325 kB     00:00     
(4/67): argyllcms-1.5.1-1.fc19.x86_64.rpm                | 1.3 MB     00:00     
(5/67): autocorr-cs-4.1.0.0-2.beta1.fc19.noarch.rpm      | 132 kB     00:00     
(6/67): autocorr-en-4.1.0.0-2.beta1.fc19.noarch.rpm      | 149 kB     00:00     
(7/67): dnf-0.3.7-1.gitf8bdc98.fc19.noarch.rpm           | 422 kB     00:00     
...

Hotovo!
Comment 4 Ales Kozumplik 2013-05-30 04:01:37 EDT
(In reply to Panu Matilainen from comment #2)
> Hmm, why? For one, this differs from yum which shows the "target version"
> and that is what I'd think people are more interested in wrt the summary.

Because I didn't notice it's what yum does:) The fix is going to be simple and we'll also get the sizes shown right.
Comment 5 Panu Matilainen 2013-06-12 03:46:43 EDT
*** Bug 973319 has been marked as a duplicate of this bug. ***
Comment 6 Igor Gnatenko 2013-06-25 08:51:29 EDT
*** Bug 977753 has been marked as a duplicate of this bug. ***
Comment 7 Ales Kozumplik 2013-06-26 02:36:06 EDT
With dnf-0.3.8 the sizes are shown right in the overview table. Panu's e9911ea has fixed this, closing.

Note You need to log in before you can comment on or make changes to this bug.