Bug 977753 - Repository "@System" instead of "fedora"
Repository "@System" instead of "fedora"
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
: Reopened
: 989116 (view as bug list)
Depends On:
Blocks: 871892
  Show dependency treegraph
Reported: 2013-06-25 05:20 EDT by Miroslav Suchý
Modified: 2014-09-30 19:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-0.3.11-1.git7d717c7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-16 19:05:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2013-06-25 05:20:08 EDT
Description of problem:
When I run "yum upgrade I will get this output:
 Package                                       Arch                     Version                            Repository                        Size
 PackageKit                                    x86_64                   0.8.9-5.fc19                       fedora                           643 k
 PackageKit-device-rebind                      x86_64                   0.8.9-5.fc19                       fedora                            48 k
 PackageKit-gstreamer-plugin                   x86_64                   0.8.9-5.fc19                       fedora                            48 k
 PackageKit-yum-plugin                         x86_64                   0.8.9-5.fc19                       fedora                            44 k
 anaconda                                      x86_64                   19.30.9-1.fc19                     fedora                           2.0 M
 fedora-logos                                  noarch                   19.0.4-2.fc19                      fedora                           8.7 M
 fedora-release                                noarch                   19-2                               fedora                            32 k
 ffmpeg                                        x86_64                   1.2.1-3.fc19                       rpmfusion-free                   413 k
 ffmpeg-libs                                   x86_64                   1.2.1-3.fc19                       rpmfusion-free                   3.7 M
 glib2                                         x86_64                   2.36.3-2.fc19                      fedora                           2.1 M
 glib2-devel                                   x86_64                   2.36.3-2.fc19                      fedora                           436 k
 grub2                                         x86_64                   1:2.00-22.fc19                     fedora                           1.3 M
 mozjs17                                       i686                     17.0.0-7.fc19                      fedora                           1.4 M
 mozjs17                                       x86_64                   17.0.0-7.fc19                      fedora                           1.3 M
 selinux-policy                                noarch                   3.12.1-54.fc19                     fedora                           266 k
 selinux-policy-devel                          noarch                   3.12.1-54.fc19                     fedora                           2.5 M
 selinux-policy-doc                            noarch                   3.12.1-54.fc19                     fedora                           759 k
 selinux-policy-targeted                       noarch                   3.12.1-54.fc19                     fedora                           4.0 M
Installing for dependencies:
 policycoreutils-devel                         x86_64                   2.1.14-45.fc19                     fedora                           235 k
Updating for dependencies:
 PackageKit-glib                               x86_64                   0.8.9-5.fc19                       fedora                           160 k
 PackageKit-yum                                x86_64                   0.8.9-5.fc19                       fedora                           114 k
 anaconda-widgets                              x86_64                   19.30.9-1.fc19                     fedora                           673 k
 glib2                                         i686                     2.36.3-2.fc19                      fedora                           2.1 M
 grub2-tools                                   x86_64                   1:2.00-22.fc19                     fedora                           2.5 M

Transaction Summary
Install              ( 1 Dependent package)
Upgrade  18 Packages (+5 Dependent packages)

But when I run "dnf upgrade" I see this output:
Dependencies Resolved

 Package                                         Arch                       Version                             Repository                   Size
 policycoreutils-devel                           x86_64                     2.1.14-45.fc19                      fedora                      235 k
 PackageKit                                      x86_64                     0.8.9-4.fc19                        @System                     2.9 M
 PackageKit-glib                                 x86_64                     0.8.9-4.fc19                        @System                     482 k
 PackageKit-yum-plugin                           x86_64                     0.8.9-4.fc19                        @System                     3.9 k
 PackageKit-yum                                  x86_64                     0.8.9-4.fc19                        @System                     306 k
 PackageKit-gstreamer-plugin                     x86_64                     0.8.9-4.fc19                        @System                      16 k
 PackageKit-device-rebind                        x86_64                     0.8.9-4.fc19                        @System                      16 k
 anaconda                                        x86_64                     19.30.8-1.fc19                      @System                     7.6 M
 anaconda-widgets                                x86_64                     19.30.8-1.fc19                      @System                     669 k
 fedora-logos                                    noarch                     19.0.4-1.fc19                       @System                     8.8 M
 fedora-release                                  noarch                     19-0.5                              @System                      29 k
 ffmpeg                                          x86_64                     1.2.1-1.fc19                        @System                     867 k
 ffmpeg-libs                                     x86_64                     1.2.1-1.fc19                        @System                     9.0 M
 glib2                                           x86_64                     2.36.3-1.fc19                       @System                     9.7 M
 glib2                                           i686                       2.36.3-1.fc19                       @System                     9.8 M
 glib2-devel                                     x86_64                     2.36.3-1.fc19                       @System                     2.4 M
 grub2                                           x86_64                     1:2.00-20.fc19                      @System                     6.0 M
 grub2-tools                                     x86_64                     1:2.00-20.fc19                      @System                      13 M
 mozjs17                                         x86_64                     17.0.0-6.fc19                       @System                     3.8 M
 mozjs17                                         i686                       17.0.0-6.fc19                       @System                     3.8 M
 selinux-policy                                  noarch                     3.12.1-52.fc19                      @System                      62  
 selinux-policy-targeted                         noarch                     3.12.1-52.fc19                      @System                      18 M
 selinux-policy-doc                              noarch                     3.12.1-52.fc19                      @System                      23 M
 selinux-policy-devel                            noarch                     3.12.1-52.fc19                      @System                      12 M

Transaction Summary
Install   1 Package
Upgrade  23 Packages

Note the difference in "Repository" column when yum correctly use name "fedora", while dnf use "@System".

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. yum upgrade
2. dnf upgrade
3. compare column 'Repository'
Comment 1 Igor Gnatenko 2013-06-25 05:27:31 EDT
I can confirm this.
Comment 2 Igor Gnatenko 2013-06-25 06:27:06 EDT
I pulled request to Ales git with patch.
If you need test:
There it's possible download rpm with patch.
$ sudo dnf install thunar
Setting up Install Process
Resolving Dependencies
--> Starting dependency resolution
---> Package Thunar.x86_64 1.6.3-1.fc19 will be installed
---> Package libxfce4ui.x86_64 4.10.0-5.fc19 will be installed
---> Package xfconf.x86_64 4.10.0-4.fc19 will be installed
---> Package libxfce4util.x86_64 4.10.1-1.fc19 will be installed
---> Package xfce4-panel.x86_64 4.10.1-1.fc19 will be installed
---> Package libwnck.x86_64 2.30.7-5.fc19 will be installed
---> Package exo.x86_64 0.10.2-4.fc19 will be installed
---> Package garcon.x86_64 0.2.1-1.fc19 will be installed
--> Finished dependency resolution

Dependencies Resolved

 Package           Arch        Version               Repository            Size
 Thunar            x86_64      1.6.3-1.fc19          updates-testing      1.2 M
 libxfce4ui        x86_64      4.10.0-5.fc19         fedora               139 k
 xfconf            x86_64      4.10.0-4.fc19         fedora               180 k
 libxfce4util      x86_64      4.10.1-1.fc19         updates-testing      135 k
 xfce4-panel       x86_64      4.10.1-1.fc19         updates-testing      729 k
 libwnck           x86_64      2.30.7-5.fc19         fedora               357 k
 exo               x86_64      0.10.2-4.fc19         updates-testing      519 k
 garcon            x86_64      0.2.1-1.fc19          updates-testing      147 k

Transaction Summary
Install  8 Packages

Total download size: 3.4 M
Installed size: 3.4 M
Is this ok [y/N]:
Comment 3 Igor Gnatenko 2013-06-25 07:09:43 EDT
In previous pull request I'm wrong..
See this:
Can you test it ?
Comment 4 Miroslav Suchý 2013-06-25 07:17:36 EDT
I tested your fix and it behave correctly.
Comment 5 Miroslav Suchý 2013-06-25 07:22:13 EDT
Err, I'm stupido. I tested yum upgrade :)

Nope, your fix did not fix it. With patch applied - dnf upgrade say:

Dependencies Resolved

 Package                                       Arch             Version                                           Repository                 Size
 aether-connector-wagon                        noarch           1.13.1-10.fc19                                    updates-testing            37 k
 aether-util                                   noarch           1.13.1-10.fc19                                    updates-testing           121 k
 aether-test-util                              noarch           1.13.1-10.fc19                                    updates-testing            77 k
 aether-api                                    noarch           1.13.1-10.fc19                                    updates-testing            84 k
 aether-connector-file                         noarch           1.13.1-10.fc19                                    updates-testing            31 k
 aether-impl                                   noarch           1.13.1-10.fc19                                    updates-testing           126 k
 aether-spi                                    noarch           1.13.1-10.fc19                                    updates-testing            22 k
 kernel                                        x86_64           3.9.6-301.fc19                                    updates-testing            29 M
 kernel-devel                                  x86_64           3.9.6-301.fc19                                    updates-testing           8.1 M
 texlive-babel-english                         noarch           3:svn30264.0-0.1.fc19                             updates-testing            18 k
 PackageKit                                    x86_64           0.8.9-5.fc19                                      @System                   2.9 M
 PackageKit-glib                               x86_64           0.8.9-5.fc19                                      @System                   482 k
 PackageKit-yum-plugin                         x86_64           0.8.9-5.fc19                                      @System                   3.9 k
 PackageKit-yum                                x86_64           0.8.9-5.fc19                                      @System                   306 k
 PackageKit-gstreamer-plugin                   x86_64           0.8.9-5.fc19                                      @System                    16 k
 PackageKit-device-rebind                      x86_64           0.8.9-5.fc19                                      @System                    16 k
 SDL                                           x86_64           1.2.15-8.fc19                                     @System                   461 k
 SDL-devel                                     x86_64           1.2.15-8.fc19                                     @System                   1.5 M
Comment 6 Igor Gnatenko 2013-06-25 07:46:16 EDT
@Miroslav, yes. I will try to write additional patch for fixing it.
Comment 7 Igor Gnatenko 2013-06-25 07:58:31 EDT
output.py shows info from installed repository
 libreoffice-core               x86_64 1:   updates-testing  80 M
 libreoffice-core                x86_64  1:  @System  229 M
Comment 8 Panu Matilainen 2013-06-25 08:05:25 EDT
Yup, see https://bugzilla.redhat.com/show_bug.cgi?id=968157#c4
Comment 9 Igor Gnatenko 2013-06-25 08:51:29 EDT

*** This bug has been marked as a duplicate of bug 968157 ***
Comment 10 Ales Kozumplik 2013-06-26 02:29:50 EDT
This is not a dupe, bug 968157 mentions this current issue but pertains to something else.
Comment 11 Ales Kozumplik 2013-07-29 02:18:58 EDT
*** Bug 989116 has been marked as a duplicate of this bug. ***
Comment 12 Ales Kozumplik 2013-07-29 06:34:42 EDT
Fixed by aaa91aa, the fix will be included in dnf-0.3.11.
Comment 13 Fedora Update System 2013-08-13 06:47:22 EDT
dnf-0.3.11-1.git7d717c7.fc19 has been submitted as an update for Fedora 19.
Comment 14 Fedora Update System 2013-08-14 22:33:48 EDT
Package dnf-0.3.11-1.git7d717c7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.3.11-1.git7d717c7.fc19'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-08-16 19:05:42 EDT
dnf-0.3.11-1.git7d717c7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.