Bug 970025 - Dependency can not be resolved
Summary: Dependency can not be resolved
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ycssmin (Show other bugs)
(Show other bugs)
Version: el6
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: T.C. Hollingsworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 968776
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-03 11:00 UTC by Matthias Runge
Modified: 2013-07-05 21:32 UTC (History)
4 users (show)

Fixed In Version: ycssmin-1.0.1-4.el6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 21:32:11 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Runge 2013-06-03 11:00:47 UTC
Error: Package: nodejs-less-1.3.3-4.el6.noarch (epel)
           Requires: npm(ycssmin) >= 1.0.1
Error: Package: nodejs-less-1.3.3-4.el6.noarch (epel)
           Requires: npm(ycssmin) < 1.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The older version 
nodejs-less-1.3.3-3.el6.noarch
works fine.

Comment 1 T.C. Hollingsworth 2013-06-03 11:11:03 UTC
ycssmin-1.0.1-3.el6 is missing the "npm(ycssmin)" virtual provides:
https://koji.fedoraproject.org/koji/rpminfo?rpmID=3982698

This happened with another module too (bug 968531).  Looks like there might have been something wrong with the buildroot around the time these packages were built.

I'll rebuild ycssmin later today (writing in via smartphone right now ;-) to fix the issue.

Comment 2 T.C. Hollingsworth 2013-06-03 11:12:55 UTC
Wait, I forgot I gave you and sgallagh ACLs on ycssmin too.  You can just rebuild it yourself if you need it fixed in a hurry, just a straight bump-release-and-rebuild should be all that is necessary.

Comment 3 Matthias Runge 2013-06-03 11:32:32 UTC
will do! Thank you for the quick hint. I just opened the ticket to investigate and get it fixed :-)

Comment 4 Fedora Update System 2013-06-03 11:38:30 UTC
ycssmin-1.0.1-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ycssmin-1.0.1-4.el6

Comment 5 Fedora Update System 2013-06-03 19:31:13 UTC
Package ycssmin-1.0.1-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ycssmin-1.0.1-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-6072/ycssmin-1.0.1-4.el6
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-06-18 21:19:06 UTC
ycssmin-1.0.1-4.el6.1 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ycssmin-1.0.1-4.el6.1

Comment 7 Fedora Update System 2013-07-05 21:32:11 UTC
ycssmin-1.0.1-4.el6.1 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.