Bug 970493 - group pages are inconsistent
Summary: group pages are inconsistent
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
(Show other bugs)
Version: develop
Hardware: Unspecified Unspecified
unspecified
unspecified vote
Target Milestone: 0.13
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords:
: 838401 965388 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-04 07:18 UTC by Dan Callaghan
Modified: 2018-02-06 00:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 06:26:32 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Callaghan 2013-06-04 07:18:16 UTC
Currently we have three different pages that list groups:

/groups/
/groups/admin
/groups/mine

but none of them are consistent with each other. /groups/admin and /groups/mine both show a search box and alpha nav, but the search POSTs to /groups/admin which normal users cannot access. /groups/ doesn't have a search at all, which is where it would be needed most.

Similarly, there are two separate pages showing group info:

/groups/edit
/groups/group_members

Which one Beaker links to depends on whether you are logged in or not, and whether you have permission to edit the group (except there is some code which unconditionally links to /groups/group_members). /groups/group_members doesn't display other data about a group, like permissions or system members, even though it is useful for non-owners to be able to view that data as well.

We should rationalise all of these to three pages:

/groups/
/groups/mine
/groups/edit

To be consistent with other parts of the UI, the /groups/ and /groups/mine pages should behave the same as each other except that /groups/mine should be filtered to groups which the user is a member of. They should both have search bars which POST back to ''. The /groups/edit page will really be "view or edit" in the sense that it will show the same data, but with extra UI visible depending on what the user is allowed to modify.

Comment 1 Dan Callaghan 2013-06-04 12:23:27 UTC
On Gerrit: http://gerrit.beaker-project.org/2015

Comment 2 Dan Callaghan 2013-06-05 05:49:02 UTC
*** Bug 965388 has been marked as a duplicate of this bug. ***

Comment 5 xjia 2013-06-06 09:15:35 UTC
Verify on chrome 27.0.1453.94 :
Pass

Comment 7 Amit Saha 2013-06-25 06:26:32 UTC
Beaker 0.13.1 has been released.

Comment 8 Dan Callaghan 2013-06-25 23:08:17 UTC
*** Bug 838401 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.