Bug 971653 - LibreOffice Crash SegFault F19 x86_64
LibreOffice Crash SegFault F19 x86_64
Status: CLOSED DUPLICATE of bug 971795
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 01:28 EDT by Álvaro Castillo
Modified: 2013-06-07 08:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 03:49:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Álvaro Castillo 2013-06-07 01:28:10 EDT
Description of problem:

Latest update of LibreOffice Office suite free software produced a segfault.


Version-Release number of selected component (if applicable):

libreoffice-opensymbol-fonts-4.1.0.0-6.beta1.fc19.noarch
libreoffice-langpack-es-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-base-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-calc-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-core-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-math-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-emailmerge-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-ure-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-pyuno-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-writer-4.1.0.0-6.beta1.fc19.x86_64
libreoffice-impress-4.1.0.0-6.beta1.fc19.x86_64

Steps to Reproduce:
1. Upgrade your system
2. Launch LibreOffice
3. See dmesg

Additional info:

[41351.597663] soffice.bin[10272]: segfault at 0 ip           (null) sp 00007fffb9419138 error 14 in soffice.bin[400000+1000]
[41416.318895] soffice.bin[10296]: segfault at 0 ip           (null) sp 00007fffdaacf188 error 14 in soffice.bin[400000+1000]
[41424.370100] soffice.bin[10377]: segfault at 0 ip           (null) sp 00007ffff2cc6028 error 14 in soffice.bin[400000+1000]
Comment 1 Álvaro Castillo 2013-06-07 01:54:11 EDT
Does not work downgrade.

libreoffice-ure-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-base-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-calc-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-opensymbol-fonts-4.1.0.0-2.beta1.fc19.noarch
libreoffice-math-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-emailmerge-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-core-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-impress-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-pyuno-4.1.0.0-2.beta1.fc19.x86_64
libreoffice-writer-4.1.0.0-2.beta1.fc19.x86_64

Differences between its.

Downgrade version has got message:

$ libreoffice 
/usr/lib64/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib64/libreoffice/program/libvcllo.so: undefined symbol: hb_icu_script_to_script
Comment 2 oliver 2013-06-07 03:41:11 EDT
For me, 4.1.0.0-6.beta1 also fails with "undefined symbol: hb_icu_script_to_script".  This problem has been discussed on the Debian bug tracker:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709973
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709926
Comment 3 David Tardon 2013-06-07 03:49:32 EDT

*** This bug has been marked as a duplicate of bug 971566 ***
Comment 4 David Tardon 2013-06-07 08:24:30 EDT

*** This bug has been marked as a duplicate of bug 971795 ***

Note You need to log in before you can comment on or make changes to this bug.