Bug 971566 - after update to 4.1.0.0-6.beta1.fc19.i686 LibreOffice stopped working.
after update to 4.1.0.0-6.beta1.fc19.i686 LibreOffice stopped working.
Status: CLOSED DUPLICATE of bug 971795
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 16:14 EDT by Mikhail
Modified: 2013-06-08 14:32 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 03:21:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2013-06-06 16:14:07 EDT
Description of problem:
Today after update to 4.1.0.0-6.beta1.fc19.i686 LibreOffice stopped working.


$ /usr/bin/libreoffice 
/usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib/libreoffice/program/libvcllo.so: undefined symbol: hb_icu_script_to_script
Comment 1 Konrad Paumann 2013-06-06 17:08:08 EDT
I can confirm this bug.
Comment 2 Thorsten Leemhuis 2013-06-07 02:45:53 EDT
Saw this, too. Downgraded to this harfbuzz-release made it work again:
http://koji.fedoraproject.org/koji/buildinfo?buildID=420523

Might be related: 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709973
Comment 3 Parag Nemade 2013-06-07 03:14:53 EDT
When new libreoffice package be built against new harfbuzz-0.9.18, this bug will get resolved.

$ nm libharfbuzz.so.0.917.0 | grep script_to_script
000000000003cc90 T hb_glib_script_to_script
000000000003d300 T hb_icu_script_to_script

$ nm libharfbuzz.so.0.918.0 | grep script_to_script
00000000000383f0 T hb_glib_script_to_script
Comment 4 David Tardon 2013-06-07 03:21:11 EDT
I will do another build today, with updated build dependency.

*** This bug has been marked as a duplicate of bug 971230 ***
Comment 5 Nivag 2013-06-07 03:38:39 EDT
did a yum update, which included upgrades to LibreOffice, now LO seg faults at start up, I tried 3 times clicking on a menu item!

from /var/log/messages:
Jun  7 10:10:50 localhost kernel: [  620.157379] soffice.bin[1557]: segfault at 0 ip           (null) sp 00007fffb28368d8 error 14 in soffice.bin[400000+1000]
Jun  7 10:11:04 localhost kernel: [  634.017946] soffice.bin[1577]: segfault at 0 ip           (null) sp 00007ffffeb20d18 error 14 in soffice.bin[400000+1000]
Jun  7 19:20:37 localhost kernel: [33607.308536] soffice.bin[3443]: segfault at 0 ip           (null) sp 00007fffef79cea8 error 14 in soffice.bin[400000+1000]

Linux localhost.localdomain 3.9.4-301.fc19.x86_64 #1 SMP Tue Jun 4 00:30:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Intel core 7 64 bit quad core in a laptop

from yum.log
Jun 07 09:59:06 Updated: harfbuzz-0.9.18-1.fc19.x86_64
Jun 07 09:59:19 Updated: 1:libreoffice-core-4.1.0.0-6.beta1.fc19.x86_64

The splash screen shows up for about a second, and then disappears.

after I did 
yum downgrade harfbuzz
LibreOffice came up okay.
Comment 6 David Tardon 2013-06-07 03:49:32 EDT
*** Bug 971653 has been marked as a duplicate of this bug. ***
Comment 7 David Tardon 2013-06-07 08:22:55 EDT

*** This bug has been marked as a duplicate of bug 971795 ***
Comment 8 Constantin Dunayev 2013-06-08 14:32:56 EDT
libreoffice-4.1.0.0-7.beta2.fc19, harfbuzz-0.9.18-2.fc19 works ok, maybe fixed

Note You need to log in before you can comment on or make changes to this bug.