Bug 971795 - Handling the harfbuzz / harfbuzz-icu split
Handling the harfbuzz / harfbuzz-icu split
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: harfbuzz (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
: 971566 971653 971703 971829 971922 972221 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 05:51 EDT by Kalev Lember
Modified: 2013-06-08 23:33 EDT (History)
13 users (show)

See Also:
Fixed In Version: harfbuzz-0.9.18-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 23:33:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kalev Lember 2013-06-07 05:51:47 EDT
I have two suggestions for the harfbuzz / harfbuzz-icu split.

1) Don't do separate -devel packages, only library packages

It's uncommon in Fedora to have multiple -devel subpackages. In most packages
that split up shared libraries into separate subpackages, all the headers still
go in a single -devel package.

This would simplify packaging in both harfbuzz and consumers.

(It's fine to keep it split up as well if there's a reason for that, just
wanted to point out that it's an uncommon thing to do.)

2) 'undefined symbol: hb_icu_script_to_script' issues

It's an ABI break and needs some care to avoid breaking user systems. Before submitting the harfbuzz 0.9.18 update again, all the consumers should be rebuilt with the new harfbuzz (most will need patching) and submit them as a
single Bodhi ticket, together with the harfbuzz 0.9.18 build.

So far I know of libreoffice and webkitgtk3, but there are probably more.
Comment 1 Parag Nemade 2013-06-07 06:08:14 EDT
Does this looks good update for harfbuzz?
http://paragn.fedorapeople.org/harfbuzz/harfbuzz.spec
Comment 2 Kalev Lember 2013-06-07 06:15:43 EDT
Almost! The ldconfig calls are still needed:

%post icu -p /sbin/ldconfig
%postun icu -p /sbin/ldconfig

And -devel should require the -icu subpackage:
Requires:       %{name}-icu%{?_isa} = %{version}-%{release}
Comment 3 Parag Nemade 2013-06-07 06:24:34 EDT
Ah! right. Fixed again in same spec. I think libreoffice build is going on with BR:harfbuzz-icu-devel
Comment 4 Kalev Lember 2013-06-07 06:30:01 EDT
Looks good to me.
Comment 5 David Tardon 2013-06-07 06:33:55 EDT
(In reply to Parag from comment #3)
> Ah! right. Fixed again in same spec. I think libreoffice build is going on
> with BR:harfbuzz-icu-devel

Yes, it is. I will change it back and close the other bug.
Comment 6 David Tardon 2013-06-07 08:22:55 EDT
*** Bug 971566 has been marked as a duplicate of this bug. ***
Comment 7 David Tardon 2013-06-07 08:23:36 EDT
*** Bug 971703 has been marked as a duplicate of this bug. ***
Comment 8 David Tardon 2013-06-07 08:24:30 EDT
*** Bug 971653 has been marked as a duplicate of this bug. ***
Comment 9 David Tardon 2013-06-07 08:25:01 EDT
*** Bug 971829 has been marked as a duplicate of this bug. ***
Comment 10 Parag Nemade 2013-06-07 08:31:06 EDT
I have built new harfbuzz-0.9.18-2 in f19 and f20. Build is only available on koji for f19. Not pushed yet to testing. Any idea when should I push this build to f19? Guess after all other packages are rebuilt against harfbuzz-0.9.18-1.fc19?
Comment 11 Kalev Lember 2013-06-07 09:00:25 EDT
Yes, wait with the update and let's submit all the builds in a single Bodhi ticket (I can do that, I have commit access to all the packages here).

Can you do a buildroot override with the new harfbuzz build, and I'll then rebuild webkitgtk?
Comment 12 Parag Nemade 2013-06-07 09:12:05 EDT
koji wait-repo f19-build --build=harfbuzz-0.9.18-2.fc19
Comment 13 David Tardon 2013-06-07 10:24:31 EDT
new libreoffice is built as libreoffice-4.1.0.0-7.beta2.fc19
Comment 14 Parag Nemade 2013-06-07 10:32:08 EDT
Thanks dtardon for this build. Also, you can change to BR:harfbuzz-devel back in libreoffice.spec file.
Comment 15 Parag Nemade 2013-06-07 10:34:48 EDT
I see $ chromium-browser 
/usr/lib64/chromium-browser/chromium-browser: symbol lookup error: /usr/lib64/chromium-browser/chromium-browser: undefined symbol: hb_icu_get_unicode_funcs

I have sent email to spot for rebuilding new chromium package.
Comment 16 David Tardon 2013-06-07 11:23:28 EDT
*** Bug 971922 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2013-06-07 12:50:24 EDT
harfbuzz-0.9.18-2.fc19,libreoffice-4.1.0.0-7.beta2.fc19,webkitgtk-2.0.2-2.fc19,webkitgtk3-2.0.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/harfbuzz-0.9.18-2.fc19,libreoffice-4.1.0.0-7.beta2.fc19,webkitgtk-2.0.2-2.fc19,webkitgtk3-2.0.2-3.fc19
Comment 18 Fedora Update System 2013-06-07 22:58:12 EDT
Package harfbuzz-0.9.18-2.fc19, libreoffice-4.1.0.0-7.beta2.fc19, webkitgtk-2.0.2-2.fc19, webkitgtk3-2.0.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing harfbuzz-0.9.18-2.fc19 libreoffice-4.1.0.0-7.beta2.fc19 webkitgtk-2.0.2-2.fc19 webkitgtk3-2.0.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10363/harfbuzz-0.9.18-2.fc19,libreoffice-4.1.0.0-7.beta2.fc19,webkitgtk-2.0.2-2.fc19,webkitgtk3-2.0.2-3.fc19
then log in and leave karma (feedback).
Comment 19 David Tardon 2013-06-08 02:14:32 EDT
*** Bug 972221 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2013-06-08 23:33:21 EDT
harfbuzz-0.9.18-2.fc19, libreoffice-4.1.0.0-7.beta2.fc19, webkitgtk-2.0.2-2.fc19, webkitgtk3-2.0.2-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.