This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 981793 - RFE: "Hardware clock uses UTC" checkbox under the "Date & Time" spoke
RFE: "Hardware clock uses UTC" checkbox under the "Date & Time" spoke
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 16:32 EDT by Andre Robatino
Modified: 2013-07-26 16:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 14:22:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2013-07-05 16:32:27 EDT
Description of problem:
Currently anaconda sets the system clock to local time if Windows is detected, otherwise UTC. These are reasonable defaults, but there exists a registry hack to make Windows use UTC, in which case one wants Fedora to use UTC as well. It can be changed after the install, but there are a lot of things to configure afterwards, and if not done promptly, can lead to problems like bug 981617. This can be avoided by adding a "System clock uses UTC" checkbox under the "Date & Time" spoke so it's possible to set during installation (as was possible in oldUI).
Comment 1 Steve Tyler 2013-07-05 17:18:45 EDT
This was proposed in:
Bug 881403 - Anaconda doesn't correctly infer if system clock shows UTC or local time

But see:
Bug 881403, Comment 29
Bug 881403, Comment 30

NB: The clock in question is the hardware clock, not the system clock:
Bug 881403, Comment 33
Comment 2 Andre Robatino 2013-07-06 01:57:04 EDT
Thanks, I wasn't sure about the right terminology and copied what system-config-date said. I filed bug 981831 against s-c-d.
Comment 3 David Shea 2013-07-26 14:22:06 EDT
As was noted in bug 881403, the removal of the UTC checkbox was intentional, since it was found to be confusing for many users. The setting can be changed after the installation. It can be also set during installation through the use of a kickstart file, by adding or omitting the --utc parameter to the timezone command.
Comment 4 Andre Robatino 2013-07-26 15:30:25 EDT
It should be noted that partial kickstart files currently don't work (see bug 972265 and bug 972266) so it's currently not practical for the average kickstart-ignorant user (like me) to do this, unless they first do a scratch install to get a complete kickstart file for their hardware, then tweak it and reinstall. If they worked, one could just use a 1-line file. For the time being I'll have to use s-c-d followed by rebuilding the initramfs.
Comment 5 Steve Tyler 2013-07-26 16:03:24 EDT
The fact that the initramfs needs to be rebuilt is a bug, IMO. The relevant config file is /etc/adjtime and that is available in the actual file system, so there doesn't seem to be any reason to have a copy in the initramfs.
See Bug 981617, Comment 18.

It might be worth opening a bug against dracut for the problem of needing to rebuild the initramfs after the RTC time zone is changed.

Note You need to log in before you can comment on or make changes to this bug.