Bug 972338 - TrackerCrawler can crash due to invalid container pointers, and not staying alive across async calls
TrackerCrawler can crash due to invalid container pointers, and not staying a...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
abrt_hash:562c1022343b8c9672a4c46d9c1...
:
: 973850 990954 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 12:29 EDT by Mikhail
Modified: 2014-11-06 06:06 EST (History)
4 users (show)

See Also:
Fixed In Version: tracker-0.16.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-31 21:45:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.93 KB, text/plain)
2013-06-08 12:29 EDT, Mikhail
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-08 12:29 EDT, Mikhail
no flags Details
File: core_backtrace (1.02 KB, text/plain)
2013-06-08 12:29 EDT, Mikhail
no flags Details
File: dso_list (4.86 KB, text/plain)
2013-06-08 12:29 EDT, Mikhail
no flags Details
File: environ (1.55 KB, text/plain)
2013-06-08 12:29 EDT, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-08 12:29 EDT, Mikhail
no flags Details
File: maps (18.27 KB, text/plain)
2013-06-08 12:29 EDT, Mikhail
no flags Details
File: open_fds (646 bytes, text/plain)
2013-06-08 12:30 EDT, Mikhail
no flags Details
File: proc_pid_status (786 bytes, text/plain)
2013-06-08 12:30 EDT, Mikhail
no flags Details
File: var_log_messages (20.87 KB, text/plain)
2013-06-08 12:30 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 737768 None None None Never
GNOME Desktop 737769 None None None Never

  None (edit)
Description Mikhail 2013-06-08 12:29:37 EDT
Version-Release number of selected component:
tracker-0.16.1-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-miner-fs
crash_function: g_type_check_instance_is_a
executable:     /usr/libexec/tracker-miner-fs
kernel:         3.9.4-301.fc19.i686.PAE
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 g_type_check_instance_is_a at gtype.c:3999
 #1 g_file_get_child at gfile.c:722
 #2 file_enumerate_next_cb at tracker-crawler.c:736
 #3 next_async_callback_wrapper at gfileenumerator.c:297
 #4 g_task_return_now at gtask.c:1105
 #5 complete_in_idle_cb at gtask.c:1114

Potential duplicate: bug 817318
Comment 1 Mikhail 2013-06-08 12:29:41 EDT
Created attachment 758578 [details]
File: backtrace
Comment 2 Mikhail 2013-06-08 12:29:44 EDT
Created attachment 758579 [details]
File: cgroup
Comment 3 Mikhail 2013-06-08 12:29:47 EDT
Created attachment 758580 [details]
File: core_backtrace
Comment 4 Mikhail 2013-06-08 12:29:50 EDT
Created attachment 758581 [details]
File: dso_list
Comment 5 Mikhail 2013-06-08 12:29:53 EDT
Created attachment 758582 [details]
File: environ
Comment 6 Mikhail 2013-06-08 12:29:56 EDT
Created attachment 758583 [details]
File: limits
Comment 7 Mikhail 2013-06-08 12:29:59 EDT
Created attachment 758584 [details]
File: maps
Comment 8 Mikhail 2013-06-08 12:30:02 EDT
Created attachment 758585 [details]
File: open_fds
Comment 9 Mikhail 2013-06-08 12:30:05 EDT
Created attachment 758586 [details]
File: proc_pid_status
Comment 10 Mikhail 2013-06-08 12:30:09 EDT
Created attachment 758587 [details]
File: var_log_messages
Comment 11 Tom Arne Trovatn 2013-09-03 08:56:11 EDT
i think it was while moving a couple of thousand files from an ntfs system.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-miner-fs
crash_function: g_type_check_instance_is_a
executable:     /usr/libexec/tracker-miner-fs
kernel:         3.10.10-200.fc19.x86_64
package:        tracker-0.16.2-1.fc19
reason:         Process /usr/libexec/tracker-miner-fs was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 12 Fedora Admin XMLRPC Client 2014-07-26 13:11:08 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Fedora Admin XMLRPC Client 2014-07-27 02:33:03 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 14 Fedora Update System 2014-10-02 07:06:49 EDT
tracker-0.16.4-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/tracker-0.16.4-4.fc20
Comment 15 Fedora Update System 2014-10-02 23:59:23 EDT
Package tracker-0.16.4-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tracker-0.16.4-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11973/tracker-0.16.4-4.fc20
then log in and leave karma (feedback).
Comment 16 Debarshi Ray 2014-10-14 13:26:05 EDT
*** Bug 990954 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2014-10-16 13:10:35 EDT
tracker-0.16.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/tracker-0.16.5-1.fc20
Comment 18 Fedora Update System 2014-10-31 21:45:58 EDT
tracker-0.16.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Debarshi Ray 2014-11-06 06:06:46 EST
*** Bug 973850 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.